ASP.NET Controls - Introduction

APNSoft Controls [4.5.2.20]
Introduction

Welcome to the APNSoft Controls Suite.

APNSoft Controls Suite is a collection of ASP.NET controls that assists you in building feature-rich, stable web applications in the shortest possible time. The collection includes such essential components as Menu, DataGrid, TreeView, etc.

All of the controls are extremely easy to use. You do not need to learn a complex API to accomplish a task; use only a few lines of code to add a control to your web page. Each component has both a default style and an initial data structure in order to see the result immediately. No additional requirements to your web site layout and settings. No additional components and frameworks.

Also, we offer useful examples and free responsive technical support to our customers and those interested in evaluating our products.


ASP.NET Controls - Key Features

APNSoft Controls [4.5.2.20]
Key Features

Standards-Based software
  • Output is XHTML 1.1 compliant.
  • Ready for ASP.NET 2.0, 3.5, 4.0 & 4.5. Visual Studio 2005, 2008, 2010 & 2012.
  • Full Support for ASP.NET AJAX
  • Based on industry standards: XML and CSS.

Easy-to-Use Software
  • Simplicity. No complex API.
  • Uses the default style and data to see the result immediately.
  • Compact Documentation.
  • C# and VB.NET examples included.

Cross-Browser Support
  • APNSoft Controls Suite offers full up-level cross-browser support for IE 5.5+, Firefox 0.8+, Google Chrome 6.0+, Mozilla 1.4+, Netscape 7.0+, Opera 7.5+, and Safari 1.2+.

Highly Customizable Look
  • Colors, sizes, borders, fonts, etc. can be customized to visually integrate with any project.
  • The visual appearance is specified with CSS.
  • Support for Skins. Collection of free, ready-to-use skins.

Flexible Programming Options
  • Rich and powerful Server-side API.
  • Data binding support.
  • Support for client-side and server-side events.

Other Features
  • Multiple controls on a single page are allowed.
  • Support for Unicode characters.
  • Generated code is dramatically small.


ASP.NET Controls - What's New

APNSoft Controls [4.5.2.20]
What's New

09/17/2012 Controls Suite 4.5

  • All controls - Update

    • Added support for Microsoft's Visual Studio 2012 and .NET Framework 4.5.
    • Several minor bugs are fixed.

  • DataGrid control - Update

    • A new property, DataSourceID, gets or sets the ID of the control from which the DataGrid retrieves its list of data items.
    • A new method, SetPage(PageNumber), sets the current page number.

05/10/2012 Controls Suite 4.3

  • All controls - Update

    • Several minor bugs are fixed.

03/24/2012 Controls Suite 4.2

  • DataGrid control - Update

    • Cell editing with tabbing through editable cells-when the cell of the selected row is clicked, it is transformed into an Input Box for editing the value. To switch between cells, you can use the Tab Key (or Shift + Tab to go in reverse). Support for validation and auto-correction has also been added. A new property, ClientSideBeforeCellUpdate, specifies the client-side code (procedure) to be launched before Cell Update.
    • Support for Fixed (Summary) row-a user might be interested in aggregate information, such as the average price, the total number of units in stock, etc. Such summary information can be displayed in the fixed (frozen) row. Fixed rows remain visible at the bottom of the grid and do not scroll when the grid scrolls. To add summary information to the column, use the Summary property. A column also includes auxiliary aggregate methods: Sum(), Average(), Minimum() and Maximum().
    • A new client-side method, dg.SetCellValue(GridID, RowID, ColumnName, CellValue);, sets the value of the specified cell on the current page.
    • Updated Skins.

  • Menu control - Update

    • A new property, SubmenusHideOnItemClick, gets or sets a value indicating whether the submenus should automatically close when an Item is clicked.
    • A new property, SaveScrollPosition, gets or sets the value indicating whether the menu keeps the scroll position for submenus.

  • All controls - Update

    • Several minor bugs are fixed.
    • Code improvements for better performance results.

01/30/2012 Controls Suite 4.1

  • Rating control - New

    Controls Suite now includes new reach-featured ASP.NET server control which allows people to easily provide feedback on an article, blog item, product description, etc. In addition to this, the Rating control has an option to display a value by segment-oriented bar.

    Key features:

    • Ajax-enabled component.
    • Segment-oriented. Each segment has ID and value.
    • Based on images and CSS.
    • Each segment can be customized separately.
    • Support for templates.
    • Allows to set or display a value.

  • Menu control - Update

    • PNG shadows. A shadow based on PNG image supports transparency and looks identical in all browsers.
    • New properties SubMenuMarginLeft and SubMenuMarginTop. These properties specify the left and top margin of the submenu, so you can now specify the position of any single submenu separately.

  • ComboBox control - Update

    • PNG shadows. A shadow based on PNG image supports transparency and looks identical in all browsers.

  • All controls - Update

    • Compatibility with last popular browsers.
    • Several minor bugs are fixed.
    • Code improvements for better performance results.

10/17/2011 Controls Suite 4.0
    We are pleased to announce that APNSoft Controls Suite 4.0 is now available.

    All of our products (Menu, DataGrid, TreeView, etc.) were re-written from the ground up, significantly enhanced and now are combined into the single assembly APNSoftControls.dll which is much stable, more carefully controls system resources and gives additional reliability, compatibility and performance results. New features have been implemented too. Added support for .NET 4.0 and additional compatibility with all popular browsers.

10/04/2010 Menu 3.8
  • Compatibility with Internet Explorer 8 and Google Chrome
    APNSoft Menu now supports all popular browsers including Internet Explorer 8 and Google Chrome. Product is staffed with new skins which are fully optimized for these browsers. All previous browsers are supported too.
    New skins (ver. 1.4) can be downloaded from the Download Section. To see them in action open the section Live Demos.

  • Property HighlightedPathOpacity changed to HighlightedPathColor
    The HighlightedPathColor property is used to specify a color for the Highlighted Path. Opacity is not flexible and, therefore, cannot be used for advanced menu customization.

  • ASP.NET 1.1 is not supported anymore
    ASP.NET 1.1 is obsolete. New functionality can be added only by using features of ASP.NET 2.0 and above. It is important for performance, reliability, compatibility etc. Also, the statistics show that very few developers use ASP.NET 1.1. These circumstances force us to close support the ASP.NET 1.1 version. Please use Menu for ASP.NET 2.0 and above. Previous product versions will be available via support.

  • Fixed bugs

    • Fixed a bug with memory leaks in client-side script.
    • Several minor bugs are fixed.

  • Code improvements
    Now Menu more carefully controls system resources and gives the best performance results.

09/24/2010 DataGrid 3.2
  • Compatibility with Google Chrome
    APNSoft DataGrid now supports all popular browsers including Google Chrome.

  • New client-side methods

    • dg.FindSelectedRow(GridID); - finds the page where the selected row is located. Returns 'true' if the row was found, otherwise the function returns 'false'.
    • dg.ClearCache(GridID); - deletes the cached pages of Grid.

  • Updated client-side methods

    • dg.InsertRow(CloseEditForm); - adds a record to the Grid. The Edit Form is not closed automatically if the CloseEditForm=false.
    • dg.UpdateRow(CloseEditForm); - updates the current record. The Edit Form is not closed automatically if the CloseEditForm=false.

  • New properties
    The MessageLoading specifies a message to be displayed when component loads records. The MessageNoRecords specifies a message to be displayed when there are no records in the data source.

  • New method SetTemplateVariable
    This method is used to set a value for user-defined variable in the column template. Now column templates are more flexible. The program logic in templates can be changed by using external parameters.

  • ASP.NET 1.1 is not supported anymore
    ASP.NET 1.1 is obsolete. New functionality can be added only by using features of ASP.NET 2.0 and above. It is important for performance, reliability, compatibility etc. Also, the statistics show that very few developers use ASP.NET 1.1. These circumstances force us to close support the ASP.NET 1.1 version. Please use DataGrid for ASP.NET 2.0 and above. Previous product versions will be available via support.

  • Fixed bugs

    • Fixed a bug with memory leaks in client-side script.
    • The behavior of hovered row is fixed when new row is added.
    • Panel with DataGrid does not generate error in Visual Studio Design Mode.
    • Several minor bugs are fixed.

  • Code improvements
    Now DataGrid more carefully controls system resources and gives the best performance results.

02/09/2010 DataGrid 3.1
  • Compatibility with Internet Explorer 8
    APNSoft DataGrid is now staffed with new skins which are fully optimized for Internet Explorer 8. All previous browsers are supported too.
    New skins (ver. 1.13) can be downloaded from the Download Section. To see them in action open the section Live Demos.

  • Double-click support
    The new AutoPostBackOnDblClickRow property specifies whether the control causes a postback to the server when a row is double-clicked.
    The new ClientSideOnDblClickRow property specifies the name of the client-side function to be called when a row is double-clicked.

  • Best Fit for columns (automatic column sizing)
    APNSoft DataGrid can now automatically adjust column width to make a cell's contents fully visible. To activate this feature, simply double-click a right edge of the column header.

  • Advanced template processing
    HTML and XSL templates can now include the $ColumnName$ variable, instead of which the name of current column is inserted. ASCX Template can now include the field GridColumn which is declared as public.

  • Renamed properties
    The property AutoPostBackOnSelect is renamed to AutoPostBackOnSelectRow.
    The property ClientSideOnSelect is renamed to ClientSideOnSelectRow.
    These properties are renamed for a more proper description.

  • Fixed bugs

    • Fixed a bug with style for Context Menu.
    • The behavior of hovered row is fixed when multiple Grids are placed.
    • Fixed a bug with row selection when filter is applied.
    • The GetSelectedRow() method now works correctly with PostBack.
    • Fixed a bug that causes wrong behavior under Safari 4.
    • Several minor bugs are fixed.

  • Small code improvements
    Now DataGrid more carefully controls system resources and gives the best performance results.

02/26/2009 Menu 3.6
  • User roles (Security Trimming)
    User roles provide developers with an easy and flexible way to control access to various menu elements. Menu (as well as menu elements) can be assigned to multiple, comma-separated roles.

  • New variable: $Rnd$
    XML Structure can now include the $Rnd$ variable, instead of which a random number is inserted. This variable can be used for additional parameter in the href attribute to avoid page caching in browser.

    Example:

    <item title="Home" href="~/Default.aspx?Rnd=$Rnd$" />

  • Fixed bugs

    • Fixed a bug with scrollable menu displayed in Firefox and Safari.
    • Fixed a bug in the DataBind() method.
    • Root node in the Web.sitemap file can now include standard attributes.
    • Several minor bugs fixed.

  • Small code improvements
    Now Menu more carefully controls system resources and gives the best performance results.

12/29/2008 DataGrid 3.0
  • Custom AJAX calls
    APNSoft DataGrid includes its own AJAX engine which now allows developer to launch custom asynchronous calls. In other words, DataGrid placed on ASP.NET page, adds AJAX functionality to this page. Such AJAX calls are processed by the DataGrid component, but can be launched independently of the current DataGrid task.

  • Fixed columns
    DataGrid includes support for fixed (frozen) columns. Fixed columns remain visible on the left side of the grid and do not scroll when the grid scrolls.

  • Row Filter
    APNSoft DataGrid now includes the filter feature which allows users to quickly locate records they are looking for. Row filter can be applied from the server side or client side (JavaScript procedure, context menu, input box, etc.).

  • CSS customization for rows
    Use the new property CssClass to specify custom Cascading Style Sheet (CSS) class for the values displayed in the row. All custom classes must be included in the skin's CSS Style.

  • Column order
    The new property OrderIndex specifies the order index of a column in the collection of columns. In other words, the order index is a position of the column.

  • New property ClientSideAfterCallBack
    This property specifies the name of the client-side function to be called after CallBack request.

  • New variables for the Context Menu template
    Template for Context Menu can include special variables, instead of which data (RowID, ColumnName, CellValue, etc.) is inserted.

  • File name for export data
    The new property ExportFileName specifies the name of the file that is the data to export.

  • Z-Index
    The property zIndex has been added to the DataGrid, Edit Form and Context Menu.

  • Processing of selected row
    The new property Selected gets or sets a Boolean value that indicates whether the row is selected. The new method GetSelectedRow() returns the Selected Row.

  • Right-click selection
    The new property RightClickSelect specifies whether a row is selected when the user right-clicks on the row.

  • Additional client-side methods

    • dg.GetColumnName(GridID, ColumnIndex); - returns the name of the specified column.
    • dg.GetCellValue(GridID, RowID, ColumnName); - returns the cell value.
    • dg.GetEditFormElement(GridID, ElementID); - returns the Element in the Edit Form. By using this method, any element on the Edit Form can be validated on the client side before request to the server.
    • dg.ClearPageCache(GridID); - deletes the cached data for the current Grid page.
    • dg.DecodeValue(Value); - decodes the value received from the server-side event-handling method. Can be used for decoding the Parameter value received by the client-side function applied by the ClientSideAfterCallBack property.
    • dg.DecodeCellValue(CellValue); - decodes the cell value received from the column template (from the $CellValueEncoded$ variable).

  • Updated Skins
    Each Skin now includes new images and CSS classes required for fixed columns, row filter, etc. New skins (ver. 1.9) can be downloaded from the Download Section. To see them in action open the section Live Demos.

  • Fixed bugs

    • Fixed bugs with data exporting (HTML and Excel).
    • Horizontal scrollbar position is corrected when the page is loaded after PostBack.
    • Several minor bugs fixed.

  • Small code improvements
    Now DataGrid more carefully controls system resources and gives the best performance results.

06/02/2008 TreeView 3.0

  • Server-side API
    APNSoft TreeView now provides an extremely rich and powerful server-side API allowing developer to add, remove or edit TreeView elements and element collections. TreeView includes two new classes TreeViewElement and TreeViewElementCollection.

  • Check boxes
    Check boxes allow the user to select more than one tree node. Each item has three potential states: checked, partially-checked (not all subitems are checked) and unchecked. Checking off an item automatically checks off all subitems. The property CheckBoxes specifies the value indicating whether check boxes are displayed next to the tree nodes.

  • The href attribute can include a JavaScript call
    TreeView item can now include a JavaScript call in the href attribute. Also it can include variables $TreeViewID$ and $ItemID$, instead of which data is inserted.

    Example:

    <item title="JavaScript" href="javascript:ItemClick('$TreeViewID$','$ItemID$');" />

    JavaScript function:

    function ItemClick(TreeViewID,ItemID){
    alert('TreeViewID='+TreeViewID+',ItemID='+ItemID);
};

  • Support for Web.sitemap
    The "Web.sitemap" file can be used as TreeView structure. Use the StructureFileURL property to set the TreeView structure.

  • New property ShowStartingNode
    This property specifies a value indicating whether the TreeView renders the starting node.

  • New properties for client-side operations

    • ClientSideOnSelect - specifies the name of the client-side function to be called when an item is selected.
    • ClientSideOnDeselect - specifies the name of the client-side function to be called when an item is deselected.
    • ClientSideOnExpand - specifies the name of the client-side function to be called when an item is expanded.
    • ClientSideOnCollapse - specifies the name of the client-side function to be called when an item is collapsed.
    • ClientSideOnCheck - specifies the name of the client-side function to be called when an item is checked.
    • ClientSideOnUnCheck - specifies the name of the client-side function to be called when an item is unchecked.

  • Structure checking
    APNSoft TreeView now checks the structure for duplicated IDs and wrong-referenced elements in the database table with TreeView structure.

  • Fixed bugs

    • Fixed a bug that cause the "The HTTP verb POST used to access path '/' is not allowed." message.
    • Fixed a bug that causes the "Invalid postback or callback argument." message.
    • Several minor bugs fixed.

04/02/2008 DataGrid 2.5
  • Support for different data sources
    The first step in programming a DataGrid is to set up its DataSource property. APNSoft DataGrid now supports different data sources: DataView, DataTable, DataSet, DataReader and any object that implements IEnumerable interface.

  • Cell editing
    APNSoft DataGrid is now enriched with new useful feature. It allows the user to modify a record right in the DataGrid area. When cell is clicked, it is transformed into Input Box populated with the cell value. The user can then edit this value. This sort of editing is also known as Inline editing.

  • ASCX template (User Control) for a Column
    APNSoft DataGrid displays each item in the column in accordance with a specified template. You can now use ASCX templates to organize and format column data by using your preferred programming language C# or VB.NET. The DataGrid component automatically identifies the type of applicable template (ASCX, XSL or HTML).

  • Custom Buttons on the Bottom Bar
    Now you can extend Bottom Bar with custom buttons, which make DataGrid more relevant to users. Each custom button is defined by a single XML node in the XML template applied to Bottom Bar and one or two icon files, which are all stored in the Grid's Skin Folder.

  • New client-side methods

    • dg.Refresh(GridID); - refreshes the content of the DataGrid.
    • dg.SetPage(GridID, PageNumber); - sets the grid page number to be shown.
    • dg.ScrollToTop(GridID); - scrolls the contents of the grid to the top position.
    • dg.ScrollToLeft(GridID); - scrolls the contents of the grid to the left position.

01/20/2008 DataGrid 2.0
  • Running Mode
    APNSoft DataGrid now supports different running modes: CallBack and PostBack. Running mode controls how DataGrid handles sorting and paging. Use the Mode property to specify the running mode of the DataGrid. If the Mode property value is CallBack, paging and sorting are performed through AJAX-style HTTP callbacks. If the Mode property value is PostBack, each action initiates an ASP.NET postback and triggers the appropriate server-side event.

  • ASP.NET AJAX compatibility
    By default, any postback control inside an UpdatePanel control causes an asynchronous postback and refreshes the panel's content. As the DataGrid now supports PostBack running mode, component can be placed inside an UpdatePanel control. Server side events for paging and sorting must be specified as asynchronous triggers.

  • Support for Context Menu
    APNSoft DataGrid now provides you with full support for context menu. You can use context menu for rows or column headers.

  • Export to HTML
    APNSoft DataGrid can now export the data to HTML by using the new button with 'HTML' icon on the Bottom Bar. The property Exportable specifies the value indicating whether the column data will be exported to HTML or not.

  • Visible/invisible Bottom Bar
    You can now make the Bottom Bar invisible by using the new property BottomBar.Visible.

  • Updated Skins
    Each Skin now includes new images and CSS classes required for Context Menu and export to HTML. New skins (ver. 1.3) can be downloaded from the Download Section. To see them in action open the section Live Demos.

  • New server-side methods

    • ResetColumnWidths - sets all columns at an equal percent fraction of the DataGrid width.
    • ResetPageNumber - sets a Page Number to its default value (1).
    • ResetSelectedRow - removes the 'Selected' attribute from the row.
    • ResetSortedColumn - removes the 'Sorted' attribute from the column.

  • New client-side methods

    • dg.Sort(GridID, ColumnIndex, Direction) - sorts the data in the DataGrid.

  • Fixed bugs

    • Fixed a bug that cause the "The HTTP verb POST used to access path '/' is not allowed." message.
    • Fixed a bug that causes the "Invalid postback or callback argument." message.
    • The behavior of scrollbars is fixed when the AutoResize property is defined.
    • Position of the Edit Form is fixed if the DataGrid is placed in the DIV with absolute position.
    • Several minor bugs fixed.

12/06/2007 Menu 3.5
    New features available in version 3.5:

  • Server-side API
    APNSoft Menu now provides an extremely rich and powerful server-side API allowing developer to add, remove or edit menu elements and element collections. Menu includes two new classes MenuElement and MenuElementCollection.

  • The href attribute can include a JavaScript call
    Menu item can now include a JavaScript call in the href attribute. Also it can include variables $MenuID$ and $ItemID$, instead of which data is inserted.

    Example:

    <item title="JavaScript" href="javascript:ItemClick('$MenuID$','$ItemID$');" />

    JavaScript function:

    function ItemClick(MenuID,ItemID){
    alert('MenuID='+MenuID+',ItemID='+ItemID);
};

  • New property ShowStartingNode
    This property specifies a value indicating whether the menu renders the starting node.

  • Structure checking
    APNSoft Menu now checks the structure for duplicated IDs and wrong-referenced elements in the database table with menu structure.

  • Fixed bugs

    • Menu can now handle the "\" symbol in Web.sitemap file.
    • Submenu position is corrected when the window has a horizontal scrollbar.
    • Submenus are now displayed in browser with High-Level Security and enabled JavaScript.
    • Tooltip position is corrected when the menu is in the DIV with relative position.
    • Several minor bugs fixed.

  • Lite Mode removed
    The Lite Mode will not be supported anymore.

10/03/2007 DataGrid 1.5
  • Export to Excel
    APNSoft DataGrid can now export the data to Microsoft Excel format by using the new button with 'Excel' icon on the Bottom Bar. The property Exportable specifies the value indicating whether the column data will be exported to Excel or not.

  • DataGrid size on the client side
    New client-side methods enables you to set width and height on the client side.

  • Support for hovered rows
    DataGrid includes two new properties. Please use the CssClassRowHovered property to specify the CSS class for hovered row. The CssClassRowSelectedHovered property is used to specify the CSS class for the row which is selected and hovered. These classes should be included in the CSS Style.

  • HighlightSelectedRow property
    This new property specifies the value indicating whether the selected row is highlighted.

  • Double click for buttons in the Bottom Bar
    The new EventType attribute specifies the type of action the user must take to perform the button's action. This attribute is a part of Button node in the template for the Bottom Bar. Examples:

    • <Button Action="PageFirst" Title="First Page" EventType="Click" />
    • <Button Action="PageFirst" Title="First Page" EventType="DoubleClick" />

  • Skins have been changed
    The following CSS class names have been changed to make them easier to understand:

    • GridRowsEvenTRs changed to GridRowEvenTR
    • GridRowsTRs changed to GridRowSelectedTR
    • GridBarButtonTDh changed to GridBarButtonHoveredTD

    New skins (ver. 1.2) can be downloaded from the Download Section. To see them in action open the section Live Demos.

  • Fixed bug
    Fixed bug with inserting a new record when multiple Grids are placed on the page.

  • Lite Mode removed
    The Lite Mode will not be supported anymore.

06/01/2007 DataGrid 1.3
  • Support for Line Numbers.
    The new LineNumbers property is used to display the row numbers in the specific column.

  • Different styles for alternating rows.
    You can specify complete style information for alternating rows by modifying the GridRowEvenTR class in the skin's CSS Style. Alternating rows tell which cells are in each row, especially with wide tables that have many columns.

  • Customizable position of the Edit Form.
    To set the position the EditForm.PositionInsert and EditForm.PositionUpdate properties are used. The Edit Form can be positioned in the center of the screen,
    at the top left corner of the DataGrid, in the center of the DataGrid, below the selected row, etc.

  • Customizable shadow displayed for Edit Form.
    The EditForm.ShadowDepth, EditForm.ShadowColor and EditForm.ShadowOpacity properties are used to set the shadow.

  • Support for SEO (Search Engine Optimization).
    The SEOEnabled property specifies the value indicating whether the DataGrid renders an additional NOSCRIPT section with links which correspond to DataGrid rows.

05/05/2007 Menu 3.0
    APNSoft Menu has been significantly improved and includes new properties and methods. Some properties and methods have been removed and will not be used anymore.

    New features available in version 3.0:

  • AJAX-based Load On Demand
    APNSoft Menu now supports AJAX-based load on demand. The LoadOnDemand property specifies whether submenu will be loaded on demand without postback to the server. The LoadingText property specifies the text displayed in the tooltip while loading load-on-demand content.

  • Data Binding
    The source of data can be bound directly to the Menu. Simply set the DataSource property and call the DataBind() method. Menu supports building multiple levels of hierarchy (the ID/ParentID model) from a single table in the data source.

  • Support for Skins
    The SkinFolder property specifies the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS styles, images, etc.).

  • Path Highlighting
    The HighlightPath property specifies the value indicating whether the menu highlights the selected item as well as the whole navigation path. The HighlightedPathOpacity property specifies the opacity level in percent of the Highlighted Path.

  • New attribute iconOver
    APNSoft Menu now supports using the separate icon for hovered item. Use the iconOver attribute in menu structure to specify the name of the icon for hovered item.

  • Expand Delay can be customized
    The ExpandDelay property specifies the delay in milliseconds before a submenu expands.

  • Support for Web.sitemap
    The "Web.sitemap" file can be used as menu structure. Use the StructureFileURL property to set the menu structure.

  • Support for selected item
    APNSoft Menu now saves selected item between postbacks. The GetSelectedItemID() method returns the selected Item ID. The item's attribute selected keeps the current item selected by default.

  • New property ClientSideOnSelect
    The ClientSideOnSelect property specifies the name of the client-side function to be called when an item is selected. The function accepts two parameters: MenuID and ItemID.

  • Lite Mode
    APNSoft Menu operates in "full" mode by default. If the Lite property value is true, component operates in "lite" mode and can be used for FREE!

    Properties and methods that are out-of-date and will not be used in the current and next versions:

  • ClientSideProcedureName property
    APNSoft Menu now uses the ClientSideOnSelect property.

  • ArrowFileName and ArrowOverFileName properties

    • ArrowDown.gif, ArrowDownOver.gif - arrows for horizontal menu which opens downward.
    • ArrowRight.gif, ArrowRightOver.gif - arrows for vertical menu or submenus.
    • ArrowUp.gif, ArrowUpOver.gif - arrows for horizontal menu which opens upward.

    Menu now uses arrow images with predefined names. Arrow images should be placed in the Skin Folder as specified by the SkinFolder property.

  • ServerSideProcedureName property
    Please use the event-handling method for the OnItemClick event. This event occurs on the server side when an item is clicked.

  • CSSFileURL property
    The new menu version uses CSS styles which have fixed names and are located in the Skin Folder. One CSS style ("CSSStyleHorizontal.CSS") is used for menu with horizontal orientation. The second ("CSSStyleVertical.CSS") is used for menu with vertical orientation.

  • ImagesFolderURL property
    All images must be located in the Skin Folder. The SkinFolder property specifies the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.).

  • Methods Render() and Reset()
    These methods have been removed due to its needlessness.

04/05/2007 DataGrid 1.0

  • Initial release

11/27/2006 TreeView 2.0

  • Data Binding
    The source of the data can be bound directly to the TreeView. Simply set the DataSource property and call the DataBind() method. TreeView supports building multiple levels of hierarchy (the ID/ParentID model) from a single table in the data source.

  • New DurationExpand and DurationCollapse properties
    The DurationExpand property specifies the duration (in milliseconds) of the expand animation. The DurationCollapse property specifies the duration of the collapse animation.

  • Fixed bugs

    • Fixed the bug with icons if TreeView uses the property ExpandSinglePath="True"
    • Fixed the bug which blocked the ability to use the "~" symbol in all modes. This symbol is an abbreviation for the home directory of web application. Tilde can be used in property values, XML Structure and CSS Style.

  • Small code improvements
    Now TreeView more carefully controls system resources and gives the best performance results.

10/21/2006 TreeView 1.5

  • AJAX-based Load On Demand
    APNSoft TreeView now supports AJAX-based load on demand. The LoadOnDemand property specifies whether child nodes will be populated on demand without postback to the server.

  • iconOpen node attribute
    The iconOpen attribute allows to define the icon for expanded node.

  • Health Checking
    APNSoft TreeView now uses client-side JavaScript messages which allow developers control the TreeView status. For example, if you use a new TreeView version with the old JS file, you will see a warning. This feature can be switched off by using the WarningsEnabled property.

10/04/2006 ComboBox 1.5
  • Ready for ASP.NET 2.0 and Visual Studio 2005
    APNSoft ComboBox has been tested on ASP.NET 2.0 and Visual Studio 2005. For example, you can use product on the master page to create a combobox that applies to all pages.

  • The new method: GetSelectedItemID
    Returns the selected Item ID after postback. This method can be used only in Code Behind.

  • Using the "~" (tilde) symbol
    This symbol is an abbreviation for the home directory of web application. Tilde can be used in property values, XML Structure and CSS File.
    This feature is very useful because User Control with ComboBox can be placed on the ASPX pages which are located in different subdirectories of the web application.

  • Support for keyboard navigation
    Now you can select an item from the list by pressing the first letter on your keyboard. For example, you use a combo box for states. If you select Pennsylvania, but you want to change to Wisconsin, instead of navigating through the list, you can hit a "W" to get to Wisconsin.

  • Updated Client-Side Procedures
    Client-Side Procedures now utilize two input parameters: ComponentID and ItemID.

  • Health Checking
    APNSoft ComboBox now uses client-side JavaScript messages which allow developers control the component status. For example, if you use a new ComboBox version with the old JS file, you will see a warning. This feature can be switched off by using the WarningsEnabled property.

  • The source code is now available
    The Source Code package includes the full Visual Studio .NET 2003 and Visual Studio 2005 solutions (C#, XML, XSL, JS, image files, etc.) for APNSoft ComboBox in one archive (ZIP format).
    You should purchase the Source Code License or Corporate Site License if you want to use the Source Code.

09/22/2006 Include 1.5

  • SSL compatibility
    APNSoft Include can retrieve pages from the servers which use HTTPS protocol.

  • Browser Emulation
    Component emulates the IE 6.0 behavior. This is done automatically without any additional effort on the developer's side.

09/19/2006 Menu 2.5
  • Support for scrollable menus
    The SubMenusHeight property specifies the maximum height for Submenus. A Submenu automatically becomes scrollable if its height less than the real height of its contents.

  • Search Engine Optimization
    The new version uses the SEOEnabled property. It indicates whether the menu renders an additional NOSCRIPT section with links let all search engines index the website properly.

  • Health Checking
    APNSoft Menu now uses client-side JavaScript messages which allow developers control the menu status. For example, if you use a new menu version with the old JS file, you will see a warning. This feature can be switched off by using the WarningsEnabled property.

06/29/2006 Menu 2.1
  • Transparency
    The new version supports transparency. Now menu can appear as semi-transparent, so you can freely see behind it.

  • Small code improvements
    Now menu more carefully controls system resources and gives the best performance results.

06/28/2006 TreeView 1.0

  • Initial release

12/20/2005 Menu 2.0
  • Ready for ASP.NET 2.0 and Visual Studio 2005
    APNSoft Menu has been tested on ASP.NET 2.0 and Visual Studio 2005.

  • XHTML 1.1 compliance
    The entire APNSoft Menu output is XHTML 1.1 compliant. This ensures that menu product is a standards-based software.

  • New CSSSource and CSSClassesPrefix properties
    CSSSource specifies the CSS Style location. Now menu can use a style in the <head> section of ASPX page. The CSSClassesPrefix used for association between menus and a set of CSS classes.

  • New property ExpandDirectionV
    ExpandDirectionV specifies the vertical direction to which submenus expand. It is applied to horizontal menu only. Available values are Downwards and Upwards.

  • Support for Tooltips
    Tooltip describes the purpose of the currently selected item and can be specified through the tooltip node attribute in the menu XML Structure.

  • New Styles Library
    The new version 1.2 includes 67 ready-to-use menu styles, including 8 new styles. All of them are grouped by shape and color tints. All styles are FREE for commercial and non-commercial use. You can distribute and modify them freely.

09/27/2005 Menu 1.8
  • Menu items can include pure HTML code
    It gives additional flexibility for customization. Square brackets ("[" and "]") are used instead of standard corner brackets ("<" and ">"). Sometimes it is required to use square brackets without transformation to corner brackets. In this case simply use the double square brackets ("[[" and "]]").

  • New SubMenusOpen and SubMenusClose properties
    SubMenusOpen specifies the value indicating whether the submenus of the root menu are opened by mouse click or automatically when user moves mouse pointer over the menu item. SubMenusClose specifies the value indicating whether all of the opened submenus are closed by mouse click outside the menu or automatically when the mouse goes away.

  • Using the "~" (tilde) symbol
    This symbol is an abbreviation for the home directory of web application. Tilde can be used in property values, XML Structure and CSS Style.
    This feature is very useful because User Control with a menu can be placed on the ASPX pages which are located in different subdirectories of the web application.

  • New OutputHeader and OutputFooter properties
    Menu now allows to customize header and footer in result DHTML code by using of the OutputHeader and OutputFooter properties.

  • Additional improvements

    • Additional CSS classes for Precise Customization are now included in the main CSS Style. Now Precise Customization does not require using of additional CSS definition of ASPX page where the menu is used.
    • Mechanism of positioning is improved.
    • A new version more carefully controls system resources and gives the best performance results.

  • Fixed bugs

    • Menu ID as well as IDs in the XML Structure can include the "_" symbol.
    • Fixed the bug with z-index if multiple menus on one page.
    • Now the OnItemClick event works properly for dynamically loaded menu.

  • New example applications
    Two new examples are added in the download section. The first one uses MS Access database for menu structure. The next one demonstrates how to enable/disable menu items. You are welcome to use code from the examples in your own application.

02/26/2005 ComboBox 1.2
  • MAC browsers compatibility
    Now the ComboBox is compatible with most popular MAC browsers:
    Safari, Camino, Netscape, Opera, Mozilla, Firefox. See the full list of browsers in the Features section.

  • SSL compatibility
    The new version of ComboBox works on a SSL secured site without the message:

    This page contains both secure and nonsecure items.
    Do you want to display the nonsecure items?

    If the ComboBox is used on a SSL secured site, you should use the SSLSecured property.

02/26/2005 Menu 1.5
  • MAC browsers compatibility
    Now the menu is compatible with most popular MAC browsers:
    Safari, Camino, Netscape, Opera, Mozilla, Firefox. See the full list of browsers in Features section.

  • AutoPostBack component property
    AutoPostBack property specifies whether the Menu control causes a postback to the server when an item is clicked.

  • AutoPostBack item attribute
    The one item's attribute AutoPostBack allows to turn off the menu's AutoPostBack property only for specified menu item.

  • OnItemClick server side event
    Now the component includes the OnItemClick event. It occurs on the server side when a menu item is clicked.

  • id item attribute
    Now you can set the unique id attribute for each menu item. For example, the id can be used for receiving the one menu item that is pressed while the OnItemClick server side event is processed. If the id attribute is not specified, the component will automatically set it for each menu item (id="1", id="2", etc.)

  • ItemOverCustomization property
    The ItemOverCustomization property allows to make a deep customization for hovered items. It can be used when you want to create the border for the hovered Item or make it sunken or raised, or set different colors, fonts, etc.

  • Example Applications
    The C# and VB.NET examples that make use of the APNSoft Menu 1.5 are included in the Download Section. The examples will help you jump-start the development of your own applications, by showing how basic tasks are performed. You are welcome to use code from the examples in your own application.

12/16/2004 ComboBox 1.0

  • Initial release

11/11/2004 Menu 1.3
  • The name of product
    Formerly known as ASP.NET DHTML Menu, the component's name has recently changed to APNSoft Menu. We think our products must include the Company Name. Because of this, some changes are made.

    The table of differences:

    APNSoft Menu | ASP.NET DHTML Menu
    Component DLL | APNSoftMenu.dll | ASPNetDHTMLMenu.dll
    Main class | APNSoftMenu | ASPNetDHTMLMenu
    Code at the top of ASPX page | <%@ Register TagPrefix="mn" Namespace="APNSoft.WebControls" Assembly="APNSoftMenu" %> | <%@ Register TagPrefix="dm" Namespace="APNSoft.WebControls" Assembly="ASPNetDHTMLMenu" %>
    ASPX syntax | <mn:APNSoftMenu id="m1" runat="server" /> | <dm:ASPNetDHTMLMenu id="dm1" runat="server" />
    Code Behind syntax (C#) using APNSoft.WebControls;
    APNSoftMenu myMenu =
    new APNSoftMenu();         		using APNSoft.WebControls;
    ASPNetDHTMLMenu myMenu =
    new ASPNetDHTMLMenu();
    Distributive package | APNSoftMenu.msi | ASPNetDHTMLMenu.msi

  • Overlap for submenus
    Now you can change the horizontal and vertical overlap a submenu will have over its parent Menu Item. To customize the overlap, please, use the OverlapH and OverlapV properties.

  • The menu client-side script in external .JS file
    By default, the client-side script is generated by component. The new version allows you to use external .JS file with the client-side script. If you want to increase the performance, you should use external .JS file. The browser will use the cached version of the .JS file, saving you about 15 kb per request. See the ClientScriptSource property for more information.

  • zIndex property
    You can manually set the value of z-index for the layers are generated by the menu. See the zIndex property description.

  • Each menu Item, submenu, separator can be customized separately
    The new attributes for the Menu Structure are available:

    Attributes | Description
    css_Item_MainTdd | Attribute for the items customization. (Main menu, horizontal orientation).
    css_Item_MainTrd
    css_Item_MainTd         		Attributes for the items customization. (Main menu, vertical orientation).
    css_Item_SubTrd
    css_Item_SubTd         		Attributes for the submenu's items customization.
    css_submenu_ParentSubTab
    css_submenu_ParentSubTd
    css_submenu_SubTab         		Attributes for the submenus customization.
    css_separator_Spr | Attribute for the separators customization.

  • SSL compatibility
    Now the menu works on an SSL secured site without the message:

    This page contains both secure and nonsecure items.
    Do you want to display the nonsecure items?

    If the menu is used on an SSL secured site, you should use the SSLSecured property.

  • Client-side script performance
    Small correction in menu client-side script. Now the menu more carefully controls system resources and gives the best performance results.

03/25/2004 Menu 1.0

  • Initial release

03/16/2004 Include 1.0

  • Initial release


ASP.NET Controls - 3 Easy Steps

APNSoft Controls [4.5.2.20]
3 Easy Steps

3 Easy Steps to add Menu, DataGrid, TreeView, etc. to your ASP.NET Web Page:

To install APNSoft Controls Suite, download and run the installation program. more | Add control to your page manually, from Visual Studio Toolbox or in the Code Behind. more | Set a control structure (data source), apply the Skin and set the properties. more


ASP.NET Controls - Installation

APNSoft Controls [4.5.2.20]
Installation

APNSoft Controls Suite is offered as EXE installer and as ZIP file (the last versions can be downloaded from the APNSoft Downloads page).

To install product from ZIP file (manually), unpack it into the preferred folder on your machine.

To install product from EXE installer, run it and follow on-screen instructions during the installation process. Installer creates a set of files and directories in the destination folder. By default, the destination folder is:

C:\Program Files\APNSoft Controls [Product_Version] for ASP.NET [NET_Version]\

The [Product_Version] is the version of APNSoft Controls Suite.
The [NET_Version] is the version of .NET Framework.

The contents of destination folder:

Folder / File | Description
Bin | Contains the main assembly APNSoftControls.dll.
ExampleApplication.CS | Contains Visual Studio solution with C# demos.
ExampleApplication.VB | Contains Visual Studio solution with VB.NET demos.
Skins | Contains the collection of ready-to-use skins.
Documentation.chm | The documentation file.
LicenseAgreement.rtf | The End-User License Agreement for the product.

After the installation procedure is completed you can open the window with Reference Book, Code Samples, etc. by this shortcut:

Start Menu -> Programs -> APNSoft Controls [Product_Version] for ASP.NET [NET_Version]


ASP.NET Controls - System Requirements

APNSoft Controls [4.5.2.20]
System Requirements

Operating system (OS)

The product is supported on the following operating systems:
  • Windows 2000
  • Windows XP
  • Windows Vista
  • Windows 7
  • Window Server (all versions)

Framework

The following frameworks are supported:
  • .NET Framework 2.0
  • .NET Framework 3.5
  • .NET Framework 4.0
  • .NET Framework 4.5

Editor (IDE)

You can use any editor to set the required properties of the control and to implement it in your pages. Best integration is provided for:
  • Visual Studio 2005 (or Visual Web Developer 2005)
  • Visual Studio 2008 (or Visual Web Developer 2008)
  • Visual Studio 2010 (or Visual Web Developer 2010)
  • Visual Studio 2012 (or Visual Studio Express 2012 for Web)


ASP.NET Controls - Visual Studio Integration

APNSoft Controls [4.5.2.20]
Adding controls to the Visual Studio Toolbox

APNSoft Controls Suite integrates with Visual Studio toolbox, so you can easily drag and drop APNSoft controls on your pages. To add APNSoft Controls to your Visual Studio Toolbox please follow these steps:

  1. Make sure you have installed the APNSoft Controls Suite on your machine.
  2. Open your Visual Studio environment.
  3. Open or create an ASP.NET Web application.
  4. Open or add an ASP.NET Web page or user control for editing in design view.
  5. Expand the Toolbox window.
  6. Right-click the Toolbox. Select Add Tab menu item.
  7. Type in APNSoft Controls tab name and press Enter.
  8. Right-click the APNSoft Controls tab and select Choose Items menu item.
  9. Click Browse in the dialog. Find the APNSoftControls.dll assembly, select Open and then Ok.
    By default, installer puts this dll in the folder:
    C:\Program Files\APNSoft Controls [Product_Version] for ASP.NET [NET_Version]\Bin\
  10. The list of APNSoft controls should appear in the Toolbox.


ASP.NET Controls - Deployment

APNSoft Controls [4.5.2.20]
Adding controls to an ASP.NET Web Page

APNSoft Controls Suite does not require special handlers, modules, application settings (Web.Config), etc. There are three main ways to add APNSoft control to an ASP.NET Web Page.
  1. Manually.
  2. From Visual Studio Toolbox (recommended).
  3. In Code Behind.

  1. Manually embedding a Control into the page.

    All you need to do is to add main dll library to your web application and write two lines of code on the WebForm:

    1. Copy the APNSoftControls.dll assembly into the Bin directory of your web application.

      By default, installer puts the APNSoftControls.dll in the folder:
      C:\Program Files\APNSoft Controls [Product_Version] for ASP.NET [NET_Version]\Bin\

    2. Add the following line of code to the top of your page:

      <%@ Register TagPrefix="APNSoft" Namespace="APNSoft.WebControls" Assembly="APNSoftControls" %>

    3. Add corresponding code anywhere within your page to embed the control. The common syntax is:

      <APNSoft:APNSoft[Control_Name] id="myID" runat="server" />

      The [Control_Name] is the name of control (Menu, DataGrid, TreeView, etc.).

      For example, the complete code for Menu:
      <APNSoft:APNSoftMenu id="myMenu" runat="server" />

      Or the code for DataGrid:
      <APNSoft:APNSoftDataGrid id="myDataGrid" runat="server" />

    Now you can open the page in your browser to see output.

  2. Adding a Control to your web application using Visual Studio.

    Make sure you have added APNSoft Controls to your Visual Studio Toolbox. Drag the component icon from the toolbox and drop it in your web form / user control. Visual Studio will automatically copy the APNSoftControls.dll assembly to the Bin folder of your web application and will add required code to the page. All of the properties are available via Properties Panel.

  3. Adding a Control programmatically (in Code Behind).

    For more programming flexibility you can use the built-in API of any APNSoft control. We recommend to use the PlaceHolder as a container to store dynamically added server controls on the Web page. The PlaceHolder is a standard Web Forms control.

    1. Copy the APNSoftControls.dll assembly into the Bin directory of your web application.
    2. Put the PlaceHolder somewhere on your Web page.
      <asp:PlaceHolder ID="PlaceHolder1" runat="server" />

    3. Put code in the Page_Load() procedure in Code Behind.

      [C#]
      protected void Page_Load(object sender, EventArgs e)
{
    //Create component instance
    APNSoft.WebControls.APNSoftMenu myMenu = new APNSoft.WebControls.APNSoftMenu();
    myMenu.BasePage = base.Page;
    myMenu.ID = "myMenu";

    //Set properties
    myMenu.StructureFileURL = "~/Structures/Menu.xml";
    myMenu.SkinFolder = "~/Skins/Classic/";

    //Add the control to PlaceHolder
    PlaceHolder1.Controls.Add(myMenu);
}

      [VB.NET]
      Protected Sub Page_Load(sender As Object, e As System.EventArgs) Handles Me.Load

    'Create component instance
    Dim myMenu As APNSoft.WebControls.APNSoftMenu = New APNSoft.WebControls.APNSoftMenu
    myMenu.BasePage = Me.Page
    myMenu.ID = "myMenu"

    'Set component properties
    myMenu.StructureFileURL = "~/Structures/Menu.xml"
    myMenu.SkinFolder = "~/Skins/Classic/"

    'Add the control to PlaceHolder
    PlaceHolder1.Controls.Add(myMenu)

End Sub


ASP.NET Controls - Customization

APNSoft Controls [4.5.2.20]
Customization

Customizing the look-and-feel of APNSoft control is accomplished through the following steps:
  1. Specifying the XML Structure or Data Source.

    The control like a Menu or TreeView uses XML for defining structure since XML is the most convenient format for structured data. You can save the XML structure as a file and bind the control by specifying the StructureFileURL property. Also, you can set the DataSource property to specify a source of data and call the DataBind() method. APNSoft controls provide an extremely rich and powerful server-side API allowing developer to add, remove or edit elements and element collections programmatically. Each component has initial data structure to see the result immediately.

  2. Applying the Skin.

    A Skin is a folder with CSS Style and a set of graphic files that determine the way the control is going to look. A CSS Style consists of predefined classes. You use the SkinFolder property to link the control with Skin. The collection of ready-to-use skins is included in installer. Each component has a default Skin to see the result immediately.

  3. Setting properties.

    To customize behavior and the look and feel of APNSoft control, you set the properties. Properties can be set in three ways:

    • Properties panel in IDE (Visual Studio)
    • ASPX (the Source View)
    • Code Behind (C# or VB.NET)


ASP.NET Controls - Example Applications

APNSoft Controls [4.5.2.20]
Example Applications

The APNSoft Controls Suite installation program includes ready-to-use Visual Studio solutions with C# and VB.NET samples. They are easy to customize and very useful when you are looking for a particular code sample.

The examples will help you jump-start the development of your own applications, by showing how basic tasks are performed. You are welcome to use code from the examples in your own applications.


ASP.NET Controls

APNSoft Controls [4.5.2.20]
Individual Controls

APNSoft ComboBox is a professional replacement for the classic ASP.NET ComboBox (ASP.NET DropDownList) component. It provides powerful, unique, and useful capabilities for building a web application user interface. You can use icons, separators, user-defined slider arrows, rulers, backgrounds, etc.
more

APNSoft DataGrid is an ASP.NET server control with AJAX support to display data in a tabular format with options of choice, sorting, and editing entries. DataGrid component has been designed to reduce development time and to require no specific knowledge from developers.
more

APNSoft Include is a component (Server Control) for ASP.NET. It allows you to include HTML files into your ASP.NET pages as Server Side Includes (SSI). The component is more flexible than standard #include directive. A remote page can be included from the target URL via HTTP protocol.
more

APNSoft Menu is an ASP.NET server control with AJAX support to display both statically and dynamically created menus on your web pages. It is a flexible, reliable, powerful, and easy-to-use menu system. Anyone can use it, no matter what level of experience you have. APNSoft Menu is excellent tool for web developers.
more

APNSoft Rating is a reach-featured ASP.NET server control with AJAX support, which allows people to easily provide feedback on an article, blog item, product description, etc. In addition to this, the Rating control has an option to display a value by a segment-oriented bar.
more

APNSoft TreeView is an ASP.NET server control with AJAX support to display hierarchical data in a tree structure. The main advantage over other TreeView controls is the SIMPLICITY. You do not need to learn a complex API to accomplish a task; create professional looking treeviews with only a few lines of code.
more


ASP.NET ComboBox Control - Overview

APNSoft Controls [4.5.2.20]
ComboBox > Overview

APNSoft ComboBox is a professional replacement for the classic ASP.NET ComboBox (ASP.NET DropDownList) component.

It provides powerful, unique, and useful capabilities for building a web application user interface. You can use icons, separators, user-defined slider arrows, rulers, backgrounds, etc.

APNSoft ComboBox is developed as a fully managed .NET server control. It generates DHTML output using an XML source with the ComboBox structure that can be obtained from a static file or programmatically. The product includes intelligent behavior support: auto and smooth content scrolling, transition effects, etc.

APNSoft ComboBox is a flexible, reliable, powerful, and easy-to-use product. It generates compact HTML and JavaScript code and is fully compatible with all popular browsers.


ASP.NET ComboBox Control - Features

APNSoft Controls [4.5.2.20]
ComboBox > Features

Standards-Based software
  • ComboBox output is XHTML 1.1 compliant.
  • Ready for ASP.NET 2.0, 3.5, 4.0 & 4.5. Visual Studio 2005, 2008, 2010 & 2012.
  • Based on industry standards: XML and CSS.

Easy-to-Use Software
  • Simplicity. No complex API.
  • Uses the default style and structure to see the result immediately.
  • Compact Documentation.
  • C# and VB.NET examples included.

Cross-Browser Support
  • APNSoft ComboBox offers full up-level cross-browser support for IE 5.5+, Firefox 0.8+, Google Chrome 6.0+, Mozilla 1.4+, Netscape 7.0+, Opera 7.5+, and Safari 1.2+.

Highly Customizable Look
  • Colors, sizes, borders and fonts can all be customized to visually integrate with any project.
  • Support for icons, background images, separators, user-defined images for the slider arrows and rulers.
  • The visual appearance is specified with CSS.
  • Support for Skins. Collection of free, ready-to-use skins.

Rich featured
  • Smooth content scrolling.
  • Support for transition effects.
  • Support for CSS and PNG shadows.
  • Semi-transparent DropDown List.
  • Customizable component width and height of DropDown List.
  • Support for onClick / onMouseOver events to open DropDown List.
  • Support for auto scrolling DropDown List content.
  • Absolute or static positioning.
  • Support for keyboard navigation.

Intelligent Behavior
  • Automatically displayed over HTML select boxes, Flash movies, and other ActiveX components.
  • Structure checking. APNSoft ComboBox checks the structure for duplicated IDs.
  • Saves its state after PostBack.
  • Search Engine Optimization. Allows search engines index your site properly.
  • Health Checking. Can generate client-side messages which allow developers control the ComboBox status.

Flexible Programming Options
  • The ComboBox Structure is defined through XML and can be obtained from a static file or programmatically.
  • Server-side API. APNSoft ComboBox provides an extremely rich and powerful server-side API allowing developer to add, remove or edit ComboBox elements and element collections.
  • Data binding support. ComboBox includes the DataSource property and the DataBind() method.
  • Automatic PostBack function is supported.
  • Support for client-side and server-side events.

Other Features
  • Multiple ComboBoxes on a single page are allowed.
  • Support for Unicode characters.
  • Generated code is dramatically small.


ASP.NET ComboBox Control - Component Parts

APNSoft Controls [4.5.2.20]
ComboBox > Component Parts
  1. Main Item.
    Customized via Skin's CSS Style classes:
    .MainItemTABLE{} .MainItemTD{}

  2. Main Icon.
    Specifies the default icon or icon of selected item. To define the default icon, you need to use the DefaultIcon property. The image file must be located in the Skin Folder.

  3. Main Text.
    Specifies the default text or text of selected item. To define the default text, you need to use the DefaultText property.

  4. Main Arrow.
    Specified by the images in the Skin Folder:
    MainArrow.gif MainArrowActive.gif

  5. The DropDown List.
    Customized via Skin's CSS Style classes:
    .ListDIV{} .ListTABLE{}

  6. Item in the DropDown List.
    Presented by the item node in the XML Structure. Customized via Skin's CSS Style classes:
    .ListItemTD{}
.ListItemHoveredTD{}
.ListItemSelectedTD{}

  7. The blank space of the Item.
    Customized via leftSpan node attribute in the XML Structure.

  8. Icon of Item in the DropDown List.
    Presented by the icon and iconOver node attributes in the XML Structure. The images must be located in the Skin Folder.

  9. Text of Item in the DropDown List.
    Presented by the title node attribute in the XML Structure. Customized via .ListItemTextTD{} class in the Skin's CSS Style.

  10. Separator in the DropDown List.
    Presented by the separator node in the XML Structure. Customized via Skin's CSS Style classes:
    .ListSeparatorTD{} .ListSeparatorSpaceTD{}

  11. Slider.
    Customized via .SliderTABLE{} class in the Skin's CSS Style.

  12. Slider's Arrow Up.
    Specified by the images in the Skin Folder:
    SliderArrowUp.gif SliderArrowUpActive.gif

  13. Slider's Ruler.
    Specified by the images in the Skin Folder:
    SliderRuler.gif SliderRulerActive.gif

  14. Slider's Arrow Down.
    Specified by the images in the Skin Folder:
    SliderArrowDown.gif SliderArrowDownActive.gif


ASP.NET ComboBox Control - Deployment

APNSoft Controls [4.5.2.20]
ComboBox > Deployment

Most of the time, all you need to do is to add main dll library to your web application and write two lines of code on the WebForm:

  1. Copy the APNSoftControls.dll assembly into the Bin directory of your web application.

  2. Add the following line of code to the top of your page:

    <%@ Register TagPrefix="APNSoft" Namespace="APNSoft.WebControls" Assembly="APNSoftControls" %>

  3. Add the following line of code anywhere within your page to embed the ComboBox:

    <APNSoft:APNSoftComboBox id="myComboBox" runat="server" />

For more information about adding controls to an ASP.NET Web Page, see this page.


ASP.NET ComboBox Control - Defining the Structure

APNSoft Controls [4.5.2.20]
ComboBox > Defining the Structure

APNSoft ComboBox uses XML for defining the structure since XML is the most convenient and widespread format for structured data. The XML Structure consists of elements (items and separators):

<ComboBox>
    <item title="AltaVista" />
    <item title="Google" />
    <item title="Yahoo" />
    <separator />
    <item title="AlltheWeb" />
    <item title="dmoz" />
    <item title="Excite" />
    <item title="GO" />
    <item title="HotBot" />
    <item title="MSN" />
    <item title="Overture" />
</ComboBox>

The code above creates the following ComboBox:

Structure elements:
  • <ComboBox /> - the root element for entire ComboBox Structure File. Does not include attributes.
  • <item /> - one ComboBox element in DropDown List. Available attributes:

    • AutoPostBackOnItemClick - specifies a value indicating whether the control causes a postback to the server when the item is clicked.
    • ClientSideOnItemClick - specifies the client-side code to be launched when the item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
    • href, target - the URL and target the browser is directed to when a user clicks the Item. The href attribute can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
    • icon - specifies the name of item's icon image. The icon image displayed at the left side of the item. The icon images must be located in the Skin Folder as specified by the SkinFolder property.
    • iconOver - specifies the name of the icon for hovered item.
    • iconWidth, iconHeight - one Item's icon image width and height. Attributes are optional. Control automatically calculates Width and Height of each icon.
    • id - specifies a unique identifier for the element. The attribute is required. If the id attribute is not specified, the component will automatically set it for each item (id="itm1", id="itm2", etc.).
    • leftSpan - specifies the blank space in pixels at the left side of the current Item.
    • selected - specifies a value indicating whether the item is selected.
    • title - specifies the text (caption) displayed for the item.

  • <separator /> - element for horizontal separator. Available attributes:

    • id - specifies a unique identifier for the element. The attribute is required. If the id attribute is not specified, the component will automatically set it for each separator (id="spr1", id="spr2", etc.).

ComboBox element examples:

<item id="i1" title="Home" href="~/Default.aspx?ItemID=$ItemID$&amp;Rnd=$Rnd$" />
<item title="Local Disk" icon="IconDisk.gif" iconOver="IconDiskActive.gif" />
<item title="Google" href="http://www.google.com" target="_blank" />
<item title="Yahoo" selected="true" leftSpan="16" />
<item title="JavaScript" ClientSideOnItemClick="alert('The $Title$ ($ItemID$) is clicked!');" />

Attention! Element names and attributes are case-sensitive. Be careful when you're typing in your data.

Applying the XML Structure or Data Source:

You can save the XML definition structure as a file and bind the ComboBox by specifying the StructureFileURL property.

<APNSoft:APNSoftComboBox id="myComboBox" runat="server"
    StructureFileURL = "~/Structures/ComboBox.xml" />

You can also apply the XML Document with structure by using the DataSource property. If the control loads structure from the database, you should set the DataSource property to specify a source of data and call the DataBind() method. To create an appropriate table in the SQL Server, use the following SQL command:

CREATE TABLE [dbo].[Items](
    [id] [nvarchar](20) NOT NULL,
    [Type] [nvarchar](10) NOT NULL CONSTRAINT [DF_Items_Type] DEFAULT ('item'),
    [title] [nvarchar](250) NULL,
    [href] [nvarchar](250) NULL,
    [target] [nvarchar](100) NULL,
    [icon] [nvarchar](100) NULL,
    [iconOver] [nvarchar](100) NULL,
    [iconWidth] [tinyint] NULL,
    [iconHeight] [tinyint] NULL,
    [AutoPostBackOnItemClick] [bit]
        NOT NULL CONSTRAINT [DF_Items_AutoPostBackOnItemClick] DEFAULT ((0)),
    [ClientSideOnItemClick] [nvarchar](250) NULL,
    [selected] [bit] NOT NULL CONSTRAINT [DF_Items_selected] DEFAULT ((0)),
    [leftSpan] [smallint] NULL
)

You can also build up ComboBox at runtime. APNSoft ComboBox provides an extremely rich and powerful server-side API allowing developer to add, remove or edit elements and element collections. You can programmatically control any item at runtime by using two classes ComboBoxElement and ComboBoxElementCollection.


ASP.NET ComboBox Control - Appearance Customization

APNSoft Controls [4.5.2.20]
ComboBox > Appearance Customization

APNSoft ComboBox supports easy appearance customization through Skins. A Skin is a folder that contains one CSS Style (Style.CSS) and a set of images:

ComboBox consists of the elements: Main Item, DropDown List, List items, icons, separators, etc. Each ComboBox element corresponds to an image or CSS class. Images and CSS classes have the predefined names. During customization you can change contents of these images/classes.

To link the control with Skin, use the SkinFolder property:

<APNSoft:APNSoftComboBox id="myComboBox" runat="server"
    SkinFolder = "~/Skins/GrayScale/" />

The collection of ready-to-use skins is included in installer. ComboBox has a default Skin to see the result immediately.


ASP.NET ComboBox Control - APNSoftComboBox Members

APNSoft Controls [4.5.2.20] - API Reference
APNSoftComboBox Members

APNSoftComboBox overview

Public Instance Constructors

APNSoftComboBox Constructor Initializes a new instance of the APNSoftComboBox class.

Public Instance Properties

AutoPostBackOnItemClick | Specifies whether the control causes a postback to the server when an Item is clicked. Default value is false.
AutoScrollList | Allows to enable content auto scrolling while the mouse cursor is moving over the opened DropDown List.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
ClientSideOnItemClick | Gets or sets the client-side code to be launched when an item is clicked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnItemOver | Gets or sets the client-side code to be launched while the mouse cursor is moving over the item in DropDown List. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
DefaultIcon | Specifies the image filename for the Default Icon if no items are selected from the DropDown List. The image file must be located in the Skin Folder of your web site, as specified by the SkinFolder property.
DefaultText | Specifies default ComboBox text. Default text is displayed if no items are selected from the DropDown List.
Elements | Gets the collection of elements.
FadeEffect | Specifies whether the control displays the DropDown List with animated Fade effect. Default value is true.
FadeSpeed | Gets or sets the speed of Fade Effect. Range: 0-50. Default value is 5.
ListClose | Gets or sets a value indicating whether the DropDown List is closed by mouse click outside the control or automatically when the mouse goes away. Default value is Auto.
ListHeight | Specifies the DropDown List height in pixels. If the height of the List content is more than property value, the Slider is displayed automatically. Default value is 140.
ListOpen | Gets or sets a value indicating whether the DropDown List is opened by mouse click or automatically when user moves the mouse pointer over the control. Default value is OnMouseClick.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
SEOEnabled | Gets or sets a value indicating whether the control renders an additional NOSCRIPT section with links let all search engines index your website properly. Default value is false.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
StructureFileURL | Gets or sets the URL to the structure file. If the property is not specified, component uses internal default structure. The property value can be an absolute or relative URI.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
Width | Gets or sets a value indicating the width of the ComboBox in pixels. Note that the property value is equal or greater than the actual width of the DropDown List content. Default value is 220.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

Public Instance Methods

DataBind | Creates a binding between the ComboBox control and a data source.
GetSelectedItemID | Returns the selected Item ID.

Public Instance Events

OnItemClick Occurs on the server side when the item is clicked.

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Overview

APNSoft Controls [4.5.2.20]
DataGrid > Overview

APNSoft DataGrid is an ASP.NET server control with AJAX support to display data in a tabular format with options of choice, sorting, and editing entries.

DataGrid component has been designed to reduce development time and to require no specific knowledge from developers. You do not need to learn a complex API to accomplish a task; our Grid represents an obvious, easily understandable model-a set of columns and rows and a set of options for their interaction.

  • "Smart" component

    Our DataGrid component is a "Smart" one, which loads data on demand, pages it, scrolls the list up to the selected entry, automatically displays scrollbars, and saves its state after PostBack.

  • Processing speed

    Operates perfectly with tables, containing tens of thousands of entries, loads data on demand, and automatically checks loaded data in order to avoid extra requests by using client-side caching.

  • AJAX support

    Built-in AJAX support provides independence from additional components and frameworks.

  • Data check

    Our component checks the state of the data source and displays relevant data without reloading the page.

  • Appearance

    APNSoft DataGrid is very flexible in customization. Skin support allows a professional appearance to be easily created with ready-to-use skins. The form for editing entries can be configured by the developer independently.

  • Flexible templates

    A flexible structure of templates allows for combining data from different fields, processing conditional formatting, and creating calculated columns. By using templates, you can create complete integrated solutions on the basis of a single DataGrid component.

  • Data formatting

    Universal multilanguage support allows for formatting and displaying data in several languages simultaneously.

  • Intuitive model

    APNSoft DataGrid represents an obvious, easily understandable model-a set of columns and rows and a set of options for their interaction.


ASP.NET DataGrid Control - Features

APNSoft Controls [4.5.2.20]
DataGrid > Features

Standards-Based Software
  • DataGrid output is XHTML 1.1 compliant.
  • Ready for ASP.NET 2.0, 3.5, 4.0 & 4.5. Visual Studio 2005, 2008, 2010 & 2012.
  • Based on industry standards: XML and CSS.

Easy-to-Use Software
  • Simplicity. No complex API.
  • Uses the default style and data to see the result immediately.
  • Compact Documentation.
  • C# and VB.NET examples included.

Cross-Browser Support
  • APNSoft DataGrid offers full up-level cross-browser support for IE 5.5+, Firefox 0.8+, Google Chrome 6.0+, Mozilla 1.4+, Netscape 7.0+, Opera 7.5+, and Safari 1.2+.

"Smart" component
  • Loads data on demand using AJAX.
  • High Processing Speed. Operates perfectly with tables, containing tens of thousands entries.
  • Automatically displays scrollbars.
  • Saves its state after PostBack.
  • Scrolls the list up to the selected entry.
  • Automatic column sizing (Best Fit).
  • Checks the state of data source and displays relevant data.
  • Client-side caching. Automatically checks loaded data in order to avoid extra requests.
  • Support for SEO (Search Engine Optimization).
  • Health Checking. Generates client-side messages which allow developers control the component status.

Highly Customizable Look
  • Colors, sizes, borders and fonts can all be customized to visually integrate with any project.
  • Support for Skins. Collection of free, ready-to-use DataGrid skins.
  • The visual appearance is specified with CSS.
  • Support for background images.
  • Alternating rows support.
  • CSS customization for rows and columns.
  • Support for transparency and shadows.

Rich featured
  • Resizable and Sortable columns.
  • Export to Excel, HTML and custom format (PDF, Images, etc.).
  • Context Menu for rows and headers.
  • Support for fixed (frozen) columns.
  • Support for fixed (summary) row.
  • Row Filter support.
  • Data formatting.
  • Support for columns with Line Numbers.
  • Support for hovered rows.
  • Column Ordering.
  • CheckBoxes, DropDowns, Images, Links, etc.
  • Flexible templates. Allows combining data from different fields, processing conditional formatting and creating calculated columns. Automatically identifies the type of applicable template (ASCX, XSL or HTML). Support for external parameters.
  • Support for custom editor. The form for editing entries can be configured independently.
  • Support for cell editing with tabbing through editable cells.
  • Click/Double-click row events.
  • Built-in paging support.
  • Customizable Toolbar. Support for custom buttons.
  • Absolute or static positioning.

Flexible Programming Options
  • Data binding support. DataGrid includes the DataSource property and the DataBind() method and supports different data sources: DataView, DataTable, DataSet, DataReader and any object that implements IEnumerable interface.
  • DataGrid items can be defined programmatically.
  • Internal AJAX engine. Support for user-defined asynchronous (AJAX) calls to the server.
  • Support for different running modes: CallBack and PostBack.
  • ASP.NET AJAX compatibility.
  • Additional support for row uniqueness.
  • Support for client-side and server-side events and methods.
  • ViewState maintenance.
  • Represents an obvious, easily understandable model - a set of columns and rows.

Other Features
  • Multiple component instances on a single page are allowed.
  • Support for Unicode characters. Universal Multilanguage support allows formatting and displaying data in several languages simultaneously.
  • Generated code is dramatically small.


ASP.NET DataGrid Control - Component Parts

APNSoft Controls [4.5.2.20]
DataGrid > Component Parts
  1. The Rows collection.
    Customized via Skin's CSS Style classes:
    .RowsDIV{} .RowsTABLE{}

  2. The Row.
    Customized via Skin's CSS Style classes:
    .RowEvenTR{}
.RowSelectedTR{}
.RowHoveredTR{}

  3. Grid's Header.
    Customized via .HeaderDIV{} class in the Skin's CSS Style.

  4. The Column.
    Customized via Skin's CSS Style classes:
    .ColumnResizedDIV{} .ColumnFixedDIV{}

  5. Header's Cell.
    Customized via Skin's CSS Style classes:
    .HeaderTD{} .HeaderHoveredTD{}
    The GridColumn.HeaderText property specifies the text displayed in the header section of the column.

  6. Sort Arrows.
    Specified by the images in the Skin Folder:
    SortArrowAsc.gif SortArrowDesc.gif

  7. Bottom Bar.
    Customized via Skin's CSS Style classes:
    .BottomBarDIV{} .BottomBarTABLE{}
    The layout of elements on Bottom Bar is defined via template applied by using the GridBottomBar.Template property.

  8. Button on the Bottom Bar.
    Presented by the Button node in the Bottom Bar's Template. Customized via Skin's CSS Style classes:
    .BottomBarButtonTD{} .BottomBarButtonHoveredTD{}

  9. Page number.
    Presented by the Info node (and Data="Pages" node attribute) in the Bottom Bar's Template.

  10. Separator on the Bottom Bar.
    Presented by the Separator node in the Bottom Bar's Template.

  11. The Rows info.
    Presented by the Rows node (and Data="Rows" node attribute) in the Bottom Bar's Template.

  12. Status Bar.
    Presented by the StatusBar node in the Bottom Bar's Template.

  13. Context Menu.
    Use the ContextMenuHeader.Template property to specify the template for column headers or ContextMenuRow.Template property to specify the template for rows. Customized via .ContextMenuDIV{} class in the Skin's CSS Style.

  14. Item in Context Menu.
    Presented by the item node in the Context Menu Template. Customized via Skin's CSS Style classes:
    .ContextMenuItemTD{} .ContextMenuItemHoveredTD{}

  15. Icon of Item in Context Menu.
    Presented by the icon node attribute in the Context Menu Template.

  16. Text of Item in Context Menu.
    Presented by the title node attribute in the Context Menu Template.

  17. Separator in Context Menu.
    Presented by the separator node in the Context Menu Template. Customized via .ContextMenuSeparatorTD{} class in the Skin's CSS Style.


ASP.NET DataGrid Control - Deployment

APNSoft Controls [4.5.2.20]
DataGrid > Deployment

Most of the time, all you need to do is to add main dll library to your web application and write two lines of code on the WebForm:

  1. Copy the APNSoftControls.dll assembly into the Bin directory of your web application.

  2. Add the following line of code to the top of your page:

    <%@ Register TagPrefix="APNSoft" Namespace="APNSoft.WebControls" Assembly="APNSoftControls" %>

  3. Add the following line of code anywhere within your page to embed the DataGrid:

    <APNSoft:APNSoftDataGrid id="myDataGrid" runat="server" />

For more information about adding controls to an ASP.NET Web Page, see this page.


ASP.NET DataGrid Control - Binding to Data

APNSoft Controls [4.5.2.20]
DataGrid > Binding to Data

APNSoft DataGrid displays data obtained from a database or other data source. The data is presented in tabular format. To bind to a data source, set the DataSource property and call the DataBind() method. DataGrid supports different data sources: DataView, DataTable, DataSet, DataReader and any object that implements IEnumerable interface.

[C#]
protected void Page_Load(object sender, EventArgs e)
{
    //Define SQL query
    string SqlQuery = @"SELECT CustomerID, CompanyName, ContactName FROM Customers";

    //Get DataTable
    DataTable myDataSource = GetDataTable(SqlQuery);

    //Set the data source
    myDataGrid.KeyFieldName = "CustomerID";
    myDataGrid.DataSource = myDataSource;
    myDataGrid.DataBind();
}

[VB.NET]
Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

    'Define SQL query
    Dim SqlQuery As String = "SELECT CustomerID, CompanyName, ContactName FROM Customers"

    'Get DataTable (MS Access Database)
    Dim myDataSource As DataTable = GetDataTable(SqlQuery)

    'Set the data source
    myDataGrid.KeyFieldName = "CustomerID"
    myDataGrid.DataSource = myDataSource
    myDataGrid.DataBind()

End Sub

Also, APNSoft DataGrid has the DataSourceID property. This property can be used to refer to actual .NET data source object (SqlDataSource) from which the DataGrid retrieves its list of data items.

[ASPX]
<asp:SqlDataSource id="mySqlDataSource" runat="server"
    DataSourceMode="DataReader"
    ConnectionString="..."
    SelectCommand="..." />

<APNSoft:APNSoftDataGrid id="myDataGrid" runat="server"
    DataSourceID="mySqlDataSource" />


ASP.NET DataGrid Control - Appearance Customization

APNSoft Controls [4.5.2.20]
DataGrid > Appearance Customization

APNSoft DataGrid supports easy appearance customization through Skins. A Skin is a folder that contains one CSS Style (Style.CSS) and a set of images:

DataGrid consists of the elements: Header, Columns, Rows, Bottom Bar, etc. Each DataGrid element corresponds to an image or CSS class. Images and CSS classes have the predefined names. During customization you can change contents of these images/classes.

To link the control with Skin, use the SkinFolder property:

<APNSoft:APNSoftDataGrid id="myDataGrid" runat="server"
    SkinFolder = "~/Skins/GrayScale/" />

The collection of ready-to-use skins is included in installer. DataGrid has a default Skin to see the result immediately.


ASP.NET DataGrid Control - Templates

APNSoft Controls [4.5.2.20]
DataGrid > Templates

Various parts of the DataGrid can be configured by using templates. Templates are easy to use powerful tools, which allow changing component's appearance and behaviour flexibly on developer's demand.

Templates applied to columns.
  • HTML template
    HTML Template is a regular text file with HTML elements: tables, images, controls, etc. Template can include variables, instead of which data is inserted. Available variables:

    • $ComponentID$ - displays a unique Grid's identifier.
    • $RowID$ - displays a unique row's identifier.
    • $CellValue$ - displays the value of the current cell.
    • $ColumnName$ - displays the name of the current column.
    • $CustomerID$ - displays data from the column "CustomerID". The column can have any name.

    Also, template can include user-defined variables. This allow developers to use external parameters for templates. The GridColumn.SetTemplateVariable() method is used to set custom variables.

  • XSL Template
    XSL Template is more flexible than HTML template, because it includes XSL elements. XSL Template allows comparing/modifying data without a loss in performance. For example, under conditional formatting you must first analyze values of fields and then apply the formatting.

    XSL Template must include two key elements: the <xsl:call-template name="Main" /> and the <xsl:template name="Main">. The code below analyzes values in the "Quantity" column and fills them with red color if value is more than 20:

    <?xml version="1.0" encoding="UTF-8" ?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
    <xsl:output method="xml" version="1.0" indent="no" omit-xml-declaration="yes" />

    <xsl:template match="/">
        <xsl:call-template name="Main" />
    </xsl:template>

    <xsl:template name="Main">
        <xsl:choose>
            <xsl:when test="$Quantity$ &gt; 20">
                <font color="red">$Quantity$</font>
            </xsl:when>
            <xsl:otherwise>$Quantity$</xsl:otherwise>
        </xsl:choose>
    </xsl:template>

</xsl:stylesheet>

  • ASCX Template (User Control)
    ASCX Template is most flexible because it allows developer to organize and format column data by using the preferred programming language (C# or VB.NET). ASCX Template can include the fields GridRow and GridColumn which must be declared as public. You can use these fields to have access to the Row/Column in Template's code.

    [C#]
    public APNSoft.WebControls.GridColumn GridColumn = null;
public APNSoft.WebControls.GridRow GridRow = null;
    [VB.NET]
    Public GridColumn As APNSoft.WebControls.GridColumn = Nothing
Public GridRow As APNSoft.WebControls.GridRow = Nothing

    DataGrid automatically identifies the type of applicable template. To apply template to the column, use the GridColumn.Template property.

Template applied to Bottom Bar.

This template is an XML file, which defines the structure and the layout of elements on Bottom Bar. Available elements:
  • <BottomBar /> - the root element. Includes buttons, separators, etc.
  • <Button /> - places the button for a certain action. Available standard buttons:

    <Button Action="PageFirst" Title="First Page" />
<Button Action="PagePrev" Title="Previous Page" />
<Button Action="PageNext" Title="Next Page" />
<Button Action="PageLast" Title="Last Page" />
<Button Action="RowNew" Title="New Row" />
<Button Action="RowFilter"
    TitleNoFilter="There is no current filter."
    TitleFilterON="Filter is switched ON. Click to switch OFF the filter."
    TitleFilterOFF="Filter is switched OFF. Click to switch ON the last saved filter."
/>
<Button Action="ExportToExcel" Title="Export to Excel" />
<Button Action="ExportToHTML" Title="Export to HTML" />

    Also you can extend Bottom Bar with custom buttons, which make DataGrid more relevant to users. You can use custom buttons for Export or for launching a client-side code:

    <Button Action="Custom" Title="..." ClientCode="..." Icon="..." IconOver="..." />
<Button Action="ExportCustom" Title="..." Parameter="..." Icon="..." IconOver="..." />

    The Icon and IconOver attributes specify images for a button. Image files must be located in the Skin Folder.

    Buttons support the click and double-click events by using the EventType attribute:

    <Button Action="..." EventType="Click" />
<Button Action="..." EventType="DoubleClick" />

  • <Info /> - displays the information panel to show, for example, the page number. Available panels:

    <Info Data="Pages" Title="Pages">Page $PageNumber$ of $PagesInTotal$.</Info>
<Info Data="Rows" Title="Rows">Rows $ItemFirst$ to $ItemLast$ of $ItemsInTotal$.</Info>

  • <StatusBar /> - displays the status bar. Example:

    <StatusBar Title="Status Bar" />

  • <Separator /> - displays a vertical line.
  • <Spacer /> - sets the blank space in pixels. Example:

    <Spacer Width="2" />

Template is applied to a Bottom Bar by using the GridBottomBar.Template property.

Template applied to Context Menu.

This template is an XML file with items and separators. Available elements:
  • <ContextMenu /> - the root element for entire template. Does not include attributes.
  • <item /> - one menu item element. Available attributes:

    • id - specifies a unique identifier for the element.
    • title - specifies the text (caption) displayed for the item.
    • onclick - specifies the client-side code to be launched when the item is clicked.
    • icon - specifies the name of item's icon image. The icon image displayed at the left side of the item and must be located in the Skin Folder.
  • <separator /> - element for separator. Available attributes:

    • id - specifies a unique identifier for the element.

Template for Context Menu can include variables, instead of which data is inserted. Available variables:
  • $ComponentID$ - displays a unique Grid's identifier.
  • $RowID$ - displays a unique row's identifier.
  • $ColumnIndex$ - displays the current column index.
  • $ColumnName$ - displays the current column name.
  • $CellValue$ - displays the content of the current cell.
  • $CellValueText$ - displays the text of the current cell.
  • $CellValueTextShort$ - displays the short text (12 symbols with "...") of the current cell.
  • $CellValueEncoded$ - displays the encoded text of the current cell. This value can be used as a parameter for JavaScript function. To decode this value, use the dg.DecodeCellValue(CellValue) client-side procedure.
Use the GridContextMenuHeader.Template and GridContextMenuRow.Template properties to apply a template for Context Menu.


ASP.NET DataGrid Control - Edit Form

APNSoft Controls [4.5.2.20]
DataGrid > Edit Form

Edit Form is used to create a new entry or edit a current one. Edit Form is an .ascx file (User Control) to be configured by the developer independently. The DataGrid automatically loads Edit Form and displays it at the moment when user presses button "insert" or "update".

The APNSoftDataGrid.EditForm.Path property is used to inform the DataGrid which .ascx file is applied as an editing form.

In order to create a new entry the user presses the button, which performs a standard client-side procedure dg.OpenFormForInsert(). The procedure dg.OpenFormForUpdate('$RowID$') is used to open the form in "update" mode. Bottom Bar already includes the standard button for opening Edit Form in "insert" mode.

The Edit Form itself may contain buttons, which use standard client-side procedures:
  • dg.InsertRow(CloseEditForm) - for "insert".
  • dg.UpdateRow(CloseEditForm) - for "update".
  • dg.CloseEditForm() - for closing the form.
The Edit Form is not closed automatically if the CloseEditForm=false.

For data validation use the dg.GetEditFormElement(GridID, ElementID) client-side procedure. It returns the Element on the Edit Form. By using this method, any element on the Edit Form can be validated on the client side before request to the server.


ASP.NET DataGrid Control - Client-side API

APNSoft Controls [4.5.2.20]
DataGrid > Client-side API

  • dg.AddRowFilter(GridID, Filter);
    Adds a filter expression to the current Grid's filter expression.

  • dg.CallTheServer(GridID, RowID, ColumnName, CellValue, Parameter);
    Initiates a user-defined asynchronous (AJAX) call to the server. Parameter is a string value that is passed from the client-side procedure to the server-side procedure. For example, you can write conditional branches within a method depending on a Parameter's value.

  • dg.ClearCache(GridID);
    Deletes the cached pages of Grid.

  • dg.ClearPageCache(GridID);
    Deletes the cached data for the current Grid page.

  • dg.CloseEditForm();
    Closes the Edit Form.

  • dg.DecodeCellValue(CellValue);
    Decodes the cell value received from the column template (from the $CellValueEncoded$ variable).

  • dg.DecodeValue(Value);
    Decodes the value received from the server-side event-handling method. Can be used for decoding the Parameter value received by the client-side function applied by the ClientSideAfterCallBack property.

  • dg.DeleteRow(RowID);
    Deletes the Row by its ID.

  • dg.FindSelectedRow(GridID);
    Finds the page where the selected row is located. Returns 'true' if the row was found, otherwise the function returns 'false'.

  • dg.GetCellValue(GridID, RowID, ColumnName);
    Returns the cell value.

  • dg.GetColumnName(GridID, ColumnIndex);
    Returns the name of the specified column.

  • dg.GetEditFormElement(GridID, ElementID);
    Returns the Element on the Edit Form. By using this method, any element on the Edit Form can be validated on the client side before request to the server.

  • dg.GetFullGridID(GridID);
    Gets the unique identifier of the DataGrid.

  • dg.GetRowFilter(GridID);
    Gets the expression used to filter which rows are viewed in the DataGrid.

  • dg.GetWindowWidth();
    Gets the width of window in pixels.

  • dg.GetWindowHeight();
    Gets the height of window in pixels.

  • dg.InitGrid(GridID);
    Initializes the DataGrid control.

  • dg.InitColumnWidths(GridID, PostBack);
    Initializes columns of the DataGrid control. Sets all columns at an equal percent fraction of the DataGrid width. The initialization is not performed if the page is loaded after PostBack and the PostBack=false.

  • dg.InsertRow(CloseEditForm);
    Adds a record to the Grid. The Edit Form is not closed automatically if the CloseEditForm=false.

  • dg.Refresh(GridID);
    Refreshes the content of the DataGrid.

  • dg.RemoveRowFilter(GridID);
    Removes a filter from the DataGrid.

  • dg.SetCellValue(GridID, RowID, ColumnName, CellValue);
    Sets the value of the specified cell on the current page.

  • dg.SetGridHeight(GridID, Height);
    Sets the height of the DataGrid in pixels. Range: 60-2048.

  • dg.SetGridWidth(GridID, Width);
    Sets the width of the DataGrid in pixels. Range: 100-4096. Example:

    <div onclick="dg.SetGridWidth('dg1', 500);">Set width</div>

  • dg.SetPage(GridID, PageNumber);
    Sets the grid page number to be shown.

  • dg.SetRowFilter(GridID, Filter);
    Sets the expression used to filter which rows are viewed in the DataGrid. Filter - a string that specifies how rows are to be filtered.

    <div onclick="dg.SetRowFilter('dg1', 'CustomerID Like \'A%\'');">SetRowFilter</div>
<div onclick="dg.SetRowFilter('dg1', 'CustomerID = \'ANTON\'');">SetRowFilter</div>

  • dg.ScrollToTop(GridID);
    Scrolls the contents of the grid to the top position.

  • dg.ScrollToLeft(GridID);
    Scrolls the contents of the grid to the left position.

  • dg.Sort(GridID, ColumnIndex, Direction);
    Sorts the data in the DataGrid. Direction values: '1' - ascending order, '2' - descending order. Example:

    <div onclick="dg.Sort('dg1', 1, '2');">Sort</div>

  • dg.UpdateRow(CloseEditForm);
    Updates the current record. The Edit Form is not closed automatically if the CloseEditForm=false.


ASP.NET DataGrid Control - APNSoftDataGrid Members

APNSoftDataGrid Members

APNSoftDataGrid overview

Public Static (Shared) Properties

EditFormMethod | Gets a value indicating the Edit Form is opened for INSERT or UPDATE. Default value is Undefined. When you open the Edit Form for UPDATE, fill in form fields with selected row data. Use the EditFormRow property to get the selected row.
EditFormRow | Gets the selected row, used to fill in the Edit Form before update.

Public Instance Constructors

APNSoftDataGrid Constructor Initializes a new instance of the APNSoftDataGrid class.

Public Instance Properties

AutoPostBackOnRowClick | Specifies whether the control causes a postback to the server when a row is clicked. Default value is false.
AutoPostBackOnRowDblClick | Specifies whether the control causes a postback to the server when a row is double-clicked. Default value is false.
AutoResize | Gets or sets a value specifying the way for DataGrid to be resized (if necessary) when data is loaded. Default value is None. When the property's value is WidthAndHeight, DataGrid displays data without scrollbars.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
BottomBar | Gets the Bottom Bar.
CellEditingEnabled | Gets or sets a value specifying whether the cell editing is enabled. Triggered by clicking twice on a cell. Default value is false.
ClientSideAfterCallBack | Gets or sets the client-side code to be launched after CallBack request. Property value can include variables $ComponentID$, $Command$ and $Parameter$, instead of which data is inserted.
ClientSideAfterInit | Gets or sets the client-side code to be launched after DataGrid initialization. Property value can include variable $ComponentID$, instead of which data is inserted.
ClientSideBeforeCellUpdate | Gets or sets the client-side code (procedure) to be launched before Cell Update. This code can be used for data validation and auto correction. Property value can include variables $ComponentID$, $RowID$, $ColumnName$ and $CellValue$, instead of which data is inserted.
ClientSideOnContextMenuHeader | Gets or sets the client-side code to be launched before the context menu for header is displayed. Property value can include variables $ComponentID$, $ColumnIndex$ and $ContextMenu$, instead of which data is inserted. The $ContextMenu$ is a DIV element with context menu data.
ClientSideOnContextMenuRow | Gets or sets the client-side code to be launched before the context menu for rows is displayed. Property value can include variables $ComponentID$, $RowID$, $CellValue$ and $ContextMenu$, instead of which data is inserted. The $ContextMenu$ is a DIV element with context menu data.
ClientSideOnPage | Gets or sets the client-side code to be launched when a new page is opened. Property value can include variables $ComponentID$ and $PageNumber$, instead of which data is inserted.
ClientSideOnRowClick | Gets or sets the client-side code to be launched when a row is clicked. Property value can include variables $ComponentID$, $RowID$, $ColumnName$ and $CellValue$, instead of which data is inserted.
ClientSideOnRowDblClick | Gets or sets the client-side code to be launched when a row is double-clicked. Property value can include variables $ComponentID$, $RowID$, $ColumnName$ and $CellValue$, instead of which data is inserted.
Columns | Gets the collection of columns.
ConfirmTextDelete | Gets or sets the text to be shown on the confirmation dialog before the record is deleted. The prompt is automatically enabled if this property is set.
ConfirmTextInsert | Gets or sets the text to be shown on the confirmation dialog before the record is inserted. The prompt is automatically enabled if this property is set.
ConfirmTextUpdate | Gets or sets the text to be shown on the confirmation dialog before the record is updated. The prompt is automatically enabled if this property is set.
ContextMenuHeader | Gets the Context Menu for Header.
ContextMenuRow | Gets the Context Menu for Row.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
DataSourceID | Gets or sets the ID of the control from which the DataGrid retrieves its list of data items.
EditForm | Gets the Edit Form.
FixedColumnsOpacity | Gets or sets the opacity factor applied to the fixed columns. Range: 0-100. Default value is 100 (columns are NOT transparent).
Height | Gets or sets a value indicating the height of the DataGrid in pixels. Range: 60-2048.
HighlightHoveredRow | Gets or sets a value specifying whether the hovered row is highlighted. Default value is true.
HighlightSelectedRow | Gets or sets a value specifying whether the selected row is highlighted. Default value is true.
KeyFieldName | Gets or sets the name of column that uniquely identifies each record stored in the table. The key field is commonly used in a handler for an event, such as UpdateCommand or DeleteCommand, as part of an update query string to revise a specific record in the data source. The key field helps the update query string identify the appropriate record to modify.
MessageDeleting | Specifies a message to be displayed when control deletes a record. Default value is Deleting....
MessageInserting | Specifies a message to be displayed when control inserts a record. Default value is Inserting....
MessageLoading | Specifies a message to be displayed when control loads records. Default value is Loading....
MessageNoRecords | Specifies a message to be displayed when there are no records in the data source. Default value is No records to display..
MessageProcessing | Specifies a message to be displayed when control launches custom asynchronous call. Default value is Processing....
MessageReady | Specifies a message to be displayed when control is ready for an action. Default value is Ready..
MessageUpdating | Specifies a message to be displayed when control updates a record. Default value is Updating....
Mode | Gets or sets the running mode of the DataGrid.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
PageCount | Gets the total number of pages in the grid.
PageSize | Gets or sets the maximum number of rows to be displayed on a single page of the DataGrid control. Range: 1-10000. The default value is 20. The total number of pages is calculated automatically depending on data amount.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
RightClickSelect | Gets or sets a value specifying whether a row is selected when the user right-clicks on the row. Default value is true. Note that the property value must be true if you use context menu for rows.
RowFilter | Gets or sets the expression used to filter which rows are viewed in the DataGrid.
Rows | Gets the collection of rows.
SEOEnabled | Gets or sets a value indicating whether the DataGrid renders an additional NOSCRIPT section with links which correspond to DataGrid rows. Default value is false.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
Width | Gets or sets a value indicating the width of the DataGrid in pixels. Range: 100-4096.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

Public Instance Methods

AddContextMenu | Adds Context Menu into the collection.
ApplyRowFilter | Sets a filter to the rows.
DataBind | Creates a binding between the DataGrid control and a data source.
GetSelectedRow | Returns the Selected Row.
GetSortedColumn | Returns the Sorted Column.
ResetColumnWidths | This method sets all columns at an equal percent fraction of the DataGrid width.
ResetPageNumber | This method sets a Page Number to its default value.
ResetScrollbars | This method sets Scrollbars to default values.
ResetSelectedRow | This method removes the 'Selected' attribute from the row.
ResetSortedColumn | This method removes the 'Sorted' attribute from the column.
SetPage | Sets the current page number. This method must be called after the DataBind() method.
SortRows | Sorts the rows in the collection.

Public Instance Events

CallTheServer | Occurs on the server side when we call the server from client side by launching the dg.CallTheServer(); procedure.
CellValueChanged | Occurs on the server side when the cell value is changed.
DeleteCommand | Occurs on the server side when an delete command is fired.
ExportCustom | Occurs on the server side when the Custom Export command is fired.
ExportToExcel | Occurs on the server side when the Export To Excel command is fired.
ExportToHTML | Occurs on the server side when the Export To HTML command is fired.
InsertCommand | Occurs on the server side when an insert command is fired.
OnRowClick | Occurs on the server side when the row is clicked or double-clicked.
PageNumberChanged | Occurs on the server side after the page is changed.
SortCommand | Occurs on the server side when a sort command is fired.
UpdateCommand | Occurs on the server side when an update command is fired.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET Include Control - Overview

APNSoft Controls [4.5.2.20]
Include > Overview

APNSoft Include is a component (Server Control) for ASP.NET. It allows you to include HTML files into your ASP.NET pages as Server Side Includes (SSI). The component is more flexible than standard #include directive.

The target URL can be used as a source data for the Include. It means the pages can be included via HTTP protocol from the local or a remote server.


ASP.NET Include Control - Features

APNSoft Controls [4.5.2.20]
Include > Features

  • Easy-to-Use Software. Simplicity. No complex API. Compact Documentation.
  • Ready for ASP.NET 2.0, 3.5, 4.0 & 4.5. Visual Studio 2005, 2008, 2010 & 2012.
  • The pages can be included via URL from the local or remote server.
  • SSL compatibility. APNSoft Include can retrieve pages from the servers which use HTTPS protocol.
  • Browser Emulation. Component emulates the IE 6.0 behavior. This is done automatically without any additional effort on the developer's side.
  • The length of time, until the request times out, can be customized.
  • The Include text can be defined directly.
  • Flexible in usage. Can be used in Code Behind.
  • Support for Unicode characters.
  • C# and VB.NET examples included.


ASP.NET Include Control - Deployment

APNSoft Controls [4.5.2.20]
Include > Deployment

Most of the time, all you need to do is to add main dll library to your web application and write two lines of code on the WebForm:

  1. Copy the APNSoftControls.dll assembly into the Bin directory of your web application.

  2. Add the following line of code to the top of your page:

    <%@ Register TagPrefix="APNSoft" Namespace="APNSoft.WebControls" Assembly="APNSoftControls" %>

  3. Add the following line of code anywhere within your page to embed the Include:

    <APNSoft:APNSoftInclude id="myInclude" runat="server" />

For more information about adding controls to an ASP.NET Web Page, see this page.


ASP.NET Include Control - APNSoftInclude Members

APNSoftInclude Members

APNSoftInclude overview

Public Instance Constructors

APNSoftInclude Constructor Initializes a new instance of the APNSoftInclude class.

Public Instance Properties

BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
IncludeFileURL | Gets or sets the target url is used as a source text data for the include.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
RequestURLTimeout | Request URL Timeout in milliseconds (20-200000).
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

Public Instance Methods

DataBind Creates a binding between the Include control and a data source.

Public Instance Events

DataBinding Occurs on the server side when the control binds to a data source.

See Also

APNSoftInclude Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - Overview

APNSoft Controls [4.5.2.20]
Menu > Overview

APNSoft Menu is an ASP.NET server control with AJAX support to display both statically and dynamically created menus on your web pages. It is a flexible, reliable, powerful, and easy-to-use menu system. Anyone can use it, no matter what level of experience you have.

Menu has been designed so that it integrates into the look and feel of any web site. Layout can be controlled by the CSS-style definitions and user-defined images. The Skins Library includes many ready-to-use menu skins. All of them are free of charge.

The product uses XML for defining menu structure since XML is the most convenient format for structured data. The generated HTML and client JavaScript code is compact and fast. It is compatible with all popular browsers.


ASP.NET Menu Control - Features

APNSoft Controls [4.5.2.20]
Menu > Features

Standards-Based software
  • Menu output is XHTML 1.1 compliant.
  • Ready for ASP.NET 2.0, 3.5, 4.0 & 4.5. Visual Studio 2005, 2008, 2010 & 2012.
  • Based on industry standards: XML and CSS.

Easy-to-Use Software
  • Simplicity. No complex API.
  • Uses the default style and structure to see the result immediately.
  • Compact Documentation.
  • C# and VB.NET examples included.

Cross-Browser Support
  • APNSoft Menu offers full up-level cross-browser support for IE 5.5+, Firefox 0.8+, Google Chrome 6.0+, Mozilla 1.4+, Netscape 7.0+, Opera 7.5+, and Safari 1.2+.

Highly Customizable Look
  • Colors, sizes, borders and fonts can all be customized to visually integrate with any project.
  • Support for icons, background images, separators, user-defined images for submenu arrows.
  • Each menu item, submenu, separator can be customized separately.
  • Each submenu can be positioned separately.
  • Menu items can include HTML formatting.
  • Menu can be based only on images.
  • Flexible templates. Automatically identifies the type of applicable template (ASCX, XSL or HTML). Conditional Formatting for items, support for external parameters.
  • The visual appearance is specified with CSS.
  • Support for Skins. Collection of free, ready-to-use menu skins.

Rich featured
  • User roles (Security Trimming).
  • Support for Path Highlighting.
  • Changeable opening direction for submenus (horizontal and vertical).
  • Vertical, horizontal orientation.
  • Absolute or static positioning.
  • Support for transition effects.
  • Support for CSS and PNG shadows.
  • Semi-transparent menu.
  • Support for scrollable menus.
  • Support for tooltips.
  • Changeable horizontal and vertical overlap a submenu has over its parent Menu Item.
  • Support for Move/Click events for Open/Close menu.
  • Expand Delay can be customized.

Intelligent Behavior
  • Loads data on demand using AJAX.
  • Automatically checks loaded data in order to avoid extra requests.
  • Structure checking. APNSoft Menu checks the structure for duplicated IDs and wrong-referenced elements in the database table with menu structure.
  • Saves its state after PostBack.
  • Automatically displayed over HTML select boxes, Flash movies and other ActiveX components.
  • Search Engine Optimization. Allows search engines index your site properly.
  • Special repositioning logic prevents "stacking" for submenus.
  • Health Checking. Can generate client-side messages which allow developers control the menu status.

Flexible Programming Options
  • Server-side API. APNSoft Menu provides an extremely rich and powerful server-side API allowing developer to add, remove or edit menu elements and element collections.
  • Data binding support. Menu includes the DataSource property and the
    DataBind() method.
  • The Menu Structure is defined through XML and can be obtained from a static file or programmatically.
  • Has support to use the Web.sitemap file as a standard menu structure.
  • Support for client-side and server-side events.

Other Features
  • Multiple menus on a single page are allowed.
  • Generated code is dramatically small.
  • Support for Unicode characters.


ASP.NET Menu Control - Component Parts

APNSoft Controls [4.5.2.20]
Menu > Component Parts
  1. Main Menu.
    Can be horizontal or vertical (the APNSoftMenu.Orientation property). Customized via .MainMenuDIV{} class in the Skin's CSS Style.

  2. Main Menu: Item.
    Presented by the item node in the XML Structure. Customized via Skin's CSS Style classes:
    .MainMenuItemTD{}
.MainMenuItemHoveredTD{}
.MainMenuItemSelectedTD{}

  3. Main Menu: Item's Text.
    Presented by the title node attribute in the XML Structure. Customized via .TitleTD{} class in the Skin's CSS Style.

  4. Main Menu: Arrow to submenu.
    Specified by the images in the Skin Folder:
    ArrowDown.gif ArrowDownActive.gif
    Or (if the APNSoftMenu.ExpandDirectionVertical="Upwards"):
    ArrowUp.gif ArrowUpActive.gif

  5. Main Menu: Item's Icon.
    Presented by the icon and iconOver node attributes in the XML Structure. The images must be located in the Skin Folder.

  6. Main Menu: Separator.
    Presented by the separator node in the XML Structure. Customized via .SeparatorVerticalTD{} class in the Skin's CSS Style.

  7. Submenu.
    Customized via .SubMenuDIV{} class in the Skin's CSS Style.

  8. Submenu: Item.
    Presented by the item node in the XML Structure. Customized via Skin's CSS Style classes:
    .SubMenuItemTD{}
.SubMenuItemHoveredTD{}
.SubMenuItemSelectedTD{}

  9. Submenu: Item's Icon.
    Presented by the icon and iconOver node attributes in the XML Structure. The images must be located in the Skin Folder.

  10. Submenu: Item's Text.
    Presented by the title node attribute in the XML Structure. Customized via .TitleTD{} class in the Skin's CSS Style.

  11. Submenu: Separator.
    Presented by the separator node in the XML Structure. Customized via .SeparatorHorizontalTD{} class in the Skin's CSS Style.

  12. Submenu: Arrow to submenu.
    Specified by the images in the Skin Folder:
    ArrowRight.gif ArrowRightActive.gif


ASP.NET Menu Control - Deployment

APNSoft Controls [4.5.2.20]
Menu > Deployment

Most of the time, all you need to do is to add main dll library to your web application and write two lines of code on the WebForm:

  1. Copy the APNSoftControls.dll assembly into the Bin directory of your web application.

  2. Add the following line of code to the top of your page:

    <%@ Register TagPrefix="APNSoft" Namespace="APNSoft.WebControls" Assembly="APNSoftControls" %>

  3. Add the following line of code anywhere within your page to embed the Menu:

    <APNSoft:APNSoftMenu id="myMenu" runat="server" />

For more information about adding controls to an ASP.NET Web Page, see this page.


ASP.NET Menu Control - Defining the Structure

APNSoft Controls [4.5.2.20]
Menu > Defining the Structure

APNSoft Menu uses XML for defining the structure since XML is the most convenient and widespread format for structured data. The XML Structure consists of elements (items and separators):

<Menu>
    <item title="Main Page" />
    <separator />
    <item title="About Us" />
    <item title="Products">
        <item title="Menu" />
        <item title="DataGrid" />
        <item title="TreeView" />
    </item>
    <item title="Contacts" />
</Menu>

The code above creates the following menu (horizontal orientation):

Structure elements:
  • <Menu /> - the root element for entire Menu Structure File. Does not include attributes.
  • <item /> - one item element. Each item element can include other elements. Available attributes:

    • AutoPostBackOnItemClick - specifies a value indicating whether the control causes a postback to the server when the item is clicked.
    • ClientSideOnItemClick - specifies the client-side code to be launched when the item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
    • CSS_ItemHoveredTD - specifies the name of the CSS class used for precise item customization. It is applied to the hovered item TD.
    • CSS_ItemSelectedTD - specifies the name of the CSS class used for precise item customization. It is applied to the selected item TD.
    • CSS_ItemTD - specifies the name of the CSS class used for precise item customization. It is applied to the item TD.
    • CSS_SubMenuDIV - specifies the name of the CSS class used for precise submenu customization. It is applied to the submenu DIV.
    • href, target - the URL and target the browser is directed to when a user clicks the Item. The href attribute can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
    • icon - specifies the name of item's icon image. The icon image displayed at the left side of the item. The icon images must be located in the Skin Folder as specified by the SkinFolder property.
    • iconOver - specifies the name of icon for hovered item.
    • iconWidth, iconHeight - one Item's icon image width and height. Attributes are optional. Control automatically calculates Width and Height of each icon.
    • id - specifies a unique identifier for the element. The attribute is required. If the id attribute is not specified, the component will automatically set it for each item (id="itm1", id="itm2", etc.).
    • image - specifies the name of the picture, used as one menu item. This attribute is used instead of the title attribute. The image file must be located in the Skin Folder as specified by the SkinFolder property.
    • imageOver - specifies the name of the picture, used for hovered item.
    • imageWidth, imageHeight - one Item's image width and height. Attributes are optional. Control automatically calculates Width and Height of each image.
    • SubMenuMarginLeft, SubMenuMarginTop - the width of the left (top) margin of the submenu. Use these attributes to specify the position of every single submenu.
    • Template - specifies the path to item's template file.
    • title - specifies the text (caption) displayed for the item. Can include HTML formatting by using of square brackets ("[" and "]") instead of standard corner brackets ("<" and ">"). Double square brackets ("[[" and "]]") are used to show single square brackets.
    • roles - specifies the collection of comma-separated user roles that are associated with the element. User roles provide developers with an easy and flexible way to control access to menu elements.
    • selected - specifies a value indicating whether the item is selected.
    • tooltip - specifies the text for item's tooltip.

  • <separator /> - element for horizontal or vertical separator. Available attributes:

    • CSS_SeparatorTD - specifies the name of the CSS class used for precise separator customization. It is applied to the separator TD.
    • id - specifies a unique identifier for the element. The attribute is required. If the id attribute is not specified, the component will automatically set it for each separator (id="spr1", id="spr2", etc.).
    • image - specifies the name of the picture, used for separator.
    • imageWidth, imageHeight - one separator's image width and height.
    • roles - specifies the collection of comma-separated user roles that are associated with the element.

Menu element examples:

<item id="i1" title="Home" />
<item id="i1" title="Home" href="~/Default.aspx?ItemID=$ItemID$&amp;Rnd=$Rnd$" />
<item title="Google" href="http://www.google.com" target="_blank" />
<item title="JavaScript" ClientSideOnItemClick="alert('The $Title$ ($ItemID$) is clicked!');" />
<item title="New" icon="IconNew.gif" iconOver="IconNewActive.gif" roles="Admins, Owners" />
<item title="TV Schedule" Template="~/Templates/Template.ascx" />
<item image="Home.jpg" imageOver="HomeActive.jpg" />
<separator image="SeparatorVertical.jpg" />

Attention! Element names and attributes are case-sensitive. Be careful when you're typing in your data.

Applying the XML Structure or Data Source:

You can save the XML definition structure as a file and bind the menu by specifying the StructureFileURL property. APNSoft Menu has support to use the Web.sitemap file as a standard menu structure.

<APNSoft:APNSoftMenu id="myMenu" runat="server"
    StructureFileURL = "~/Structures/Menu.xml" />

You can also apply the XML Document with structure by using the DataSource property. If the menu loads structure from the database, you should set the DataSource property to specify a source of data and call the DataBind() method. To create an appropriate table in the SQL Server, use the following SQL command:

CREATE TABLE [dbo].[Items](
    [id] [nvarchar](20) NOT NULL,
    [pid] [nvarchar](20) NULL,
    [Type] [nvarchar](10) NOT NULL CONSTRAINT [DF_Items_Type] DEFAULT ('item'),
    [title] [nvarchar](250) NULL,
    [href] [nvarchar](250) NULL,
    [target] [nvarchar](100) NULL,
    [tooltip] [nvarchar](250) NULL,
    [icon] [nvarchar](100) NULL,
    [iconOver] [nvarchar](100) NULL,
    [iconWidth] [tinyint] NULL,
    [iconHeight] [tinyint] NULL,
    [image] [nvarchar](100) NULL,
    [imageOver] [nvarchar](100) NULL,
    [imageWidth] [tinyint] NULL,
    [imageHeight] [tinyint] NULL,
    [AutoPostBackOnItemClick] [bit]
        NOT NULL CONSTRAINT [DF_Items_AutoPostBackOnItemClick] DEFAULT ((0)),
    [ClientSideOnItemClick] [nvarchar](250) NULL,
    [selected] [bit] NOT NULL CONSTRAINT [DF_Items_selected] DEFAULT ((0)),
    [CSS_ItemTD] [nvarchar](100) NULL,
    [CSS_ItemHoveredTD] [nvarchar](100) NULL,
    [CSS_ItemSelectedTD] [nvarchar](100) NULL,
    [CSS_SubMenuDIV] [nvarchar](100) NULL,
    [CSS_SeparatorTD] [nvarchar](100) NULL,
    [roles] [nvarchar](50) NULL,
    [Template] [nvarchar](255) NULL
)

You can also build up menu at runtime. APNSoft Menu provides an extremely rich and powerful server-side API allowing developer to add, remove or edit menu elements and element collections. You can programmatically control any item at runtime by using two classes MenuElement and MenuElementCollection.


ASP.NET Menu Control - Appearance Customization

APNSoft Controls [4.5.2.20]
Menu > Appearance Customization

APNSoft Menu supports easy appearance customization through Skins. A Skin is a folder that contains two CSS Styles: Style.CSS and StyleVertical.CSS (for the menu with vertical orientation) and a set of images:

Menu consists of the elements: Main Menu, submenus, items, icons, separators, etc. Each Menu element corresponds to an image or CSS class. Images and CSS classes have the predefined names. During customization you can change contents of these images/classes.

To link the control with Skin, use the SkinFolder property:

<APNSoft:APNSoftMenu id="myMenu" runat="server"
    SkinFolder = "~/Skins/GrayScale/" />

The collection of ready-to-use skins is included in installer. Menu has a default Skin to see the result immediately.


ASP.NET Menu Control - Precise Customization

APNSoft Controls [4.5.2.20]
Menu > Precise Customization

Each single Item, Submenu or Separator can be customized separately by using additional user-defined classes in the Skin's CSS Style. To apply a custom CSS class to the element, you use special attributes in XML Structure.

  1. Item customization

    XML Structure:
    <item title="..."
    CSS_ItemTD="MyClass"
    CSS_ItemHoveredTD="MyClassHovered"
    CSS_ItemSelectedTD="MyClassSelected"
/>

    CSS Style:
    /*Item TD*/
.MyClass
{...}

/*Item TD (Hovered)*/
.MyClassHovered
{...}

/*Item TD (Selected)*/
.MyClassSelected
{...}

  2. Submenu customization

    XML Structure:
    <item title="..." CSS_SubMenuDIV="MyClassSubmenu">
    ...
</item>

    CSS Style:
    /*Submenu: DIV*/
.MyClassSubmenu
{...}

  3. Separator customization

    XML Structure:
    <separator CSS_SeparatorTD="MyClassSeparator" />

    CSS Style:
    /*Separator: TD*/
.MyClassSeparator
{...}


ASP.NET Menu Control - Templates

APNSoft Controls [4.5.2.20]
Menu > Templates

APNSoft Menu supports three types of user-defined templates for additional item customization. Templates are easy to use powerful tools, which allow changing item's appearance flexibly on developer's demand.

  1. HTML template
    HTML Template is a regular text file with HTML elements: tables, images, controls, etc.

  2. XSL template
    XSL Template is more flexible than HTML template, because it includes XSL elements. XSL Template allows comparing/modifying data without a loss in performance. For example, under conditional formatting you must first analyze item's data and then apply the formatting.

    XSL Template must include two key elements: the <xsl:call-template name="Main" /> and the <xsl:template name="Main">. Sample code of XSL Template:

    <?xml version="1.0" encoding="UTF-8" ?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
    <xsl:output method="xml" version="1.0" indent="no" omit-xml-declaration="yes" />

    <xsl:template match="/">
        <xsl:call-template name="Main" />
    </xsl:template>

    <xsl:template name="Main">
        ...
    </xsl:template>

</xsl:stylesheet>

  3. ASCX template (User Control)
    ASCX Template is most flexible because it allows developer to format an item by using the preferred programming language (C# or VB.NET). ASCX Template can include the field MenuElement which must be declared as public. You can use this field to have access to the item in Template's code.

    [C#]
    public APNSoft.WebControls.MenuElement MenuElement = null;
    [VB.NET]
    Public MenuElement As APNSoft.WebControls.MenuElement = Nothing

Templates can include variables, instead of which data is inserted. Available variables:
  • $ComponentID$ - displays the unique identifier of the component.
  • $ItemID$ - displays the unique identifier of the item.
  • $Title$ - displays the text (caption) of the item.

Menu automatically identifies the type of applicable template. To apply template to the item, use the Template attribute:

<item title="HTML" Template="~/Templates/Template.html" />
<item title="XSL" Template="~/Templates/Template.xsl" />
<item title="ASCX" Template="~/Templates/Template.ascx" />


ASP.NET Menu Control - APNSoftMenu Members

APNSoftMenu Members

APNSoftMenu overview

Public Instance Constructors

APNSoftMenu Constructor Initializes a new instance of the APNSoftMenu class.

Public Instance Properties

AutoPostBackOnItemClick | Specifies whether the control causes a postback to the server when an Item is clicked. Default value is false.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
BuilderMode | Turns the Menu into non-standard control. Default value is false.
ClientSideOnItemClick | Gets or sets the client-side code to be launched when an item is clicked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
Elements | Gets the collection of elements.
ExpandDelay | Gets or sets a delay in milliseconds before a submenu expands. Default value is 250.
ExpandDelayHorizontal | Gets or sets a delay in milliseconds for submenus of main menu in horizontal orientation. Default value is 20.
ExpandDirectionHorizontal | Gets or sets the horizontal direction to which submenus expand. Default value is LeftToRight.
ExpandDirectionVertical | Gets or sets the vertical direction to which submenus expand. It is applied to horizontal menu only. Default value is Downwards.
FadeEffect | Specifies whether the control displays the submenus with animated Fade effect. Default value is true.
FadeSpeed | Gets or sets the speed of Fade Effect. Range: 0-50. Default value is 5.
HighlightPath | Gets or sets the value indicating whether the menu highlights the selected item as well as the whole navigation path. Default value is false.
LoadingText | Gets or sets the text displayed in the tooltip while loading load-on-demand content. Default value is Loading....
LoadOnDemand | Specifies whether submenu will be loaded on demand. Default value is false.
Orientation | Specifies the menu orientation. Default value is Horizontal.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
OverlapHorizontal | Specifies the amount of horizontal overlap a submenu will have over its parent item. Default value is -5px.
OverlapVertical | Specifies the amount of vertical overlap a submenu will have over its parent first level horizontal menu. Default value is -4px.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
Roles | Gets or sets the roles the current user belongs to. User roles provide developers with an easy and flexible way to control access to various menu elements. Menu can be assigned to multiple roles.
SaveScrollPosition | Gets or sets the value indicating whether the menu keeps the scroll position for submenus. Default value is true.
SEOEnabled | Gets or sets a value indicating whether the control renders an additional NOSCRIPT section with links let all search engines index your website properly. Default value is false.
ShowStartingNode | Gets or sets a value indicating whether the menu renders the starting node. Default value is true.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
StructureFileURL | Gets or sets the URL to the structure file. If the property is not specified, component uses internal default structure. The property value can be an absolute or relative URI. Menu has support to use the Web.sitemap file as a standard menu structure.
SubMenusClose | Gets or sets a value indicating whether all of the opened submenus are closed by mouse click outside the menu or automatically when the mouse goes away. Default value is Auto.
SubMenusHeight | Gets or sets the maximum height in pixels for submenus. A submenu automatically becomes scrollable if its height less than the real height of its contents.
SubmenusHideOnItemClick | Gets or sets a value indicating whether the submenus should automatically close when an Item is clicked. Default value is false.
SubMenusOpen | Gets or sets a value indicating whether the submenus of the root menu are opened by mouse click or automatically when user moves the mouse pointer over the menu item. Default value is OnMouseOver.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

Public Instance Methods

DataBind | Creates a binding between the Menu control and a data source.
GetSelectedItemID | Returns the selected Item ID.

Public Instance Events

OnItemClick Occurs on the server side when the item is clicked.

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Overview

APNSoft Controls [4.5.2.20]
Rating > Overview

APNSoft Rating is a reach-featured ASP.NET server control with AJAX support, which allows people to easily provide feedback on an article, blog item, product description, etc. In addition to this, the Rating control has an option to display a value by a segment-oriented bar. No complex API; the product provides easily understandable model - collection of segments with IDs and values.


ASP.NET Rating Control - Features

APNSoft Controls [4.5.2.20]
Rating > Features

Standards-Based Software
  • Rating output is XHTML 1.1 compliant.
  • Ready for ASP.NET 2.0, 3.5, 4.0 & 4.5. Visual Studio 2005, 2008, 2010 & 2012.
  • Based on images and CSS.

Easy-to-Use Software
  • Simplicity. No complex API.
  • Segment-oriented. Each segment has ID and value.
  • Compact Documentation.
  • C# and VB.NET examples included.

Cross-Browser Support
  • APNSoft Rating offers full up-level cross-browser support for IE 5.5+, Firefox 0.8+, Google Chrome 6.0+, Mozilla 1.4+, Netscape 7.0+, Opera 7.5+, and Safari 1.2+.

Highly Customizable Look
  • Colors, sizes, images and fonts can be customized to visually integrate with any project.
  • The visual appearance is specified with CSS.
  • Support for background images.
  • Precise Customization. Each segment can be customized separately.
  • Support for templates. Templates give additional flexibility in the disposition for segments.
  • Collection of free, ready-to-use skins.

Rich featured
  • Allows to set or display a value.
  • Customizable fill direction.
  • Vertical or horizontal orientation.
  • Absolute or static positioning.
  • Support for tooltips.

Intelligent Behavior
  • Saves its state after PostBack.
  • Health Checking. Generates client-side messages which allow developers control the component status.

Flexible Programming Options
  • ASP.NET AJAX compatibility. Support for user-defined asynchronous (AJAX) calls to the server.
  • Server-side API allowing developer to add, remove or edit segments and segment collections.
  • Support for client-side and server-side events and methods.
  • ViewState maintenance.

Other Features
  • Multiple Ratings on a single page are allowed.
  • Support for Unicode characters.
  • Generated code is dramatically small.


ASP.NET Rating Control - Component Parts

APNSoft Controls [4.5.2.20]
Rating > Component Parts
  1. Rating control.
    The property SegmentsInTotal specifies the total number of segments.

    Customized via Skin's CSS Style classes:
    .RatingDIV{} .RatingTABLE{}

  2. Segment.
    Specified by the Segment.gif image in the Skin Folder.

  3. Active segment (optional).
    Specified by the SegmentActive.gif image in the Skin Folder.

  4. Disabled segment.
    Specified by the SegmentDisabled.gif image in the Skin Folder.

  5. Disabled and active segment (optional).
    Specified by the SegmentDisabledActive.gif image in the Skin Folder.

  6. Tooltip.
    Specified by the Segment.title property.


ASP.NET Rating Control - Deployment

APNSoft Controls [4.5.2.20]
Rating > Deployment

Most of the time, all you need to do is to add main dll library to your web application and write two lines of code on the WebForm:

  1. Copy the APNSoftControls.dll assembly into the Bin directory of your web application.

  2. Add the following line of code to the top of your page:

    <%@ Register TagPrefix="APNSoft" Namespace="APNSoft.WebControls" Assembly="APNSoftControls" %>

  3. Add the following line of code anywhere within your page to embed the Rating:

    <APNSoft:APNSoftRating id="myRating" runat="server" />

For more information about adding controls to an ASP.NET Web Page, see this page.


ASP.NET Rating Control - Appearance Customization

APNSoft Controls [4.5.2.20]
Rating > Appearance Customization

APNSoft Rating supports easy appearance customization through Skins. A Skin is a folder that contains one CSS Style (Style.CSS) and a set of images:

The Rating control consists of the segments (images). A segment corresponds to an image and/or CSS class. Images and CSS classes have the predefined names. During customization you can change contents of these images/classes.

To link the control with Skin, use the SkinFolder property:

<APNSoft:APNSoftRating id="myRating" runat="server"
    SkinFolder = "~/Skins/Classic/" />

The collection of ready-to-use skins is included in installer. The Rating control has a default Skin to see the result immediately.


ASP.NET Rating Control - Precise Customization

APNSoft Controls [4.5.2.20]
Rating > Precise Customization

Each single segment can be customized separately by using the following properties:
  • mySegment.image - specifies the name of the picture, used for segment.
  • mySegment.imageActive - specifies the name of the picture, used for active (hovered by mouse) segment.
  • mySegment.imageDisabled - specifies the name of the picture, used for disabled segment.
  • mySegment.imageDisabledActive - specifies the name of the picture, used for segment which is disabled and active.

Images should be placed in the Skin Folder as specified by the SkinFolder property.


ASP.NET Rating Control - Templates

APNSoft Controls [4.5.2.20]
Rating > Templates

The Rating control supports use of templates. By default you have two ways the control is oriented on the page: horizontal or vertical. Templates give additional flexibility in the disposition for segments.

A Template is a regular text file (HTML file) with standard elements: tables, images, controls, etc. By using templates you can place segments (images) into the separate DIVs, table cells, anywhere inside the Template. To insert a segment into the template you use a special variable. Available variables:
  • $SegmentID_ABC$ - displays the segment with ID="ABC".
  • $SegmentIndex_4$ - displays the segment with index=4.
  • $SkinFolder$ - displays the path to SkinFolder.
  • ~ (tilde) - displays the path to the home directory of web application.

This code displays two segments in DIVs with individual absolute position:

<div style="position:absolute;left:100px;top:100px;">$SegmentIndex_0$</div>
<div style="position:absolute;left:200px;top:200px;">$SegmentIndex_1$</div>

To link the control with Template, use the Template property:

<APNSoft:APNSoftRating id="myRating" runat="server"
    Template = "~/Templates/Numpad.html" />


ASP.NET Rating Control - APNSoftRating Members

APNSoftRating Members

APNSoftRating overview

Public Instance Constructors

APNSoftRating Constructor Initializes a new instance of the APNSoftRating class.

Public Instance Properties

AutoCallBackOnSegmentClick | Specifies whether the control causes an automatic callback to the server when a Segment is clicked. Default value is false.
AutoPostBackOnSegmentClick | Specifies whether the control causes a postback to the server when a Segment is clicked. Default value is false.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
ClientSideAfterCallBack | Gets or sets the client-side code to be launched after CallBack request. Property value can include variables $ComponentID$, $SegmentID$, $SegmentValue$ and $Parameter$, instead of which data is inserted.
ClientSideOnSegmentClick | Gets or sets the client-side code to be launched when a segment is clicked. Property value can include variables $ComponentID$, $SegmentID$, $SegmentIndex$ and $SegmentValue$, instead of which data is inserted.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
Direction | Specifies the fill direction for the control. Default value is Standard.
Orientation | Gets or sets a value indicating the orientation of segments within the Rating control. Default value is Horizontal.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
ReadOnly | Gets or sets a value indicating whether the segments of the control can be clicked. Default value is False.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
Segments | Gets the collection of segments.
SegmentsInTotal | Gets or sets the total number of segments. Range: 1-1024. The default value is 5.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
Template | Gets or sets the path to the template file for the Rating control. The property value can be an absolute or relative URI.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

Public Instance Methods

DataBind | Creates a binding between the Rating control and a data source.
SetValue | Sets the value of the Rating control.

Public Instance Events

CallTheServer | Occurs on the server side when we call the server from client side by launching the rt.CallTheServer(); procedure.
OnSegmentClick | Occurs on the server side when the segment is clicked.

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - Overview

APNSoft Controls [4.5.2.20]
TreeView > Overview

APNSoft TreeView is an ASP.NET server control with AJAX support to display hierarchical data in a tree structure.

The main advantage over other TreeView controls is the SIMPLICITY. You do not need to learn a complex API to accomplish a task; create professional looking treeviews with only a few lines of code. In addition, our ASP.NET TreeView is a flexible, reliable, and powerful product. It is the perfect tool for web developers.

APNSoft TreeView has been designed so that it integrates into the look and feel of any web site. Layout can be controlled by the CSS style and user-defined images. The product uses XML for defining TreeView structure since XML is the most convenient format for structured data. The generated DHTML code is compact and fast. It is compatible with all popular browsers.


ASP.NET TreeView Control - Features

APNSoft Controls [4.5.2.20]
TreeView > Features

Standards-Based Software
  • TreeView output is XHTML 1.1 compliant.
  • Ready for ASP.NET 2.0, 3.5, 4.0 & 4.5. Visual Studio 2005, 2008, 2010 & 2012.
  • Based on industry standards: XML and CSS.

Easy-to-Use Software
  • Simplicity. No complex API.
  • Uses the default style and structure to see the result immediately.
  • Compact Documentation.
  • C# and VB.NET examples included.

Cross-Browser Support
  • APNSoft TreeView offers full up-level cross-browser support for IE 5.5+, Firefox 0.8+, Google Chrome 6.0+, Mozilla 1.4+, Netscape 7.0+, Opera 7.5+, and Safari 1.2+.

Highly Customizable Look
  • Colors, sizes, borders and fonts can all be customized to visually integrate with any project.
  • Support for icons, background images, separators, user-defined images for lines, expand/collapse buttons and check boxes.
  • TreeView items can include HTML formatting.
  • Flexible templates. Automatically identifies the type of applicable template (ASCX, XSL or HTML). Conditional Formatting for items, support for external parameters.
  • The visual appearance is specified with CSS.
  • Collection of free, ready-to-use TreeView skins.

Rich featured
  • AJAX-based Load On Demand.
  • Support for check boxes with three potential states: checked, partially-checked (not all subitems are checked) and unchecked.
  • Absolute or static positioning.
  • Support for smooth transition effect.
  • Only one path can be expanded at a time.
  • Lines can be Enabled/Disabled.

Intelligent Behavior
  • Automatically checks loaded data in order to avoid extra requests.
  • Saves its state after PostBack including the scroll position.
  • Structure checking. APNSoft TreeView checks the structure for duplicated IDs and wrong-referenced elements in the database table with structure.
  • Search Engine Optimization. Allows search engines index your site properly.
  • Health Checking. Can generate client-side messages which allow developers control the TreeView status.

Flexible Programming Options
  • Server-side API. APNSoft TreeView provides an extremely rich and powerful server-side API allowing developer to add, remove or edit structure elements and element collections.
  • Data binding support. TreeView includes the DataSource property and the DataBind() method.
  • The TreeView Structure is defined through XML and can be obtained from a static file or programmatically.
  • Has support to use the Web.sitemap file as a standard TreeView structure.
  • Support for client-side and server-side events.
  • ViewState maintenance.

Other Features
  • Multiple TreeViews on a single page are allowed.
  • Support for Unicode characters.
  • Generated code is dramatically small.


ASP.NET TreeView Control - Component Parts

APNSoft Controls [4.5.2.20]
TreeView > Component Parts
  1. Item.
    Presented by the item node in the XML Structure. Customized via Skin's CSS Style classes:
    .ItemDIV{}
.ItemHoveredDIV{}
.ItemSelectedDIV{}

  2. Item's Icon.
    Presented by the icon and iconOpen node attributes in the XML Structure. The images must be located in the Skin Folder.

  3. Item's CheckBox.
    Specified by the images in the Skin Folder:
    CheckBox.gif CheckBoxChecked.gif CheckBoxCheckedSemi.gif
    The property APNSoftTreeView.CheckBoxes specifies the value indicating whether check boxes are displayed next to the tree nodes.

  4. Expand/Collapse images.
    Specified by the images in the Skin Folder:
    Collapse.gif Expand.gif
    Or (if connecting lines are enabled):
    CollapseBottom.gif CollapseMiddle.gif CollapseSingle.gif CollapseTop.gif ExpandBottom.gif ExpandMiddle.gif ExpandSingle.gif ExpandTop.gif

  5. Connecting lines.
    Specified by the images in the Skin Folder:
    LineBottom.gif LineMiddle.gif LineSingle.gif LineTop.gif LineVertical.gif
    TreeView automatically detects line images in the Skin Folder. You can show or hide lines by using the APNSoftTreeView.ShowLines property.

  6. Separator.
    Presented by the separator node in the XML Structure. Customized via .SeparatorTD{} class in the Skin's CSS Style.


ASP.NET TreeView Control - Deployment

APNSoft Controls [4.5.2.20]
TreeView > Deployment

Most of the time, all you need to do is to add main dll library to your web application and write two lines of code on the WebForm:

  1. Copy the APNSoftControls.dll assembly into the Bin directory of your web application.

  2. Add the following line of code to the top of your page:

    <%@ Register TagPrefix="APNSoft" Namespace="APNSoft.WebControls" Assembly="APNSoftControls" %>

  3. Add the following line of code anywhere within your page to embed the TreeView:

    <APNSoft:APNSoftTreeView id="myTreeView" runat="server" />

For more information about adding controls to an ASP.NET Web Page, see this page.


ASP.NET TreeView Control - Defining the Structure

APNSoft Controls [4.5.2.20]
TreeView > Defining the Structure

APNSoft TreeView uses XML for defining the structure since XML is the most convenient and widespread format for structured data. The XML Structure consists of elements (items and separators):

<TreeView>
    <item title="About Us" />
    <item title="Products">
        <item title="Menu" />
        <item title="DataGrid" />
        <item title="TreeView" />
        <separator />
        <item title="Customization" />
    </item>
    <item title="Contacts" />
</TreeView>

The code above creates the following TreeView:

Structure elements:
  • <TreeView /> - the root element for entire TreeView Structure File. Does not include attributes.
  • <item /> - one item element. Each item element can include other elements. Available attributes:

    • AutoPostBackOnItemClick - specifies a value indicating whether the control causes a postback to the server when the item is clicked.
    • Checked - specifies a value indicating whether the item is checked.
    • ClientSideOnItemClick - specifies the client-side code to be launched when the item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
    • href, target - the URL and target the browser is directed to when a user clicks the Item. The href attribute can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
    • icon - specifies the name of item's icon image. The icon image displayed at the left side of the item. The icon images must be located in the Skin Folder as specified by the SkinFolder property.
    • iconOpen - specifies the name of the icon for expanded item.
    • iconWidth, iconHeight - one Item's icon image width and height. Attributes are optional. Control automatically calculates Width and Height of each icon.
    • id - specifies a unique identifier for the element. The attribute is required. If the id attribute is not specified, the component will automatically set it for each item (id="itm1", id="itm2", etc.).
    • opened - specifies a value indicating whether the item is opened (expanded).
    • selected - specifies a value indicating whether the item is selected.
    • Template - specifies the path to item's template file.
    • title - specifies the text (caption) displayed for the item. Can include HTML formatting by using of square brackets ("[" and "]") instead of standard corner brackets ("<" and ">"). Double square brackets ("[[" and "]]") are used to show single square brackets.

  • <separator /> - element for horizontal separator. Available attributes:

    • id - specifies a unique identifier for the element. The attribute is required. If the id attribute is not specified, the component will automatically set it for each separator (id="spr1", id="spr2", etc.).
    • width - specifies the width in pixels.

TreeView element examples:

<item id="i1" title="Home" />
<item id="i1" title="Home" href="~/Default.aspx?ItemID=$ItemID$&amp;Rnd=$Rnd$" />
<item title="Google" href="http://www.google.com" target="_blank" />
<item title="JavaScript" ClientSideOnItemClick="alert('The $Title$ ($ItemID$) is clicked!');" />
<item title="Folder" icon="IconFolder.gif" iconOpen="IconFolderOpen.gif" />
<item title="TV Schedule" Template="~/Templates/Template.ascx" />
<separator width="120" />

Attention! Element names and attributes are case-sensitive. Be careful when you're typing in your data.

Applying the XML Structure or Data Source:

You can save the XML definition structure as a file and bind the TreeView by specifying the StructureFileURL property. APNSoft TreeView has support to use the Web.sitemap file as a standard TreeView structure.

<APNSoft:APNSoftTreeView id="myTreeView" runat="server"
    StructureFileURL = "~/Structures/TreeView.xml" />

You can also apply the XML Document with structure by using the DataSource property. If the TreeView loads structure from the database, you should set the DataSource property to specify a source of data and call the DataBind() method. To create an appropriate table in the SQL Server, use the following SQL command:

CREATE TABLE [dbo].[Items](
    [id] [nvarchar](20) NOT NULL,
    [pid] [nvarchar](20) NULL,
    [Type] [nvarchar](10) NOT NULL CONSTRAINT [DF_Items_Type] DEFAULT ('item'),
    [title] [nvarchar](250) NULL,
    [href] [nvarchar](250) NULL,
    [target] [nvarchar](100) NULL,
    [icon] [nvarchar](100) NULL,
    [iconOpen] [nvarchar](100) NULL,
    [iconWidth] [tinyint] NULL,
    [iconHeight] [tinyint] NULL,
    [AutoPostBackOnItemClick] [bit]
        NOT NULL CONSTRAINT [DF_Items_AutoPostBackOnItemClick] DEFAULT ((0)),
    [ClientSideOnItemClick] [nvarchar](250) NULL,
    [selected] [bit] NOT NULL CONSTRAINT [DF_Items_selected] DEFAULT ((0)),
    [Checked] [bit] NOT NULL CONSTRAINT [DF_Items_Checked] DEFAULT ((0)),
    [opened] [bit] NOT NULL CONSTRAINT [DF_Items_opened] DEFAULT ((0)),
    [Template] [nvarchar](255) NULL
)

You can also build up TreeView at runtime. APNSoft TreeView provides an extremely rich and powerful server-side API allowing developer to add, remove or edit TreeView elements and element collections. You can programmatically control any item at runtime by using two classes TreeViewElement and TreeViewElementCollection.


ASP.NET TreeView Control - Appearance Customization

APNSoft Controls [4.5.2.20]
TreeView > Appearance Customization

APNSoft TreeView supports easy appearance customization through Skins. A Skin is a folder that contains one CSS Style (Style.CSS) and a set of images:

TreeView consists of the elements: items, icons, connecting lines, separators, etc. Each TreeView element corresponds to an image or CSS class. Images and CSS classes have the predefined names. During customization you can change contents of these images/classes.

To link the control with Skin, use the SkinFolder property:

<APNSoft:APNSoftTreeView id="myTreeView" runat="server"
    SkinFolder = "~/Skins/GrayScale/" />

The collection of ready-to-use skins is included in installer. TreeView has a default Skin to see the result immediately.


ASP.NET TreeView Control - Templates

APNSoft Controls [4.5.2.20]
TreeView > Templates

APNSoft TreeView supports three types of user-defined templates for additional item customization. Templates are easy to use powerful tools, which allow changing item's appearance flexibly on developer's demand.

  1. HTML template
    HTML Template is a regular text file with HTML elements: tables, images, controls, etc.

  2. XSL template
    XSL Template is more flexible than HTML template, because it includes XSL elements. XSL Template allows comparing/modifying data without a loss in performance. For example, under conditional formatting you must first analyze item's data and then apply the formatting.

    XSL Template must include two key elements: the <xsl:call-template name="Main" /> and the <xsl:template name="Main">. Sample code of XSL Template:

    <?xml version="1.0" encoding="UTF-8" ?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
    <xsl:output method="xml" version="1.0" indent="no" omit-xml-declaration="yes" />

    <xsl:template match="/">
        <xsl:call-template name="Main" />
    </xsl:template>

    <xsl:template name="Main">
        ...
    </xsl:template>

</xsl:stylesheet>

  3. ASCX template (User Control)
    ASCX Template is most flexible because it allows developer to format an item by using the preferred programming language (C# or VB.NET). ASCX Template can include the field TreeViewElement which must be declared as public. You can use this field to have access to the item in Template's code.

    [C#]
    public APNSoft.WebControls.TreeViewElement TreeViewElement = null;
    [VB.NET]
    Public TreeViewElement As APNSoft.WebControls.TreeViewElement = Nothing

Templates can include variables, instead of which data is inserted. Available variables:
  • $ComponentID$ - displays the unique identifier of the component.
  • $ItemID$ - displays the unique identifier of the item.
  • $Title$ - displays the text (caption) of the item.

TreeView automatically identifies the type of applicable template. To apply template to the item, use the Template attribute:

<item title="HTML" Template="~/Templates/Template.html" />
<item title="XSL" Template="~/Templates/Template.xsl" />
<item title="ASCX" Template="~/Templates/Template.ascx" />


ASP.NET TreeView Control - APNSoftTreeView Members

APNSoftTreeView Members

APNSoftTreeView overview

Public Instance Constructors

APNSoftTreeView Constructor Initializes a new instance of the APNSoftTreeView class.

Public Instance Properties

AutoCollapse | Gets or sets a value indicating whether control automatically collapses child nodes when the user selects an item. Default value is false.
AutoExpand | Gets or sets a value indicating whether control automatically expands child nodes when the user selects an item. Default value is true.
AutoPostBackOnItemClick | Specifies whether the control causes a postback to the server when an Item is clicked. Default value is false.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes. Default value is false.
ClientSideOnCheck | Gets or sets the client-side code to be launched when an item is checked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnCollapse | Gets or sets the client-side code to be launched when an item is collapsed. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnExpand | Gets or sets the client-side code to be launched when an item is expanded. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnItemClick | Gets or sets the client-side code to be launched when an item is clicked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnUnCheck | Gets or sets the client-side code to be launched when an item is unchecked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
DurationCollapse | The duration (in milliseconds) of the collapse animation.
DurationExpand | The duration (in milliseconds) of the expand animation.
Elements | Gets the collection of elements.
ExpandSinglePath | Gets or sets a value indicating whether only the current branch is expanded. Default value is false.
LoadOnDemand | Specifies whether child nodes will be populated on demand. Default value is false.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
SEOEnabled | Gets or sets a value indicating whether the control renders an additional NOSCRIPT section with links let all search engines index your website properly. Default value is false.
ShowLines | Specifies whether the TreeView renders lines for the tree. Default value is false.
ShowStartingNode | Gets or sets a value indicating whether the TreeView renders the starting node. Default value is true.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
StructureFileURL | Gets or sets the URL to the structure file. If the property is not specified, component uses internal default structure. The property value can be an absolute or relative URI. TreeView has support to use the Web.sitemap file as a standard TreeView structure.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

Public Instance Methods

DataBind | Creates a binding between the TreeView control and a data source.
GetCheckedItems | Returns all checked items in the TreeView control.
GetSelectedItem | Returns the selected Item.

Public Instance Events

OnItemClick Occurs on the server side when the item is clicked.

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoft.WebControls

APNSoft.WebControls Namespace

Classes

Class | Description
APNSoftComboBox | APNSoftComboBox control class.
APNSoftControl | APNSoftControl control class.
APNSoftDataGrid | APNSoftDataGrid control class.
APNSoftElement | Represents the part of a APNSoftElementCollection.
APNSoftElementCollection | Represents the collection of elements.
APNSoftInclude | APNSoftInclude control class.
APNSoftMenu | APNSoftMenu control class.
APNSoftRating | APNSoftRating control class.
APNSoftTreeView | APNSoft TreeView Class.
ComboBoxElement | Represents the part of a ComboBoxElementCollection.
ComboBoxElementCollection | Represents the collection of elements.
ComboBoxEventArgs | Provides data for command events of the ComboBox control.
DataGridEventArgs | Provides data for command events of the DataGrid control.
GridBottomBar | Represents the Bottom Bar.
GridCell | Represents the part of a GridCellCollection.
GridCellCollection | Represents the collection of cells in one row.
GridColumn | Represents the part of a GridColumnCollection.
GridColumnCollection | Represents the collection of grid columns.
GridContextMenuHeader | Represents the Context Menu for Header.
GridContextMenuRow | Represents the Context Menu for Row.
GridEditForm | Represents the Edit Form.
GridRow | Represents the part of a GridRowCollection.
GridRowCollection | Represents the collection of grid rows.
IncludeEventArgs | Provides data for command events of the Include control.
MenuElement | Represents the part of a MenuElementCollection.
MenuElementCollection | Represents the collection of elements.
MenuEventArgs | Provides data for command events of the Menu control.
RatingEventArgs | Provides data for command events of the Rating control.
RatingSegment | Represents the part of a RatingSegmentCollection.
RatingSegmentCollection | Represents the collection of segments.
TreeViewElement | Represents the part of a TreeViewElementCollection.
TreeViewElementCollection | Represents the collection of elements.
TreeViewEventArgs | TreeView object arguments that received after post back.

Delegates

Delegate | Description
ComboBoxEventHandler | Represents the method that will handle command events of a ComboBox.
DataGridEventHandler | Represents the method that will handle command events of a DataGrid.
IncludeEventHandler | Represents the method that will handle command events of an Include.
MenuEventHandler | Represents the method that will handle command events of a Menu.
RatingEventHandler | Represents the method that will handle command events of a Rating.
TreeViewEventHandler | Represents the method that will handle command events of a TreeView.

Enumerations

Enumeration | Description
APNSoftComboBox.ListCloseValues | Values for the ListClose property.
APNSoftComboBox.ListOpenValues | Values for the ListOpen property.
APNSoftControl.CSSSourceValues | Values for the CSSSource property.
APNSoftControl.PositionValues | Values for the Position property.
APNSoftDataGrid.AutoResizeValues | Values for the AutoResize property.
APNSoftDataGrid.EditFormMethodValues | Values for the EditFormMethod property.
APNSoftDataGrid.ModeValues | Values for the Mode property.
APNSoftElement.Types | Element types.
APNSoftMenu.ExpandDirectionHorizontalValues | Values for the ExpandDirectionHorizontal property.
APNSoftMenu.ExpandDirectionVerticalValues | Values for the ExpandDirectionVertical property.
APNSoftMenu.OrientationValues | Values for the Orientation property.
APNSoftMenu.SubMenusCloseValues | Values for the SubMenusClose property.
APNSoftMenu.SubMenusOpenValues | Values for the SubMenusOpen property.
APNSoftRating.DirectionValues | Values for the Direction property.
APNSoftRating.OrientationValues | Values for the Orientation property.
GridColumn.FormatOrderValues | Values for the FormatOrder property.
GridColumn.SortedValues | Values for the Sorted property.
GridEditForm.PositionValues | Values for the properties: PositionInsert and PositionUpdate.


ASP.NET ComboBox Control - APNSoftComboBox Class

APNSoftComboBox Class

APNSoftComboBox control class.

For a list of all members of this type, see APNSoftComboBox Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
APNSoft.WebControls.APNSoftControl
APNSoft.WebControls.APNSoftComboBox

[Visual Basic]
Public Class APNSoftComboBox
Inherits APNSoftControl
Implements IPostBackEventHandler
[C#]
public class APNSoftComboBox : APNSoftControl, IPostBackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoftComboBox Members | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - APNSoftComboBox Constructor

APNSoftComboBox Constructor

Initializes a new instance of the APNSoftComboBox class.

[Visual Basic]
Public Sub New()
[C#]
public APNSoftComboBox();

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - APNSoftComboBox Properties

APNSoftComboBox Properties

The properties of the APNSoftComboBox class are listed below. For a complete list of APNSoftComboBox class members, see the APNSoftComboBox Members topic.

Public Instance Properties

AutoPostBackOnItemClick | Specifies whether the control causes a postback to the server when an Item is clicked. Default value is false.
AutoScrollList | Allows to enable content auto scrolling while the mouse cursor is moving over the opened DropDown List.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
ClientSideOnItemClick | Gets or sets the client-side code to be launched when an item is clicked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnItemOver | Gets or sets the client-side code to be launched while the mouse cursor is moving over the item in DropDown List. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
DefaultIcon | Specifies the image filename for the Default Icon if no items are selected from the DropDown List. The image file must be located in the Skin Folder of your web site, as specified by the SkinFolder property.
DefaultText | Specifies default ComboBox text. Default text is displayed if no items are selected from the DropDown List.
Elements | Gets the collection of elements.
FadeEffect | Specifies whether the control displays the DropDown List with animated Fade effect. Default value is true.
FadeSpeed | Gets or sets the speed of Fade Effect. Range: 0-50. Default value is 5.
ListClose | Gets or sets a value indicating whether the DropDown List is closed by mouse click outside the control or automatically when the mouse goes away. Default value is Auto.
ListHeight | Specifies the DropDown List height in pixels. If the height of the List content is more than property value, the Slider is displayed automatically. Default value is 140.
ListOpen | Gets or sets a value indicating whether the DropDown List is opened by mouse click or automatically when user moves the mouse pointer over the control. Default value is OnMouseClick.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
SEOEnabled | Gets or sets a value indicating whether the control renders an additional NOSCRIPT section with links let all search engines index your website properly. Default value is false.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
StructureFileURL | Gets or sets the URL to the structure file. If the property is not specified, component uses internal default structure. The property value can be an absolute or relative URI.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
Width | Gets or sets a value indicating the width of the ComboBox in pixels. Note that the property value is equal or greater than the actual width of the DropDown List content. Default value is 220.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - AutoPostBackOnItemClick Property

APNSoftComboBox.AutoPostBackOnItemClick Property

Specifies whether the control causes a postback to the server when an Item is clicked. Default value is false.

[Visual Basic]
Public Property AutoPostBackOnItemClick As Boolean
[C#]
public bool AutoPostBackOnItemClick {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - AutoScrollList Property

APNSoftComboBox.AutoScrollList Property

Allows to enable content auto scrolling while the mouse cursor is moving over the opened DropDown List.

[Visual Basic]
Public Property AutoScrollList As Boolean
[C#]
public bool AutoScrollList {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ClientSideOnItemClick Property

APNSoftComboBox.ClientSideOnItemClick Property

Gets or sets the client-side code to be launched when an item is clicked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnItemClick As String
[C#]
public string ClientSideOnItemClick {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ClientSideOnItemOver Property

APNSoftComboBox.ClientSideOnItemOver Property

Gets or sets the client-side code to be launched while the mouse cursor is moving over the item in DropDown List. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnItemOver As String
[C#]
public string ClientSideOnItemOver {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - DefaultIcon Property

APNSoftComboBox.DefaultIcon Property

Specifies the image filename for the Default Icon if no items are selected from the DropDown List. The image file must be located in the Skin Folder of your web site, as specified by the SkinFolder property.

[Visual Basic]
Public Property DefaultIcon As String
[C#]
public string DefaultIcon {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - DefaultText Property

APNSoftComboBox.DefaultText Property

Specifies default ComboBox text. Default text is displayed if no items are selected from the DropDown List.

[Visual Basic]
Public Property DefaultText As String
[C#]
public string DefaultText {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - Elements Property

APNSoftComboBox.Elements Property

Gets the collection of elements.

[Visual Basic]
Public ReadOnly Property Elements As ComboBoxElementCollection
[C#]
public ComboBoxElementCollection Elements {get;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - FadeEffect Property

APNSoftComboBox.FadeEffect Property

Specifies whether the control displays the DropDown List with animated Fade effect. Default value is true.

[Visual Basic]
Public Property FadeEffect As Boolean
[C#]
public bool FadeEffect {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - FadeSpeed Property

APNSoftComboBox.FadeSpeed Property

Gets or sets the speed of Fade Effect. Range: 0-50. Default value is 5.

[Visual Basic]
Public Property FadeSpeed As Byte
[C#]
public byte FadeSpeed {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ListClose Property

APNSoftComboBox.ListClose Property

Gets or sets a value indicating whether the DropDown List is closed by mouse click outside the control or automatically when the mouse goes away. Default value is Auto.

[Visual Basic]
Public Property ListClose As ListCloseValues
[C#]
public APNSoftComboBox.ListCloseValues ListClose {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ListHeight Property

APNSoftComboBox.ListHeight Property

Specifies the DropDown List height in pixels. If the height of the List content is more than property value, the Slider is displayed automatically. Default value is 140.

[Visual Basic]
Public Property ListHeight As Unit
[C#]
public System.Web.UI.WebControls.Unit ListHeight {get; set;}

Example

[C#]
myComboBox.ListHeight = 200;

[Visual Basic]
myComboBox.ListHeight = New System.Web.UI.WebControls.Unit(200)

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ListOpen Property

APNSoftComboBox.ListOpen Property

Gets or sets a value indicating whether the DropDown List is opened by mouse click or automatically when user moves the mouse pointer over the control. Default value is OnMouseClick.

[Visual Basic]
Public Property ListOpen As ListOpenValues
[C#]
public APNSoftComboBox.ListOpenValues ListOpen {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - SEOEnabled Property

APNSoftComboBox.SEOEnabled Property

Gets or sets a value indicating whether the control renders an additional NOSCRIPT section with links let all search engines index your website properly. Default value is false.

[Visual Basic]
Public Property SEOEnabled As Boolean
[C#]
public bool SEOEnabled {get; set;}

Remarks

The links of the control items are implemented with the JavaScript OnClick procedure, which can not be indexed by search-engine spiders. To overcome this obstacle, control generates an additional NOSCRIPT section with regular href tags.

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - StructureFileURL Property

APNSoftComboBox.StructureFileURL Property

Gets or sets the URL to the structure file. If the property is not specified, component uses internal default structure. The property value can be an absolute or relative URI.

[Visual Basic]
Public Property StructureFileURL As String
[C#]
public string StructureFileURL {get; set;}

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - Width Property

APNSoftComboBox.Width Property

Gets or sets a value indicating the width of the ComboBox in pixels. Note that the property value is equal or greater than the actual width of the DropDown List content. Default value is 220.

[Visual Basic]
Overrides Public Property Width As Unit
[C#]
public override System.Web.UI.WebControls.Unit Width {get; set;}

Example

[C#]
myComboBox.Width = 300;

[Visual Basic]
myComboBox.Width = New System.Web.UI.WebControls.Unit(300)

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - APNSoftComboBox Methods

APNSoftComboBox Methods

The methods of the APNSoftComboBox class are listed below. For a complete list of APNSoftComboBox class members, see the APNSoftComboBox Members topic.

Public Instance Methods

DataBind | Creates a binding between the ComboBox control and a data source.
GetSelectedItemID | Returns the selected Item ID.

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - APNSoftComboBox.DataBind Method

APNSoftComboBox.DataBind Method

Creates a binding between the ComboBox control and a data source.

[Visual Basic]
Overrides Public Sub DataBind()
[C#]
public override void DataBind();

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - APNSoftComboBox.GetSelectedItemID Method

APNSoftComboBox.GetSelectedItemID Method

Returns the selected Item ID.

[Visual Basic]
Public Function GetSelectedItemID() As String
[C#]
public string GetSelectedItemID();

Return Value

The selected Item ID.

Remarks

When the form is returned after a postback, the Selected Item ID can be defined by this method.

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - APNSoftComboBox Events

APNSoftComboBox Events

The events of the APNSoftComboBox class are listed below. For a complete list of APNSoftComboBox class members, see the APNSoftComboBox Members topic.

Public Instance Events

OnItemClick Occurs on the server side when the item is clicked.

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - APNSoftComboBox.OnItemClick Event

APNSoftComboBox.OnItemClick Event

Occurs on the server side when the item is clicked.

[Visual Basic]
Public Event OnItemClick As ComboBoxEventHandler
[C#]
public event ComboBoxEventHandler OnItemClick;

See Also

APNSoftComboBox Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - APNSoftComboBox.ListCloseValues Enumeration

APNSoftComboBox.ListCloseValues Enumeration

Values for the ListClose property.

[Visual Basic]
Public Enum APNSoftComboBox.ListCloseValues
[C#]
public enum APNSoftComboBox.ListCloseValues

Members

Member Name | Description
Auto | DropDown List is closed automatically when the mouse goes away.
OnMouseClick | DropDown List is closed by mouse click outside the control.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET ComboBox Control - APNSoftComboBox.ListOpenValues Enumeration

APNSoftComboBox.ListOpenValues Enumeration

Values for the ListOpen property.

[Visual Basic]
Public Enum APNSoftComboBox.ListOpenValues
[C#]
public enum APNSoftComboBox.ListOpenValues

Members

Member Name | Description
OnMouseClick | DropDown List is opened by mouse click.
OnMouseOver | DropDown List is opened automatically when user moves the mouse pointer over the ComboBox.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Control - APNSoftControl Class

APNSoftControl Class

APNSoftControl control class.

For a list of all members of this type, see APNSoftControl Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
APNSoft.WebControls.APNSoftControl
Derived types

[Visual Basic]
MustInherit Public Class APNSoftControl
Inherits WebControl
[C#]
public abstract class APNSoftControl : WebControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoftControl Members | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftControl Members

APNSoftControl Members

APNSoftControl overview

Public Instance Constructors

APNSoftControl Constructor Initializes a new instance of the APNSoftControl class.

Public Instance Properties

BasePage | Gets or sets the reference to the Base Page. Used only in Code Behind.
CSSClassesPrefix | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText | Sets the CSS style value for the control.
DataSource | Gets or sets the data source that provides data for populating the control.
OutputFooter | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
SkinFolder | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
WarningsEnabled | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex | Gets or sets the z-index style value for the control. Default value is 200.

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftControl Constructor

APNSoftControl Constructor

Initializes a new instance of the APNSoftControl class.

[Visual Basic]
Public Sub New()
[C#]
public APNSoftControl();

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftControl Properties

APNSoftControl Properties

The properties of the APNSoftControl class are listed below. For a complete list of APNSoftControl class members, see the APNSoftControl Members topic.

Public Instance Properties

BasePage | Gets or sets the reference to the Base Page. Used only in Code Behind.
CSSClassesPrefix | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText | Sets the CSS style value for the control.
DataSource | Gets or sets the data source that provides data for populating the control.
OutputFooter | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
SkinFolder | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
WarningsEnabled | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex | Gets or sets the z-index style value for the control. Default value is 200.

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - BasePage Property

APNSoftControl.BasePage Property

Gets or sets the reference to the Base Page. Used only in Code Behind.

[Visual Basic]
Public Property BasePage As Page
[C#]
public System.Web.UI.Page BasePage {get; set;}

Example

[C#]
myControl.BasePage = base.Page;

[Visual Basic]
myControl.BasePage = Me.Page

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - CSSClassesPrefix Property

APNSoftControl.CSSClassesPrefix Property

Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.

[Visual Basic]
Public Property CSSClassesPrefix As String
[C#]
public string CSSClassesPrefix {get; set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - CSSSource Property

APNSoftControl.CSSSource Property

Gets or sets the location of the CSS Style. Default value is SkinFolder.

[Visual Basic]
Public Property CSSSource As CSSSourceValues
[C#]
public APNSoftControl.CSSSourceValues CSSSource {get; set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - CSSStyleName Property

APNSoftControl.CSSStyleName Property

Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.

[Visual Basic]
Public Property CSSStyleName As String
[C#]
public string CSSStyleName {get; set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - CSSText Property

APNSoftControl.CSSText Property

Sets the CSS style value for the control.

[Visual Basic]
Public WriteOnly Property CSSText As String
[C#]
public string CSSText {set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - DataSource Property

APNSoftControl.DataSource Property

Gets or sets the data source that provides data for populating the control.

[Visual Basic]
Public Property DataSource As Object
[C#]
public object DataSource {get; set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - OutputFooter Property

APNSoftControl.OutputFooter Property

Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.

[Visual Basic]
Public Property OutputFooter As String
[C#]
public string OutputFooter {get; set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - OutputHeader Property

APNSoftControl.OutputHeader Property

Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.

[Visual Basic]
Public Property OutputHeader As String
[C#]
public string OutputHeader {get; set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - Position Property

APNSoftControl.Position Property

Gets or sets the type of positioning used for the control. Default value is Static.

[Visual Basic]
Public Property Position As PositionValues
[C#]
public APNSoftControl.PositionValues Position {get; set;}

Remarks

You need to set the PositionLeft and PositionTop properties for the control with absolute positioning.

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - PositionLeft Property

APNSoftControl.PositionLeft Property

Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.

[Visual Basic]
Public Property PositionLeft As Unit
[C#]
public System.Web.UI.WebControls.Unit PositionLeft {get; set;}

Example

[C#]
myControl.PositionLeft = 100;

[Visual Basic]
myControl.PositionLeft = New System.Web.UI.WebControls.Unit(100)

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - PositionTop Property

APNSoftControl.PositionTop Property

Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.

[Visual Basic]
Public Property PositionTop As Unit
[C#]
public System.Web.UI.WebControls.Unit PositionTop {get; set;}

Example

[C#]
myControl.PositionTop = 100;

[Visual Basic]
myControl.PositionTop = New System.Web.UI.WebControls.Unit(100)

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - RegisterClientScript Property

APNSoftControl.RegisterClientScript Property

Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.

[Visual Basic]
Public Property RegisterClientScript As Boolean
[C#]
public bool RegisterClientScript {get; set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - SkinFolder Property

APNSoftControl.SkinFolder Property

Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.

[Visual Basic]
Public Property SkinFolder As String
[C#]
public string SkinFolder {get; set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - WarningsEnabled Property

APNSoftControl.WarningsEnabled Property

Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.

[Visual Basic]
Public Property WarningsEnabled As Boolean
[C#]
public bool WarningsEnabled {get; set;}

Remarks

For example, if you use a new component version with the old JS file, you will see a warning.

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - zIndex Property

APNSoftControl.zIndex Property

Gets or sets the z-index style value for the control. Default value is 200.

[Visual Basic]
Public Property zIndex As Integer
[C#]
public int zIndex {get; set;}

See Also

APNSoftControl Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftControl.CSSSourceValues Enumeration

APNSoftControl.CSSSourceValues Enumeration

Values for the CSSSource property.

[Visual Basic]
Public Enum APNSoftControl.CSSSourceValues
[C#]
public enum APNSoftControl.CSSSourceValues

Members

Member Name | Description
SkinFolder | CSS File is loaded from a Skin Folder as specified by the SkinFolder property.
Page | An ASPX page uses <style> element inside the <head> or uses the <link> element to link an external style sheet.
Text | CSS Style is set directly by the CSSText property.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Control - APNSoftControl.PositionValues Enumeration

APNSoftControl.PositionValues Enumeration

Values for the Position property.

[Visual Basic]
Public Enum APNSoftControl.PositionValues
[C#]
public enum APNSoftControl.PositionValues

Members

Member Name | Description
Absolute | Control is positioned relative to parent element's position using the PositionTop and PositionLeft properties.
Static | Control has no special positioning; it follows the layout rules of HTML.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid Class

APNSoftDataGrid Class

APNSoftDataGrid control class.

For a list of all members of this type, see APNSoftDataGrid Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
APNSoft.WebControls.APNSoftControl
APNSoft.WebControls.APNSoftDataGrid

[Visual Basic]
Public Class APNSoftDataGrid
Inherits APNSoftControl
Implements IPostBackEventHandler, ICallbackEventHandler
[C#]
public class APNSoftDataGrid : APNSoftControl, IPostBackEventHandler, ICallbackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoftDataGrid Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid Constructor

APNSoftDataGrid Constructor

Initializes a new instance of the APNSoftDataGrid class.

[Visual Basic]
Public Sub New()
[C#]
public APNSoftDataGrid();

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid Properties

APNSoftDataGrid Properties

The properties of the APNSoftDataGrid class are listed below. For a complete list of APNSoftDataGrid class members, see the APNSoftDataGrid Members topic.

Public Static (Shared) Properties

EditFormMethod | Gets a value indicating the Edit Form is opened for INSERT or UPDATE. Default value is Undefined. When you open the Edit Form for UPDATE, fill in form fields with selected row data. Use the EditFormRow property to get the selected row.
EditFormRow | Gets the selected row, used to fill in the Edit Form before update.

Public Instance Properties

AutoPostBackOnRowClick | Specifies whether the control causes a postback to the server when a row is clicked. Default value is false.
AutoPostBackOnRowDblClick | Specifies whether the control causes a postback to the server when a row is double-clicked. Default value is false.
AutoResize | Gets or sets a value specifying the way for DataGrid to be resized (if necessary) when data is loaded. Default value is None. When the property's value is WidthAndHeight, DataGrid displays data without scrollbars.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
BottomBar | Gets the Bottom Bar.
CellEditingEnabled | Gets or sets a value specifying whether the cell editing is enabled. Triggered by clicking twice on a cell. Default value is false.
ClientSideAfterCallBack | Gets or sets the client-side code to be launched after CallBack request. Property value can include variables $ComponentID$, $Command$ and $Parameter$, instead of which data is inserted.
ClientSideAfterInit | Gets or sets the client-side code to be launched after DataGrid initialization. Property value can include variable $ComponentID$, instead of which data is inserted.
ClientSideBeforeCellUpdate | Gets or sets the client-side code (procedure) to be launched before Cell Update. This code can be used for data validation and auto correction. Property value can include variables $ComponentID$, $RowID$, $ColumnName$ and $CellValue$, instead of which data is inserted.
ClientSideOnContextMenuHeader | Gets or sets the client-side code to be launched before the context menu for header is displayed. Property value can include variables $ComponentID$, $ColumnIndex$ and $ContextMenu$, instead of which data is inserted. The $ContextMenu$ is a DIV element with context menu data.
ClientSideOnContextMenuRow | Gets or sets the client-side code to be launched before the context menu for rows is displayed. Property value can include variables $ComponentID$, $RowID$, $CellValue$ and $ContextMenu$, instead of which data is inserted. The $ContextMenu$ is a DIV element with context menu data.
ClientSideOnPage | Gets or sets the client-side code to be launched when a new page is opened. Property value can include variables $ComponentID$ and $PageNumber$, instead of which data is inserted.
ClientSideOnRowClick | Gets or sets the client-side code to be launched when a row is clicked. Property value can include variables $ComponentID$, $RowID$, $ColumnName$ and $CellValue$, instead of which data is inserted.
ClientSideOnRowDblClick | Gets or sets the client-side code to be launched when a row is double-clicked. Property value can include variables $ComponentID$, $RowID$, $ColumnName$ and $CellValue$, instead of which data is inserted.
Columns | Gets the collection of columns.
ConfirmTextDelete | Gets or sets the text to be shown on the confirmation dialog before the record is deleted. The prompt is automatically enabled if this property is set.
ConfirmTextInsert | Gets or sets the text to be shown on the confirmation dialog before the record is inserted. The prompt is automatically enabled if this property is set.
ConfirmTextUpdate | Gets or sets the text to be shown on the confirmation dialog before the record is updated. The prompt is automatically enabled if this property is set.
ContextMenuHeader | Gets the Context Menu for Header.
ContextMenuRow | Gets the Context Menu for Row.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
DataSourceID | Gets or sets the ID of the control from which the DataGrid retrieves its list of data items.
EditForm | Gets the Edit Form.
FixedColumnsOpacity | Gets or sets the opacity factor applied to the fixed columns. Range: 0-100. Default value is 100 (columns are NOT transparent).
Height | Gets or sets a value indicating the height of the DataGrid in pixels. Range: 60-2048.
HighlightHoveredRow | Gets or sets a value specifying whether the hovered row is highlighted. Default value is true.
HighlightSelectedRow | Gets or sets a value specifying whether the selected row is highlighted. Default value is true.
KeyFieldName | Gets or sets the name of column that uniquely identifies each record stored in the table. The key field is commonly used in a handler for an event, such as UpdateCommand or DeleteCommand, as part of an update query string to revise a specific record in the data source. The key field helps the update query string identify the appropriate record to modify.
MessageDeleting | Specifies a message to be displayed when control deletes a record. Default value is Deleting....
MessageInserting | Specifies a message to be displayed when control inserts a record. Default value is Inserting....
MessageLoading | Specifies a message to be displayed when control loads records. Default value is Loading....
MessageNoRecords | Specifies a message to be displayed when there are no records in the data source. Default value is No records to display..
MessageProcessing | Specifies a message to be displayed when control launches custom asynchronous call. Default value is Processing....
MessageReady | Specifies a message to be displayed when control is ready for an action. Default value is Ready..
MessageUpdating | Specifies a message to be displayed when control updates a record. Default value is Updating....
Mode | Gets or sets the running mode of the DataGrid.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
PageCount | Gets the total number of pages in the grid.
PageSize | Gets or sets the maximum number of rows to be displayed on a single page of the DataGrid control. Range: 1-10000. The default value is 20. The total number of pages is calculated automatically depending on data amount.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
RightClickSelect | Gets or sets a value specifying whether a row is selected when the user right-clicks on the row. Default value is true. Note that the property value must be true if you use context menu for rows.
RowFilter | Gets or sets the expression used to filter which rows are viewed in the DataGrid.
Rows | Gets the collection of rows.
SEOEnabled | Gets or sets a value indicating whether the DataGrid renders an additional NOSCRIPT section with links which correspond to DataGrid rows. Default value is false.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
Width | Gets or sets a value indicating the width of the DataGrid in pixels. Range: 100-4096.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - AutoPostBackOnRowClick Property

APNSoftDataGrid.AutoPostBackOnRowClick Property

Specifies whether the control causes a postback to the server when a row is clicked. Default value is false.

[Visual Basic]
Public Property AutoPostBackOnRowClick As Boolean
[C#]
public bool AutoPostBackOnRowClick {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - AutoPostBackOnRowDblClick Property

APNSoftDataGrid.AutoPostBackOnRowDblClick Property

Specifies whether the control causes a postback to the server when a row is double-clicked. Default value is false.

[Visual Basic]
Public Property AutoPostBackOnRowDblClick As Boolean
[C#]
public bool AutoPostBackOnRowDblClick {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - AutoResize Property

APNSoftDataGrid.AutoResize Property

Gets or sets a value specifying the way for DataGrid to be resized (if necessary) when data is loaded. Default value is None. When the property's value is WidthAndHeight, DataGrid displays data without scrollbars.

[Visual Basic]
Public Property AutoResize As AutoResizeValues
[C#]
public APNSoftDataGrid.AutoResizeValues AutoResize {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - BottomBar Property

APNSoftDataGrid.BottomBar Property

Gets the Bottom Bar.

[Visual Basic]
Public ReadOnly Property BottomBar As GridBottomBar
[C#]
public GridBottomBar BottomBar {get;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - CellEditingEnabled Property

APNSoftDataGrid.CellEditingEnabled Property

Gets or sets a value specifying whether the cell editing is enabled. Triggered by clicking twice on a cell. Default value is false.

[Visual Basic]
Public Property CellEditingEnabled As Boolean
[C#]
public bool CellEditingEnabled {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ClientSideAfterCallBack Property

APNSoftDataGrid.ClientSideAfterCallBack Property

Gets or sets the client-side code to be launched after CallBack request. Property value can include variables $ComponentID$, $Command$ and $Parameter$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideAfterCallBack As String
[C#]
public string ClientSideAfterCallBack {get; set;}

Remarks

The Command value is one of the following values: 'InsertRow', 'UpdateRow', 'DeleteRow', 'GetEditForm', 'GetRows', 'UpdateCell', 'CallTheServer'. The Parameter is received in encoded form. To decode value, use the dg.DecodeValue(Value) JavaScript method.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ClientSideAfterInit Property

APNSoftDataGrid.ClientSideAfterInit Property

Gets or sets the client-side code to be launched after DataGrid initialization. Property value can include variable $ComponentID$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideAfterInit As String
[C#]
public string ClientSideAfterInit {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ClientSideBeforeCellUpdate Property

APNSoftDataGrid.ClientSideBeforeCellUpdate Property

Gets or sets the client-side code (procedure) to be launched before Cell Update. This code can be used for data validation and auto correction. Property value can include variables $ComponentID$, $RowID$, $ColumnName$ and $CellValue$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideBeforeCellUpdate As String
[C#]
public string ClientSideBeforeCellUpdate {get; set;}

Remarks

This procedure should return error message (is displayed as alert) or false if the value is not correct. The CellValue is received in escaped form. To unescape value, use the unescape(CellValue) JavaScript method. To save corrected value, set the client-side variable dg.CellValue.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ClientSideOnContextMenuHeader Property

APNSoftDataGrid.ClientSideOnContextMenuHeader Property

Gets or sets the client-side code to be launched before the context menu for header is displayed. Property value can include variables $ComponentID$, $ColumnIndex$ and $ContextMenu$, instead of which data is inserted. The $ContextMenu$ is a DIV element with context menu data.

[Visual Basic]
Public Property ClientSideOnContextMenuHeader As String
[C#]
public string ClientSideOnContextMenuHeader {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ClientSideOnContextMenuRow Property

APNSoftDataGrid.ClientSideOnContextMenuRow Property

Gets or sets the client-side code to be launched before the context menu for rows is displayed. Property value can include variables $ComponentID$, $RowID$, $CellValue$ and $ContextMenu$, instead of which data is inserted. The $ContextMenu$ is a DIV element with context menu data.

[Visual Basic]
Public Property ClientSideOnContextMenuRow As String
[C#]
public string ClientSideOnContextMenuRow {get; set;}

Remarks

The CellValue is received in encoded form. To decode value, use the unescape() JavaScript method.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ClientSideOnPage Property

APNSoftDataGrid.ClientSideOnPage Property

Gets or sets the client-side code to be launched when a new page is opened. Property value can include variables $ComponentID$ and $PageNumber$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnPage As String
[C#]
public string ClientSideOnPage {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ClientSideOnRowClick Property

APNSoftDataGrid.ClientSideOnRowClick Property

Gets or sets the client-side code to be launched when a row is clicked. Property value can include variables $ComponentID$, $RowID$, $ColumnName$ and $CellValue$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnRowClick As String
[C#]
public string ClientSideOnRowClick {get; set;}

Remarks

The CellValue is received in encoded form. To decode value, use the unescape() JavaScript method.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ClientSideOnRowDblClick Property

APNSoftDataGrid.ClientSideOnRowDblClick Property

Gets or sets the client-side code to be launched when a row is double-clicked. Property value can include variables $ComponentID$, $RowID$, $ColumnName$ and $CellValue$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnRowDblClick As String
[C#]
public string ClientSideOnRowDblClick {get; set;}

Remarks

The CellValue is received in encoded form. To decode value, use the unescape() JavaScript method.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Columns Property

APNSoftDataGrid.Columns Property

Gets the collection of columns.

[Visual Basic]
Public ReadOnly Property Columns As GridColumnCollection
[C#]
public GridColumnCollection Columns {get;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ConfirmTextDelete Property

APNSoftDataGrid.ConfirmTextDelete Property

Gets or sets the text to be shown on the confirmation dialog before the record is deleted. The prompt is automatically enabled if this property is set.

[Visual Basic]
Public Property ConfirmTextDelete As String
[C#]
public string ConfirmTextDelete {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ConfirmTextInsert Property

APNSoftDataGrid.ConfirmTextInsert Property

Gets or sets the text to be shown on the confirmation dialog before the record is inserted. The prompt is automatically enabled if this property is set.

[Visual Basic]
Public Property ConfirmTextInsert As String
[C#]
public string ConfirmTextInsert {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ConfirmTextUpdate Property

APNSoftDataGrid.ConfirmTextUpdate Property

Gets or sets the text to be shown on the confirmation dialog before the record is updated. The prompt is automatically enabled if this property is set.

[Visual Basic]
Public Property ConfirmTextUpdate As String
[C#]
public string ConfirmTextUpdate {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ContextMenuHeader Property

APNSoftDataGrid.ContextMenuHeader Property

Gets the Context Menu for Header.

[Visual Basic]
Public Property ContextMenuHeader As GridContextMenuHeader
[C#]
public GridContextMenuHeader ContextMenuHeader {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ContextMenuRow Property

APNSoftDataGrid.ContextMenuRow Property

Gets the Context Menu for Row.

[Visual Basic]
Public Property ContextMenuRow As GridContextMenuRow
[C#]
public GridContextMenuRow ContextMenuRow {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - DataSourceID Property

APNSoftDataGrid.DataSourceID Property

Gets or sets the ID of the control from which the DataGrid retrieves its list of data items.

[Visual Basic]
Public Property DataSourceID As String
[C#]
public string DataSourceID {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - EditForm Property

APNSoftDataGrid.EditForm Property

Gets the Edit Form.

[Visual Basic]
Public ReadOnly Property EditForm As GridEditForm
[C#]
public GridEditForm EditForm {get;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - EditFormMethod Property

APNSoftDataGrid.EditFormMethod Property

Gets a value indicating the Edit Form is opened for INSERT or UPDATE. Default value is Undefined. When you open the Edit Form for UPDATE, fill in form fields with selected row data. Use the EditFormRow property to get the selected row.

[Visual Basic]
Public Shared ReadOnly Property EditFormMethod As EditFormMethodValues
[C#]
public static APNSoftDataGrid.EditFormMethodValues EditFormMethod {get;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - EditFormRow Property

APNSoftDataGrid.EditFormRow Property

Gets the selected row, used to fill in the Edit Form before update.

[Visual Basic]
Public Shared ReadOnly Property EditFormRow As GridRow
[C#]
public static GridRow EditFormRow {get;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - FixedColumnsOpacity Property

APNSoftDataGrid.FixedColumnsOpacity Property

Gets or sets the opacity factor applied to the fixed columns. Range: 0-100. Default value is 100 (columns are NOT transparent).

[Visual Basic]
Public Property FixedColumnsOpacity As Byte
[C#]
public byte FixedColumnsOpacity {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Height Property

APNSoftDataGrid.Height Property

Gets or sets a value indicating the height of the DataGrid in pixels. Range: 60-2048.

[Visual Basic]
Overrides Public Property Height As Unit
[C#]
public override System.Web.UI.WebControls.Unit Height {get; set;}

Example

[C#]
myDataGrid.Height = 250;

[Visual Basic]
myDataGrid.Height = New System.Web.UI.WebControls.Unit(250)

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - HighlightHoveredRow Property

APNSoftDataGrid.HighlightHoveredRow Property

Gets or sets a value specifying whether the hovered row is highlighted. Default value is true.

[Visual Basic]
Public Property HighlightHoveredRow As Boolean
[C#]
public bool HighlightHoveredRow {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - HighlightSelectedRow Property

APNSoftDataGrid.HighlightSelectedRow Property

Gets or sets a value specifying whether the selected row is highlighted. Default value is true.

[Visual Basic]
Public Property HighlightSelectedRow As Boolean
[C#]
public bool HighlightSelectedRow {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - KeyFieldName Property

APNSoftDataGrid.KeyFieldName Property

Gets or sets the name of column that uniquely identifies each record stored in the table. The key field is commonly used in a handler for an event, such as UpdateCommand or DeleteCommand, as part of an update query string to revise a specific record in the data source. The key field helps the update query string identify the appropriate record to modify.

[Visual Basic]
Public Property KeyFieldName As String
[C#]
public string KeyFieldName {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - MessageDeleting Property

APNSoftDataGrid.MessageDeleting Property

Specifies a message to be displayed when control deletes a record. Default value is Deleting....

[Visual Basic]
Public Property MessageDeleting As String
[C#]
public string MessageDeleting {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - MessageInserting Property

APNSoftDataGrid.MessageInserting Property

Specifies a message to be displayed when control inserts a record. Default value is Inserting....

[Visual Basic]
Public Property MessageInserting As String
[C#]
public string MessageInserting {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - MessageLoading Property

APNSoftDataGrid.MessageLoading Property

Specifies a message to be displayed when control loads records. Default value is Loading....

[Visual Basic]
Public Property MessageLoading As String
[C#]
public string MessageLoading {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - MessageNoRecords Property

APNSoftDataGrid.MessageNoRecords Property

Specifies a message to be displayed when there are no records in the data source. Default value is No records to display..

[Visual Basic]
Public Property MessageNoRecords As String
[C#]
public string MessageNoRecords {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - MessageProcessing Property

APNSoftDataGrid.MessageProcessing Property

Specifies a message to be displayed when control launches custom asynchronous call. Default value is Processing....

[Visual Basic]
Public Property MessageProcessing As String
[C#]
public string MessageProcessing {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - MessageReady Property

APNSoftDataGrid.MessageReady Property

Specifies a message to be displayed when control is ready for an action. Default value is Ready..

[Visual Basic]
Public Property MessageReady As String
[C#]
public string MessageReady {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - MessageUpdating Property

APNSoftDataGrid.MessageUpdating Property

Specifies a message to be displayed when control updates a record. Default value is Updating....

[Visual Basic]
Public Property MessageUpdating As String
[C#]
public string MessageUpdating {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Mode Property

APNSoftDataGrid.Mode Property

Gets or sets the running mode of the DataGrid.

[Visual Basic]
Public Property Mode As ModeValues
[C#]
public APNSoftDataGrid.ModeValues Mode {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - PageCount Property

APNSoftDataGrid.PageCount Property

Gets the total number of pages in the grid.

[Visual Basic]
Public ReadOnly Property PageCount As Integer
[C#]
public int PageCount {get;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - PageSize Property

APNSoftDataGrid.PageSize Property

Gets or sets the maximum number of rows to be displayed on a single page of the DataGrid control. Range: 1-10000. The default value is 20. The total number of pages is calculated automatically depending on data amount.

[Visual Basic]
Public Property PageSize As Integer
[C#]
public int PageSize {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - RightClickSelect Property

APNSoftDataGrid.RightClickSelect Property

Gets or sets a value specifying whether a row is selected when the user right-clicks on the row. Default value is true. Note that the property value must be true if you use context menu for rows.

[Visual Basic]
Public Property RightClickSelect As Boolean
[C#]
public bool RightClickSelect {get; set;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - RowFilter Property

APNSoftDataGrid.RowFilter Property

Gets or sets the expression used to filter which rows are viewed in the DataGrid.

[Visual Basic]
Public Property RowFilter As String
[C#]
public string RowFilter {get; set;}

Remarks

To form a RowFilter value, specify the name of a column followed by an operator and a value to filter on. The value must be in quotes. For example: "LastName = 'Smith'"

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Rows Property

APNSoftDataGrid.Rows Property

Gets the collection of rows.

[Visual Basic]
Public ReadOnly Property Rows As GridRowCollection
[C#]
public GridRowCollection Rows {get;}

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - SEOEnabled Property

APNSoftDataGrid.SEOEnabled Property

Gets or sets a value indicating whether the DataGrid renders an additional NOSCRIPT section with links which correspond to DataGrid rows. Default value is false.

[Visual Basic]
Public Property SEOEnabled As Boolean
[C#]
public bool SEOEnabled {get; set;}

Remarks

Row link has the syntax: <a href="?RowID=8">R</a>. Developer should create additional procedure, which analyzes the RowID value (8 in our example) and displays required row data on the page. It is recommended to use the KeyFieldName property to set a name of column that identifies each row uniquely. Row indexes (0, 1, 2 ...) are used for uniqueness by default.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Width Property

APNSoftDataGrid.Width Property

Gets or sets a value indicating the width of the DataGrid in pixels. Range: 100-4096.

[Visual Basic]
Overrides Public Property Width As Unit
[C#]
public override System.Web.UI.WebControls.Unit Width {get; set;}

Example

[C#]
myDataGrid.Width = 550;

[Visual Basic]
myDataGrid.Width = New System.Web.UI.WebControls.Unit(550)

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid Methods

APNSoftDataGrid Methods

The methods of the APNSoftDataGrid class are listed below. For a complete list of APNSoftDataGrid class members, see the APNSoftDataGrid Members topic.

Public Instance Methods

AddContextMenu | Adds Context Menu into the collection.
ApplyRowFilter | Sets a filter to the rows.
DataBind | Creates a binding between the DataGrid control and a data source.
GetSelectedRow | Returns the Selected Row.
GetSortedColumn | Returns the Sorted Column.
ResetColumnWidths | This method sets all columns at an equal percent fraction of the DataGrid width.
ResetPageNumber | This method sets a Page Number to its default value.
ResetScrollbars | This method sets Scrollbars to default values.
ResetSelectedRow | This method removes the 'Selected' attribute from the row.
ResetSortedColumn | This method removes the 'Sorted' attribute from the column.
SetPage | Sets the current page number. This method must be called after the DataBind() method.
SortRows | Sorts the rows in the collection.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.AddContextMenu Method

APNSoftDataGrid.AddContextMenu Method

Adds Context Menu into the collection.

[Visual Basic]
Public Sub AddContextMenu( _
ByVal ID As String, _
ByVal ContextMenu As String _
)
[C#]
public void AddContextMenu(
string ID,
string ContextMenu
);

Parameters

ID
The string identifying the DIV element of Context Menu.
ContextMenu
An XML string or path to the template file for context menu.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ApplyRowFilter Method

APNSoftDataGrid.ApplyRowFilter Method

Sets a filter to the rows.

[Visual Basic]
Public Sub ApplyRowFilter()
[C#]
public void ApplyRowFilter();

Example

[C#]
dg1.DataSource = ...
dg1.DataBind();
dg1.RowFilter = "CustomerID Like 'A%'";
dg1.ApplyRowFilter();

[Visual Basic]
dg1.DataSource = ...
dg1.DataBind()
dg1.RowFilter = "CustomerID Like 'A%'"
dg1.ApplyRowFilter()

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.DataBind Method

APNSoftDataGrid.DataBind Method

Creates a binding between the DataGrid control and a data source.

[Visual Basic]
Overrides Public Sub DataBind()
[C#]
public override void DataBind();

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.GetSelectedRow Method

APNSoftDataGrid.GetSelectedRow Method

Returns the Selected Row.

[Visual Basic]
Public Function GetSelectedRow() As GridRow
[C#]
public GridRow GetSelectedRow();

Return Value

Selected Row.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.GetSortedColumn Method

APNSoftDataGrid.GetSortedColumn Method

Returns the Sorted Column.

[Visual Basic]
Public Function GetSortedColumn() As GridColumn
[C#]
public GridColumn GetSortedColumn();

Return Value

Sorted Column.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ResetColumnWidths Method

APNSoftDataGrid.ResetColumnWidths Method

This method sets all columns at an equal percent fraction of the DataGrid width.

[Visual Basic]
Public Sub ResetColumnWidths()
[C#]
public void ResetColumnWidths();

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ResetPageNumber Method

APNSoftDataGrid.ResetPageNumber Method

This method sets a Page Number to its default value.

[Visual Basic]
Public Sub ResetPageNumber()
[C#]
public void ResetPageNumber();

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ResetScrollbars Method

APNSoftDataGrid.ResetScrollbars Method

This method sets Scrollbars to default values.

[Visual Basic]
Public Sub ResetScrollbars()
[C#]
public void ResetScrollbars();

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ResetSelectedRow Method

APNSoftDataGrid.ResetSelectedRow Method

This method removes the 'Selected' attribute from the row.

[Visual Basic]
Public Sub ResetSelectedRow()
[C#]
public void ResetSelectedRow();

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ResetSortedColumn Method

APNSoftDataGrid.ResetSortedColumn Method

This method removes the 'Sorted' attribute from the column.

[Visual Basic]
Public Sub ResetSortedColumn()
[C#]
public void ResetSortedColumn();

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.SetPage Method

APNSoftDataGrid.SetPage Method

Sets the current page number. This method must be called after the DataBind() method.

[Visual Basic]
Public Sub SetPage( _
ByVal PageNumber As Integer _
)
[C#]
public void SetPage(
int PageNumber
);

Parameters

PageNumber
The page number to be shown.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.SortRows Method

APNSoftDataGrid.SortRows Method

Sorts the rows in the collection.

[Visual Basic]
Public Function SortRows() As GridColumn
[C#]
public GridColumn SortRows();

Return Value

Sorted column.

Example

[C#]
dg1.DataSource = ...
dg1.DataBind();
dg1.Columns["PostalCode"].Sorted = GridColumn.SortedValues.Ascending;
dg1.SortRows();

[Visual Basic]
dg1.DataSource = ...
dg1.DataBind()
dg1.Columns("PostalCode").Sorted = GridColumn.SortedValues.Ascending
dg1.SortRows()

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid Events

APNSoftDataGrid Events

The events of the APNSoftDataGrid class are listed below. For a complete list of APNSoftDataGrid class members, see the APNSoftDataGrid Members topic.

Public Instance Events

CallTheServer | Occurs on the server side when we call the server from client side by launching the dg.CallTheServer(); procedure.
CellValueChanged | Occurs on the server side when the cell value is changed.
DeleteCommand | Occurs on the server side when an delete command is fired.
ExportCustom | Occurs on the server side when the Custom Export command is fired.
ExportToExcel | Occurs on the server side when the Export To Excel command is fired.
ExportToHTML | Occurs on the server side when the Export To HTML command is fired.
InsertCommand | Occurs on the server side when an insert command is fired.
OnRowClick | Occurs on the server side when the row is clicked or double-clicked.
PageNumberChanged | Occurs on the server side after the page is changed.
SortCommand | Occurs on the server side when a sort command is fired.
UpdateCommand | Occurs on the server side when an update command is fired.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.CallTheServer Event

APNSoftDataGrid.CallTheServer Event

Occurs on the server side when we call the server from client side by launching the dg.CallTheServer(); procedure.

[Visual Basic]
Public Event CallTheServer As DataGridEventHandler
[C#]
public event DataGridEventHandler CallTheServer;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.CellValueChanged Event

APNSoftDataGrid.CellValueChanged Event

Occurs on the server side when the cell value is changed.

[Visual Basic]
Public Event CellValueChanged As DataGridEventHandler
[C#]
public event DataGridEventHandler CellValueChanged;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.DeleteCommand Event

APNSoftDataGrid.DeleteCommand Event

Occurs on the server side when an delete command is fired.

[Visual Basic]
Public Event DeleteCommand As DataGridEventHandler
[C#]
public event DataGridEventHandler DeleteCommand;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ExportCustom Event

APNSoftDataGrid.ExportCustom Event

Occurs on the server side when the Custom Export command is fired.

[Visual Basic]
Public Event ExportCustom As DataGridEventHandler
[C#]
public event DataGridEventHandler ExportCustom;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ExportToExcel Event

APNSoftDataGrid.ExportToExcel Event

Occurs on the server side when the Export To Excel command is fired.

[Visual Basic]
Public Event ExportToExcel As DataGridEventHandler
[C#]
public event DataGridEventHandler ExportToExcel;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ExportToHTML Event

APNSoftDataGrid.ExportToHTML Event

Occurs on the server side when the Export To HTML command is fired.

[Visual Basic]
Public Event ExportToHTML As DataGridEventHandler
[C#]
public event DataGridEventHandler ExportToHTML;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.InsertCommand Event

APNSoftDataGrid.InsertCommand Event

Occurs on the server side when an insert command is fired.

[Visual Basic]
Public Event InsertCommand As DataGridEventHandler
[C#]
public event DataGridEventHandler InsertCommand;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.OnRowClick Event

APNSoftDataGrid.OnRowClick Event

Occurs on the server side when the row is clicked or double-clicked.

[Visual Basic]
Public Event OnRowClick As DataGridEventHandler
[C#]
public event DataGridEventHandler OnRowClick;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.PageNumberChanged Event

APNSoftDataGrid.PageNumberChanged Event

Occurs on the server side after the page is changed.

[Visual Basic]
Public Event PageNumberChanged As DataGridEventHandler
[C#]
public event DataGridEventHandler PageNumberChanged;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.SortCommand Event

APNSoftDataGrid.SortCommand Event

Occurs on the server side when a sort command is fired.

[Visual Basic]
Public Event SortCommand As DataGridEventHandler
[C#]
public event DataGridEventHandler SortCommand;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.UpdateCommand Event

APNSoftDataGrid.UpdateCommand Event

Occurs on the server side when an update command is fired.

[Visual Basic]
Public Event UpdateCommand As DataGridEventHandler
[C#]
public event DataGridEventHandler UpdateCommand;

Event Data

The event handler receives an argument of type DataGridEventArgs containing data related to this event. The following DataGridEventArgs properties provide information specific to this event.

Property | Description
CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftDataGrid Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.AutoResizeValues Enumeration

APNSoftDataGrid.AutoResizeValues Enumeration

Values for the AutoResize property.

[Visual Basic]
Public Enum APNSoftDataGrid.AutoResizeValues
[C#]
public enum APNSoftDataGrid.AutoResizeValues

Members

Member Name | Description
None | AutoResize disabled.
Width | AutoResize enabled for Width only.
Height | AutoResize enabled for Height only.
WidthAndHeight | AutoResize enabled for both Width and Height.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.EditFormMethodValues Enumeration

APNSoftDataGrid.EditFormMethodValues Enumeration

Values for the EditFormMethod property.

[Visual Basic]
Public Enum APNSoftDataGrid.EditFormMethodValues
[C#]
public enum APNSoftDataGrid.EditFormMethodValues

Members

Member Name | Description
Insert | The Edit Form is opened to insert new record.
Update | The Edit Form is opened to update an existed record.
Undefined | The default value.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET DataGrid Control - APNSoftDataGrid.ModeValues Enumeration

APNSoftDataGrid.ModeValues Enumeration

Values for the Mode property.

[Visual Basic]
Public Enum APNSoftDataGrid.ModeValues
[C#]
public enum APNSoftDataGrid.ModeValues

Members

Member Name | Description
CallBack | Paging and sorting are performed through AJAX-style HTTP callbacks.
PostBack | Paging and sorting are performed on the server side. Each action initiates an ASP.NET postback and triggers the appropriate server-side event.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElement Class

APNSoftElement Class

Represents the part of a APNSoftElementCollection.

For a list of all members of this type, see APNSoftElement Members.

System.Object
APNSoft.WebControls.APNSoftElement
APNSoft.WebControls.ComboBoxElement
APNSoft.WebControls.MenuElement
APNSoft.WebControls.RatingSegment
APNSoft.WebControls.TreeViewElement

[Visual Basic]
Public Class APNSoftElement
[C#]
public class APNSoftElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoftElement Members | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElement Members

APNSoftElement Members

APNSoftElement overview

Public Instance Properties

AutoPostBackOnItemClick | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
ClientSideOnItemClick | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
href | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight | Gets or sets the pixel height of the item's icon.
iconWidth | Gets or sets the pixel width of the item's icon.
id | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
target | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
title | Gets or sets the text (caption) displayed for the item.
Type | Gets or sets a type of the Element.

Public Instance Methods

MoveBackward | Moves the element backward by one position in the current element group.
MoveForward | Moves the element forward by one position in the current element group.
Remove | Removes specified element from the collection.

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElement Properties

APNSoftElement Properties

The properties of the APNSoftElement class are listed below. For a complete list of APNSoftElement class members, see the APNSoftElement Members topic.

Public Instance Properties

AutoPostBackOnItemClick | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
ClientSideOnItemClick | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
href | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight | Gets or sets the pixel height of the item's icon.
iconWidth | Gets or sets the pixel width of the item's icon.
id | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
target | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
title | Gets or sets the text (caption) displayed for the item.
Type | Gets or sets a type of the Element.

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - AutoPostBackOnItemClick Property

APNSoftElement.AutoPostBackOnItemClick Property

Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.

[Visual Basic]
Public Property AutoPostBackOnItemClick As Boolean
[C#]
public bool AutoPostBackOnItemClick {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - ClientSideOnItemClick Property

APNSoftElement.ClientSideOnItemClick Property

Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.

[Visual Basic]
Public Property ClientSideOnItemClick As String
[C#]
public string ClientSideOnItemClick {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - href Property

APNSoftElement.href Property

Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.

[Visual Basic]
Public Property href As String
[C#]
public string href {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - icon Property

APNSoftElement.icon Property

Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.

[Visual Basic]
Public Property icon As String
[C#]
public string icon {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - iconHeight Property

APNSoftElement.iconHeight Property

Gets or sets the pixel height of the item's icon.

[Visual Basic]
Public Property iconHeight As Integer
[C#]
public int iconHeight {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - iconWidth Property

APNSoftElement.iconWidth Property

Gets or sets the pixel width of the item's icon.

[Visual Basic]
Public Property iconWidth As Integer
[C#]
public int iconWidth {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - id Property

APNSoftElement.id Property

Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.

[Visual Basic]
Public Property id As String
[C#]
public string id {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - target Property

APNSoftElement.target Property

Gets or sets the target window or frame to load Web page content into when a user clicks the item.

[Visual Basic]
Public Property target As String
[C#]
public string target {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - title Property

APNSoftElement.title Property

Gets or sets the text (caption) displayed for the item.

[Visual Basic]
Public Property title As String
[C#]
public string title {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - Type Property

APNSoftElement.Type Property

Gets or sets a type of the Element.

[Visual Basic]
Public Property Type As Types
[C#]
public APNSoftElement.Types Type {get; set;}

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElement Methods

APNSoftElement Methods

The methods of the APNSoftElement class are listed below. For a complete list of APNSoftElement class members, see the APNSoftElement Members topic.

Public Instance Methods

MoveBackward | Moves the element backward by one position in the current element group.
MoveForward | Moves the element forward by one position in the current element group.
Remove | Removes specified element from the collection.

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElement.MoveBackward Method

APNSoftElement.MoveBackward Method

Moves the element backward by one position in the current element group.

[Visual Basic]
Public Sub MoveBackward()
[C#]
public void MoveBackward();

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElement.MoveForward Method

APNSoftElement.MoveForward Method

Moves the element forward by one position in the current element group.

[Visual Basic]
Public Sub MoveForward()
[C#]
public void MoveForward();

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElement.Remove Method

APNSoftElement.Remove Method

Removes specified element from the collection.

[Visual Basic]
Public Sub Remove()
[C#]
public void Remove();

See Also

APNSoftElement Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElement.Types Enumeration

APNSoftElement.Types Enumeration

Element types.

[Visual Basic]
Public Enum APNSoftElement.Types
[C#]
public enum APNSoftElement.Types

Members

Member Name | Description
Item | Element is an item.
Separator | Element is a separator.
Disabled | Element is disabled.
Unknown | Unknown element.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElementCollection Class

APNSoftElementCollection Class

Represents the collection of elements.

For a list of all members of this type, see APNSoftElementCollection Members.

System.Object
APNSoft.WebControls.APNSoftElementCollection
APNSoft.WebControls.ComboBoxElementCollection
APNSoft.WebControls.MenuElementCollection
APNSoft.WebControls.RatingSegmentCollection
APNSoft.WebControls.TreeViewElementCollection

[Visual Basic]
Public Class APNSoftElementCollection
[C#]
public class APNSoftElementCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoftElementCollection Members | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElementCollection Members

APNSoftElementCollection Members

APNSoftElementCollection overview

Public Instance Properties

Count Gets the number of elements in the collection.

Public Instance Methods

Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection.
Init | Initializes the collection.
Remove | Removes a specific element from the collection.

See Also

APNSoftElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElementCollection Properties

APNSoftElementCollection Properties

The properties of the APNSoftElementCollection class are listed below. For a complete list of APNSoftElementCollection class members, see the APNSoftElementCollection Members topic.

Public Instance Properties

Count Gets the number of elements in the collection.

See Also

APNSoftElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Control - Count Property

APNSoftElementCollection.Count Property

Gets the number of elements in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}

See Also

APNSoftElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElementCollection Methods

APNSoftElementCollection Methods

The methods of the APNSoftElementCollection class are listed below. For a complete list of APNSoftElementCollection class members, see the APNSoftElementCollection Members topic.

Public Instance Methods

Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection.
Init | Initializes the collection.
Remove | Removes a specific element from the collection.

See Also

APNSoftElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElementCollection.Clear Method

APNSoftElementCollection.Clear Method

Removes all elements from the collection.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

APNSoftElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElementCollection.Contains Method

APNSoftElementCollection.Contains Method

Determines whether an element is in the collection.

[Visual Basic]
Public Function Contains( _
ByVal ID As String _
) As Boolean
[C#]
public bool Contains(
string ID
);

Parameters

ID
ID of the element.

Return Value

true if element is found in the collection; otherwise, false.

See Also

APNSoftElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElementCollection.Init Method

APNSoftElementCollection.Init Method

Initializes the collection.

[Visual Basic]
Public Sub Init()
[C#]
public void Init();

See Also

APNSoftElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Control - APNSoftElementCollection.Remove Method

APNSoftElementCollection.Remove Method

Removes a specific element from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal ID As String _
)
[C#]
public void Remove(
string ID
);

Parameters

ID
ID of the element.

See Also

APNSoftElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Include Control - APNSoftInclude Class

APNSoftInclude Class

APNSoftInclude control class.

For a list of all members of this type, see APNSoftInclude Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
APNSoft.WebControls.APNSoftControl
APNSoft.WebControls.APNSoftInclude

[Visual Basic]
Public Class APNSoftInclude
Inherits APNSoftControl
[C#]
public class APNSoftInclude : APNSoftControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoftInclude Members | APNSoft.WebControls Namespace


ASP.NET Include Control - APNSoftInclude Constructor

APNSoftInclude Constructor

Initializes a new instance of the APNSoftInclude class.

[Visual Basic]
Public Sub New()
[C#]
public APNSoftInclude();

See Also

APNSoftInclude Class | APNSoft.WebControls Namespace


ASP.NET Include Control - APNSoftInclude Properties

APNSoftInclude Properties

The properties of the APNSoftInclude class are listed below. For a complete list of APNSoftInclude class members, see the APNSoftInclude Members topic.

Public Instance Properties

BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
IncludeFileURL | Gets or sets the target url is used as a source text data for the include.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
RequestURLTimeout | Request URL Timeout in milliseconds (20-200000).
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

See Also

APNSoftInclude Class | APNSoft.WebControls Namespace


ASP.NET Include Control - IncludeFileURL Property

APNSoftInclude.IncludeFileURL Property

Gets or sets the target url is used as a source text data for the include.

[Visual Basic]
Public Property IncludeFileURL As String
[C#]
public string IncludeFileURL {get; set;}

See Also

APNSoftInclude Class | APNSoft.WebControls Namespace


ASP.NET Include Control - RequestURLTimeout Property

APNSoftInclude.RequestURLTimeout Property

Request URL Timeout in milliseconds (20-200000).

[Visual Basic]
Public Property RequestURLTimeout As Integer
[C#]
public int RequestURLTimeout {get; set;}

See Also

APNSoftInclude Class | APNSoft.WebControls Namespace


ASP.NET Include Control - APNSoftInclude Methods

APNSoftInclude Methods

The methods of the APNSoftInclude class are listed below. For a complete list of APNSoftInclude class members, see the APNSoftInclude Members topic.

Public Instance Methods

DataBind Creates a binding between the Include control and a data source.

See Also

APNSoftInclude Class | APNSoft.WebControls Namespace


ASP.NET Include Control - APNSoftInclude.DataBind Method

APNSoftInclude.DataBind Method

Creates a binding between the Include control and a data source.

[Visual Basic]
Overrides Public Sub DataBind()
[C#]
public override void DataBind();

See Also

APNSoftInclude Class | APNSoft.WebControls Namespace


ASP.NET Include Control - APNSoftInclude Events

APNSoftInclude Events

The events of the APNSoftInclude class are listed below. For a complete list of APNSoftInclude class members, see the APNSoftInclude Members topic.

Public Instance Events

DataBinding Occurs on the server side when the control binds to a data source.

See Also

APNSoftInclude Class | APNSoft.WebControls Namespace


ASP.NET Include Control - APNSoftInclude.DataBinding Event

APNSoftInclude.DataBinding Event

Occurs on the server side when the control binds to a data source.

[Visual Basic]
Public Event DataBinding As IncludeEventHandler
[C#]
public event IncludeEventHandler DataBinding;

See Also

APNSoftInclude Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu Class

APNSoftMenu Class

APNSoftMenu control class.

For a list of all members of this type, see APNSoftMenu Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
APNSoft.WebControls.APNSoftControl
APNSoft.WebControls.APNSoftMenu

[Visual Basic]
Public Class APNSoftMenu
Inherits APNSoftControl
Implements IPostBackEventHandler, ICallbackEventHandler
[C#]
public class APNSoftMenu : APNSoftControl, IPostBackEventHandler, ICallbackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoftMenu Members | APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu Constructor

APNSoftMenu Constructor

Initializes a new instance of the APNSoftMenu class.

[Visual Basic]
Public Sub New()
[C#]
public APNSoftMenu();

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu Properties

APNSoftMenu Properties

The properties of the APNSoftMenu class are listed below. For a complete list of APNSoftMenu class members, see the APNSoftMenu Members topic.

Public Instance Properties

AutoPostBackOnItemClick | Specifies whether the control causes a postback to the server when an Item is clicked. Default value is false.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
BuilderMode | Turns the Menu into non-standard control. Default value is false.
ClientSideOnItemClick | Gets or sets the client-side code to be launched when an item is clicked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
Elements | Gets the collection of elements.
ExpandDelay | Gets or sets a delay in milliseconds before a submenu expands. Default value is 250.
ExpandDelayHorizontal | Gets or sets a delay in milliseconds for submenus of main menu in horizontal orientation. Default value is 20.
ExpandDirectionHorizontal | Gets or sets the horizontal direction to which submenus expand. Default value is LeftToRight.
ExpandDirectionVertical | Gets or sets the vertical direction to which submenus expand. It is applied to horizontal menu only. Default value is Downwards.
FadeEffect | Specifies whether the control displays the submenus with animated Fade effect. Default value is true.
FadeSpeed | Gets or sets the speed of Fade Effect. Range: 0-50. Default value is 5.
HighlightPath | Gets or sets the value indicating whether the menu highlights the selected item as well as the whole navigation path. Default value is false.
LoadingText | Gets or sets the text displayed in the tooltip while loading load-on-demand content. Default value is Loading....
LoadOnDemand | Specifies whether submenu will be loaded on demand. Default value is false.
Orientation | Specifies the menu orientation. Default value is Horizontal.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
OverlapHorizontal | Specifies the amount of horizontal overlap a submenu will have over its parent item. Default value is -5px.
OverlapVertical | Specifies the amount of vertical overlap a submenu will have over its parent first level horizontal menu. Default value is -4px.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
Roles | Gets or sets the roles the current user belongs to. User roles provide developers with an easy and flexible way to control access to various menu elements. Menu can be assigned to multiple roles.
SaveScrollPosition | Gets or sets the value indicating whether the menu keeps the scroll position for submenus. Default value is true.
SEOEnabled | Gets or sets a value indicating whether the control renders an additional NOSCRIPT section with links let all search engines index your website properly. Default value is false.
ShowStartingNode | Gets or sets a value indicating whether the menu renders the starting node. Default value is true.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
StructureFileURL | Gets or sets the URL to the structure file. If the property is not specified, component uses internal default structure. The property value can be an absolute or relative URI. Menu has support to use the Web.sitemap file as a standard menu structure.
SubMenusClose | Gets or sets a value indicating whether all of the opened submenus are closed by mouse click outside the menu or automatically when the mouse goes away. Default value is Auto.
SubMenusHeight | Gets or sets the maximum height in pixels for submenus. A submenu automatically becomes scrollable if its height less than the real height of its contents.
SubmenusHideOnItemClick | Gets or sets a value indicating whether the submenus should automatically close when an Item is clicked. Default value is false.
SubMenusOpen | Gets or sets a value indicating whether the submenus of the root menu are opened by mouse click or automatically when user moves the mouse pointer over the menu item. Default value is OnMouseOver.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - AutoPostBackOnItemClick Property

APNSoftMenu.AutoPostBackOnItemClick Property

Specifies whether the control causes a postback to the server when an Item is clicked. Default value is false.

[Visual Basic]
Public Property AutoPostBackOnItemClick As Boolean
[C#]
public bool AutoPostBackOnItemClick {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - BuilderMode Property

APNSoftMenu.BuilderMode Property

Turns the Menu into non-standard control. Default value is false.

[Visual Basic]
Public Property BuilderMode As Boolean
[C#]
public bool BuilderMode {get; set;}

Remarks

For service purposes only. Do not use this property.

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - ClientSideOnItemClick Property

APNSoftMenu.ClientSideOnItemClick Property

Gets or sets the client-side code to be launched when an item is clicked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnItemClick As String
[C#]
public string ClientSideOnItemClick {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - Elements Property

APNSoftMenu.Elements Property

Gets the collection of elements.

[Visual Basic]
Public ReadOnly Property Elements As MenuElementCollection
[C#]
public MenuElementCollection Elements {get;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - ExpandDelay Property

APNSoftMenu.ExpandDelay Property

Gets or sets a delay in milliseconds before a submenu expands. Default value is 250.

[Visual Basic]
Public Property ExpandDelay As Integer
[C#]
public int ExpandDelay {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - ExpandDelayHorizontal Property

APNSoftMenu.ExpandDelayHorizontal Property

Gets or sets a delay in milliseconds for submenus of main menu in horizontal orientation. Default value is 20.

[Visual Basic]
Public Property ExpandDelayHorizontal As Integer
[C#]
public int ExpandDelayHorizontal {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - ExpandDirectionHorizontal Property

APNSoftMenu.ExpandDirectionHorizontal Property

Gets or sets the horizontal direction to which submenus expand. Default value is LeftToRight.

[Visual Basic]
Public Property ExpandDirectionHorizontal As ExpandDirectionHorizontalValues
[C#]
public APNSoftMenu.ExpandDirectionHorizontalValues ExpandDirectionHorizontal {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - ExpandDirectionVertical Property

APNSoftMenu.ExpandDirectionVertical Property

Gets or sets the vertical direction to which submenus expand. It is applied to horizontal menu only. Default value is Downwards.

[Visual Basic]
Public Property ExpandDirectionVertical As ExpandDirectionVerticalValues
[C#]
public APNSoftMenu.ExpandDirectionVerticalValues ExpandDirectionVertical {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - FadeEffect Property

APNSoftMenu.FadeEffect Property

Specifies whether the control displays the submenus with animated Fade effect. Default value is true.

[Visual Basic]
Public Property FadeEffect As Boolean
[C#]
public bool FadeEffect {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - FadeSpeed Property

APNSoftMenu.FadeSpeed Property

Gets or sets the speed of Fade Effect. Range: 0-50. Default value is 5.

[Visual Basic]
Public Property FadeSpeed As Byte
[C#]
public byte FadeSpeed {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - HighlightPath Property

APNSoftMenu.HighlightPath Property

Gets or sets the value indicating whether the menu highlights the selected item as well as the whole navigation path. Default value is false.

[Visual Basic]
Public Property HighlightPath As Boolean
[C#]
public bool HighlightPath {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - LoadingText Property

APNSoftMenu.LoadingText Property

Gets or sets the text displayed in the tooltip while loading load-on-demand content. Default value is Loading....

[Visual Basic]
Public Property LoadingText As String
[C#]
public string LoadingText {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - LoadOnDemand Property

APNSoftMenu.LoadOnDemand Property

Specifies whether submenu will be loaded on demand. Default value is false.

[Visual Basic]
Public Property LoadOnDemand As Boolean
[C#]
public bool LoadOnDemand {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - Orientation Property

APNSoftMenu.Orientation Property

Specifies the menu orientation. Default value is Horizontal.

[Visual Basic]
Public Property Orientation As OrientationValues
[C#]
public APNSoftMenu.OrientationValues Orientation {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - OverlapHorizontal Property

APNSoftMenu.OverlapHorizontal Property

Specifies the amount of horizontal overlap a submenu will have over its parent item. Default value is -5px.

[Visual Basic]
Public Property OverlapHorizontal As Unit
[C#]
public System.Web.UI.WebControls.Unit OverlapHorizontal {get; set;}

Example

[C#]
myMenu.OverlapHorizontal = 0;

[Visual Basic]
myMenu.OverlapHorizontal = New System.Web.UI.WebControls.Unit(0)

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - OverlapVertical Property

APNSoftMenu.OverlapVertical Property

Specifies the amount of vertical overlap a submenu will have over its parent first level horizontal menu. Default value is -4px.

[Visual Basic]
Public Property OverlapVertical As Unit
[C#]
public System.Web.UI.WebControls.Unit OverlapVertical {get; set;}

Example

[C#]
myMenu.OverlapVertical = 0;

[Visual Basic]
myMenu.OverlapVertical = New System.Web.UI.WebControls.Unit(0)

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - Roles Property

APNSoftMenu.Roles Property

Gets or sets the roles the current user belongs to. User roles provide developers with an easy and flexible way to control access to various menu elements. Menu can be assigned to multiple roles.

[Visual Basic]
Public Property Roles As String
[C#]
public string Roles {get; set;}

Example

[C#]
myMenu.Roles = "Admins";
or:
myMenu.Roles = "Admins,Users";

[Visual Basic]
myMenu.Roles = "Admins"
or:
myMenu.Roles = "Admins,Users"

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - SaveScrollPosition Property

APNSoftMenu.SaveScrollPosition Property

Gets or sets the value indicating whether the menu keeps the scroll position for submenus. Default value is true.

[Visual Basic]
Public Property SaveScrollPosition As Boolean
[C#]
public bool SaveScrollPosition {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - SEOEnabled Property

APNSoftMenu.SEOEnabled Property

Gets or sets a value indicating whether the control renders an additional NOSCRIPT section with links let all search engines index your website properly. Default value is false.

[Visual Basic]
Public Property SEOEnabled As Boolean
[C#]
public bool SEOEnabled {get; set;}

Remarks

The links of the control items are implemented with the JavaScript OnClick procedure, which can not be indexed by search-engine spiders. To overcome this obstacle, control generates an additional NOSCRIPT section with regular href tags.

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - ShowStartingNode Property

APNSoftMenu.ShowStartingNode Property

Gets or sets a value indicating whether the menu renders the starting node. Default value is true.

[Visual Basic]
Public Property ShowStartingNode As Boolean
[C#]
public bool ShowStartingNode {get; set;}

Remarks

You can set this property to determine whether the menu exposes the starting node as the root of the structure, or whether it starts from the child nodes of the root node instead.

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - StructureFileURL Property

APNSoftMenu.StructureFileURL Property

Gets or sets the URL to the structure file. If the property is not specified, component uses internal default structure. The property value can be an absolute or relative URI. Menu has support to use the Web.sitemap file as a standard menu structure.

[Visual Basic]
Public Property StructureFileURL As String
[C#]
public string StructureFileURL {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - SubMenusClose Property

APNSoftMenu.SubMenusClose Property

Gets or sets a value indicating whether all of the opened submenus are closed by mouse click outside the menu or automatically when the mouse goes away. Default value is Auto.

[Visual Basic]
Public Property SubMenusClose As SubMenusCloseValues
[C#]
public APNSoftMenu.SubMenusCloseValues SubMenusClose {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - SubMenusHeight Property

APNSoftMenu.SubMenusHeight Property

Gets or sets the maximum height in pixels for submenus. A submenu automatically becomes scrollable if its height less than the real height of its contents.

[Visual Basic]
Public Property SubMenusHeight As Unit
[C#]
public System.Web.UI.WebControls.Unit SubMenusHeight {get; set;}

Example

[C#]
myMenu.SubMenusHeight = 200;

[Visual Basic]
myMenu.SubMenusHeight = New System.Web.UI.WebControls.Unit(200)

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - SubmenusHideOnItemClick Property

APNSoftMenu.SubmenusHideOnItemClick Property

Gets or sets a value indicating whether the submenus should automatically close when an Item is clicked. Default value is false.

[Visual Basic]
Public Property SubmenusHideOnItemClick As Boolean
[C#]
public bool SubmenusHideOnItemClick {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - SubMenusOpen Property

APNSoftMenu.SubMenusOpen Property

Gets or sets a value indicating whether the submenus of the root menu are opened by mouse click or automatically when user moves the mouse pointer over the menu item. Default value is OnMouseOver.

[Visual Basic]
Public Property SubMenusOpen As SubMenusOpenValues
[C#]
public APNSoftMenu.SubMenusOpenValues SubMenusOpen {get; set;}

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu Methods

APNSoftMenu Methods

The methods of the APNSoftMenu class are listed below. For a complete list of APNSoftMenu class members, see the APNSoftMenu Members topic.

Public Instance Methods

DataBind | Creates a binding between the Menu control and a data source.
GetSelectedItemID | Returns the selected Item ID.

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu.DataBind Method

APNSoftMenu.DataBind Method

Creates a binding between the Menu control and a data source.

[Visual Basic]
Overrides Public Sub DataBind()
[C#]
public override void DataBind();

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu.GetSelectedItemID Method

APNSoftMenu.GetSelectedItemID Method

Returns the selected Item ID.

[Visual Basic]
Public Function GetSelectedItemID() As String
[C#]
public string GetSelectedItemID();

Return Value

The selected Item ID.

Remarks

When the form is returned after a postback, the Selected Item ID can be defined by this method.

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu Events

APNSoftMenu Events

The events of the APNSoftMenu class are listed below. For a complete list of APNSoftMenu class members, see the APNSoftMenu Members topic.

Public Instance Events

OnItemClick Occurs on the server side when the item is clicked.

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu.OnItemClick Event

APNSoftMenu.OnItemClick Event

Occurs on the server side when the item is clicked.

[Visual Basic]
Public Event OnItemClick As MenuEventHandler
[C#]
public event MenuEventHandler OnItemClick;

See Also

APNSoftMenu Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu.ExpandDirectionHorizontalValues Enumeration

APNSoftMenu.ExpandDirectionHorizontalValues Enumeration

Values for the ExpandDirectionHorizontal property.

[Visual Basic]
Public Enum APNSoftMenu.ExpandDirectionHorizontalValues
[C#]
public enum APNSoftMenu.ExpandDirectionHorizontalValues

Members

Member Name | Description
LeftToRight | Left To Right direction.
RightToLeft | Right To Left direction.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu.ExpandDirectionVerticalValues Enumeration

APNSoftMenu.ExpandDirectionVerticalValues Enumeration

Values for the ExpandDirectionVertical property.

[Visual Basic]
Public Enum APNSoftMenu.ExpandDirectionVerticalValues
[C#]
public enum APNSoftMenu.ExpandDirectionVerticalValues

Members

Member Name | Description
Downwards | Downwards direction.
Upwards | Upwards direction.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu.OrientationValues Enumeration

APNSoftMenu.OrientationValues Enumeration

Values for the Orientation property.

[Visual Basic]
Public Enum APNSoftMenu.OrientationValues
[C#]
public enum APNSoftMenu.OrientationValues

Members

Member Name | Description
Horizontal | Horizontal orientation.
Vertical | Vertical orientation.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu.SubMenusCloseValues Enumeration

APNSoftMenu.SubMenusCloseValues Enumeration

Values for the SubMenusClose property.

[Visual Basic]
Public Enum APNSoftMenu.SubMenusCloseValues
[C#]
public enum APNSoftMenu.SubMenusCloseValues

Members

Member Name | Description
Auto | Submenus are closed automatically when the mouse goes away.
OnMouseClick | Submenus are closed by mouse click outside the menu.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Menu Control - APNSoftMenu.SubMenusOpenValues Enumeration

APNSoftMenu.SubMenusOpenValues Enumeration

Values for the SubMenusOpen property.

[Visual Basic]
Public Enum APNSoftMenu.SubMenusOpenValues
[C#]
public enum APNSoftMenu.SubMenusOpenValues

Members

Member Name | Description
OnMouseOver | Submenus are opened automatically when user moves the mouse pointer over the menu item.
OnMouseClick | Submenus are opened by mouse click.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating Class

APNSoftRating Class

APNSoftRating control class.

For a list of all members of this type, see APNSoftRating Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
APNSoft.WebControls.APNSoftControl
APNSoft.WebControls.APNSoftRating

[Visual Basic]
Public Class APNSoftRating
Inherits APNSoftControl
Implements IPostBackEventHandler, ICallbackEventHandler
[C#]
public class APNSoftRating : APNSoftControl, IPostBackEventHandler, ICallbackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoftRating Members | APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating Constructor

APNSoftRating Constructor

Initializes a new instance of the APNSoftRating class.

[Visual Basic]
Public Sub New()
[C#]
public APNSoftRating();

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating Properties

APNSoftRating Properties

The properties of the APNSoftRating class are listed below. For a complete list of APNSoftRating class members, see the APNSoftRating Members topic.

Public Instance Properties

AutoCallBackOnSegmentClick | Specifies whether the control causes an automatic callback to the server when a Segment is clicked. Default value is false.
AutoPostBackOnSegmentClick | Specifies whether the control causes a postback to the server when a Segment is clicked. Default value is false.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
ClientSideAfterCallBack | Gets or sets the client-side code to be launched after CallBack request. Property value can include variables $ComponentID$, $SegmentID$, $SegmentValue$ and $Parameter$, instead of which data is inserted.
ClientSideOnSegmentClick | Gets or sets the client-side code to be launched when a segment is clicked. Property value can include variables $ComponentID$, $SegmentID$, $SegmentIndex$ and $SegmentValue$, instead of which data is inserted.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
Direction | Specifies the fill direction for the control. Default value is Standard.
Orientation | Gets or sets a value indicating the orientation of segments within the Rating control. Default value is Horizontal.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
ReadOnly | Gets or sets a value indicating whether the segments of the control can be clicked. Default value is False.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
Segments | Gets the collection of segments.
SegmentsInTotal | Gets or sets the total number of segments. Range: 1-1024. The default value is 5.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
Template | Gets or sets the path to the template file for the Rating control. The property value can be an absolute or relative URI.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - AutoCallBackOnSegmentClick Property

APNSoftRating.AutoCallBackOnSegmentClick Property

Specifies whether the control causes an automatic callback to the server when a Segment is clicked. Default value is false.

[Visual Basic]
Public Property AutoCallBackOnSegmentClick As Boolean
[C#]
public bool AutoCallBackOnSegmentClick {get; set;}

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - AutoPostBackOnSegmentClick Property

APNSoftRating.AutoPostBackOnSegmentClick Property

Specifies whether the control causes a postback to the server when a Segment is clicked. Default value is false.

[Visual Basic]
Public Property AutoPostBackOnSegmentClick As Boolean
[C#]
public bool AutoPostBackOnSegmentClick {get; set;}

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - ClientSideAfterCallBack Property

APNSoftRating.ClientSideAfterCallBack Property

Gets or sets the client-side code to be launched after CallBack request. Property value can include variables $ComponentID$, $SegmentID$, $SegmentValue$ and $Parameter$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideAfterCallBack As String
[C#]
public string ClientSideAfterCallBack {get; set;}

Remarks

The Parameter is received in encoded form. To decode value, use the cmn.DecodeValue(Value) JavaScript method.

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - ClientSideOnSegmentClick Property

APNSoftRating.ClientSideOnSegmentClick Property

Gets or sets the client-side code to be launched when a segment is clicked. Property value can include variables $ComponentID$, $SegmentID$, $SegmentIndex$ and $SegmentValue$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnSegmentClick As String
[C#]
public string ClientSideOnSegmentClick {get; set;}

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Direction Property

APNSoftRating.Direction Property

Specifies the fill direction for the control. Default value is Standard.

[Visual Basic]
Public Property Direction As DirectionValues
[C#]
public APNSoftRating.DirectionValues Direction {get; set;}

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Orientation Property

APNSoftRating.Orientation Property

Gets or sets a value indicating the orientation of segments within the Rating control. Default value is Horizontal.

[Visual Basic]
Public Property Orientation As OrientationValues
[C#]
public APNSoftRating.OrientationValues Orientation {get; set;}

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - ReadOnly Property

APNSoftRating.ReadOnly Property

Gets or sets a value indicating whether the segments of the control can be clicked. Default value is False.

[Visual Basic]
Public Property ReadOnly As Boolean
[C#]
public bool ReadOnly {get; set;}

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Segments Property

APNSoftRating.Segments Property

Gets the collection of segments.

[Visual Basic]
Public ReadOnly Property Segments As RatingSegmentCollection
[C#]
public RatingSegmentCollection Segments {get;}

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - SegmentsInTotal Property

APNSoftRating.SegmentsInTotal Property

Gets or sets the total number of segments. Range: 1-1024. The default value is 5.

[Visual Basic]
Public Property SegmentsInTotal As Integer
[C#]
public int SegmentsInTotal {get; set;}

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Template Property

APNSoftRating.Template Property

Gets or sets the path to the template file for the Rating control. The property value can be an absolute or relative URI.

[Visual Basic]
Public Property Template As String
[C#]
public string Template {get; set;}

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating Methods

APNSoftRating Methods

The methods of the APNSoftRating class are listed below. For a complete list of APNSoftRating class members, see the APNSoftRating Members topic.

Public Instance Methods

DataBind | Creates a binding between the Rating control and a data source.
SetValue | Sets the value of the Rating control.

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating.DataBind Method

APNSoftRating.DataBind Method

Creates a binding between the Rating control and a data source.

[Visual Basic]
Overrides Public Sub DataBind()
[C#]
public override void DataBind();

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating.SetValue Method

APNSoftRating.SetValue Method

Sets the value of the Rating control.

[Visual Basic]
Public Sub SetValue( _
ByVal Value As Double _
)
[C#]
public void SetValue(
double Value
);

Parameters

Value
The value.

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating Events

APNSoftRating Events

The events of the APNSoftRating class are listed below. For a complete list of APNSoftRating class members, see the APNSoftRating Members topic.

Public Instance Events

CallTheServer | Occurs on the server side when we call the server from client side by launching the rt.CallTheServer(); procedure.
OnSegmentClick | Occurs on the server side when the segment is clicked.

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating.CallTheServer Event

APNSoftRating.CallTheServer Event

Occurs on the server side when we call the server from client side by launching the rt.CallTheServer(); procedure.

[Visual Basic]
Public Event CallTheServer As RatingEventHandler
[C#]
public event RatingEventHandler CallTheServer;

Event Data

The event handler receives an argument of type RatingEventArgs containing data related to this event. The following RatingEventArgs property provides information specific to this event.

Property | Description
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating.OnSegmentClick Event

APNSoftRating.OnSegmentClick Event

Occurs on the server side when the segment is clicked.

[Visual Basic]
Public Event OnSegmentClick As RatingEventHandler
[C#]
public event RatingEventHandler OnSegmentClick;

Event Data

The event handler receives an argument of type RatingEventArgs containing data related to this event. The following RatingEventArgs property provides information specific to this event.

Property | Description
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

APNSoftRating Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating.DirectionValues Enumeration

APNSoftRating.DirectionValues Enumeration

Values for the Direction property.

[Visual Basic]
Public Enum APNSoftRating.DirectionValues
[C#]
public enum APNSoftRating.DirectionValues

Members

Member Name | Description
Standard | Standard direction (left to right or bottom to top).
Reversed | Reversed direction (right to left or top to bottom).
None | The control only highlights the selected segment.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Rating Control - APNSoftRating.OrientationValues Enumeration

APNSoftRating.OrientationValues Enumeration

Values for the Orientation property.

[Visual Basic]
Public Enum APNSoftRating.OrientationValues
[C#]
public enum APNSoftRating.OrientationValues

Members

Member Name | Description
Horizontal | Horizontal orientation.
Vertical | Vertical orientation.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET TreeView Control - APNSoftTreeView Class

APNSoftTreeView Class

APNSoft TreeView Class.

For a list of all members of this type, see APNSoftTreeView Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
APNSoft.WebControls.APNSoftControl
APNSoft.WebControls.APNSoftTreeView

[Visual Basic]
Public Class APNSoftTreeView
Inherits APNSoftControl
Implements IPostBackEventHandler, ICallbackEventHandler
[C#]
public class APNSoftTreeView : APNSoftControl, IPostBackEventHandler, ICallbackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoftTreeView Members | APNSoft.WebControls Namespace


ASP.NET TreeView Control - APNSoftTreeView Constructor

APNSoftTreeView Constructor

Initializes a new instance of the APNSoftTreeView class.

[Visual Basic]
Public Sub New()
[C#]
public APNSoftTreeView();

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - APNSoftTreeView Properties

APNSoftTreeView Properties

The properties of the APNSoftTreeView class are listed below. For a complete list of APNSoftTreeView class members, see the APNSoftTreeView Members topic.

Public Instance Properties

AutoCollapse | Gets or sets a value indicating whether control automatically collapses child nodes when the user selects an item. Default value is false.
AutoExpand | Gets or sets a value indicating whether control automatically expands child nodes when the user selects an item. Default value is true.
AutoPostBackOnItemClick | Specifies whether the control causes a postback to the server when an Item is clicked. Default value is false.
BasePage (inherited from APNSoftControl) | Gets or sets the reference to the Base Page. Used only in Code Behind.
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes. Default value is false.
ClientSideOnCheck | Gets or sets the client-side code to be launched when an item is checked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnCollapse | Gets or sets the client-side code to be launched when an item is collapsed. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnExpand | Gets or sets the client-side code to be launched when an item is expanded. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnItemClick | Gets or sets the client-side code to be launched when an item is clicked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
ClientSideOnUnCheck | Gets or sets the client-side code to be launched when an item is unchecked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.
CSSClassesPrefix (inherited from APNSoftControl) | Gets or sets the prefix for CSS Style classes. Used for association between the set of classes and component instance.
CSSSource (inherited from APNSoftControl) | Gets or sets the location of the CSS Style. Default value is SkinFolder.
CSSStyleName (inherited from APNSoftControl) | Gets or sets the name of the CSS Style. The CSS Style must be located in the Skin Folder as specified by the SkinFolder property.
CSSText (inherited from APNSoftControl) | Sets the CSS style value for the control.
DataSource (inherited from APNSoftControl) | Gets or sets the data source that provides data for populating the control.
DurationCollapse | The duration (in milliseconds) of the collapse animation.
DurationExpand | The duration (in milliseconds) of the expand animation.
Elements | Gets the collection of elements.
ExpandSinglePath | Gets or sets a value indicating whether only the current branch is expanded. Default value is false.
LoadOnDemand | Specifies whether child nodes will be populated on demand. Default value is false.
OutputFooter (inherited from APNSoftControl) | Gets or sets the data used as a footer for the output HTML markup. Use the "Default" keyword for the standard comment.
OutputHeader (inherited from APNSoftControl) | Gets or sets the data used as a header for the output HTML markup. Use the "Default" keyword for the standard comment.
Position (inherited from APNSoftControl) | Gets or sets the type of positioning used for the control. Default value is Static.
PositionLeft (inherited from APNSoftControl) | Gets or sets the left coordinate for the control, which positioned at an absolute position. Default value is 0.
PositionTop (inherited from APNSoftControl) | Gets or sets the top coordinate for the control, which positioned at an absolute position. Default value is 0.
RegisterClientScript (inherited from APNSoftControl) | Gets or sets a value indicating whether the component registers the client script with the Page. Default value is true.
SEOEnabled | Gets or sets a value indicating whether the control renders an additional NOSCRIPT section with links let all search engines index your website properly. Default value is false.
ShowLines | Specifies whether the TreeView renders lines for the tree. Default value is false.
ShowStartingNode | Gets or sets a value indicating whether the TreeView renders the starting node. Default value is true.
SkinFolder (inherited from APNSoftControl) | Gets or sets the URL for a Skin Folder. Skin Folder includes all component skin parts (CSS Style, images, etc.). The property value can be an absolute or relative URI.
StructureFileURL | Gets or sets the URL to the structure file. If the property is not specified, component uses internal default structure. The property value can be an absolute or relative URI. TreeView has support to use the Web.sitemap file as a standard TreeView structure.
WarningsEnabled (inherited from APNSoftControl) | Gets or sets a value indicating whether the component generates a client-side JavaScript messages which allow developers to control the component status. Default value is true.
zIndex (inherited from APNSoftControl) | Gets or sets the z-index style value for the control. Default value is 200.

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - AutoCollapse Property

APNSoftTreeView.AutoCollapse Property

Gets or sets a value indicating whether control automatically collapses child nodes when the user selects an item. Default value is false.

[Visual Basic]
Public Property AutoCollapse As Boolean
[C#]
public bool AutoCollapse {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - AutoExpand Property

APNSoftTreeView.AutoExpand Property

Gets or sets a value indicating whether control automatically expands child nodes when the user selects an item. Default value is true.

[Visual Basic]
Public Property AutoExpand As Boolean
[C#]
public bool AutoExpand {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - AutoPostBackOnItemClick Property

APNSoftTreeView.AutoPostBackOnItemClick Property

Specifies whether the control causes a postback to the server when an Item is clicked. Default value is false.

[Visual Basic]
Public Property AutoPostBackOnItemClick As Boolean
[C#]
public bool AutoPostBackOnItemClick {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - CheckBoxes Property

APNSoftTreeView.CheckBoxes Property

Gets or sets a value indicating whether check boxes are displayed next to the tree nodes. Default value is false.

[Visual Basic]
Public Property CheckBoxes As Boolean
[C#]
public bool CheckBoxes {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ClientSideOnCheck Property

APNSoftTreeView.ClientSideOnCheck Property

Gets or sets the client-side code to be launched when an item is checked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnCheck As String
[C#]
public string ClientSideOnCheck {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ClientSideOnCollapse Property

APNSoftTreeView.ClientSideOnCollapse Property

Gets or sets the client-side code to be launched when an item is collapsed. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnCollapse As String
[C#]
public string ClientSideOnCollapse {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ClientSideOnExpand Property

APNSoftTreeView.ClientSideOnExpand Property

Gets or sets the client-side code to be launched when an item is expanded. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnExpand As String
[C#]
public string ClientSideOnExpand {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ClientSideOnItemClick Property

APNSoftTreeView.ClientSideOnItemClick Property

Gets or sets the client-side code to be launched when an item is clicked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnItemClick As String
[C#]
public string ClientSideOnItemClick {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ClientSideOnUnCheck Property

APNSoftTreeView.ClientSideOnUnCheck Property

Gets or sets the client-side code to be launched when an item is unchecked. Property value can include variables $ComponentID$ and $ItemID$, instead of which data is inserted.

[Visual Basic]
Public Property ClientSideOnUnCheck As String
[C#]
public string ClientSideOnUnCheck {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - DurationCollapse Property

APNSoftTreeView.DurationCollapse Property

The duration (in milliseconds) of the collapse animation.

[Visual Basic]
Public Property DurationCollapse As Integer
[C#]
public int DurationCollapse {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - DurationExpand Property

APNSoftTreeView.DurationExpand Property

The duration (in milliseconds) of the expand animation.

[Visual Basic]
Public Property DurationExpand As Integer
[C#]
public int DurationExpand {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - Elements Property

APNSoftTreeView.Elements Property

Gets the collection of elements.

[Visual Basic]
Public ReadOnly Property Elements As TreeViewElementCollection
[C#]
public TreeViewElementCollection Elements {get;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ExpandSinglePath Property

APNSoftTreeView.ExpandSinglePath Property

Gets or sets a value indicating whether only the current branch is expanded. Default value is false.

[Visual Basic]
Public Property ExpandSinglePath As Boolean
[C#]
public bool ExpandSinglePath {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - LoadOnDemand Property

APNSoftTreeView.LoadOnDemand Property

Specifies whether child nodes will be populated on demand. Default value is false.

[Visual Basic]
Public Property LoadOnDemand As Boolean
[C#]
public bool LoadOnDemand {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - SEOEnabled Property

APNSoftTreeView.SEOEnabled Property

Gets or sets a value indicating whether the control renders an additional NOSCRIPT section with links let all search engines index your website properly. Default value is false.

[Visual Basic]
Public Property SEOEnabled As Boolean
[C#]
public bool SEOEnabled {get; set;}

Remarks

The links of the control items are implemented with the JavaScript OnClick procedure, which can not be indexed by search-engine spiders. To overcome this obstacle, control generates an additional NOSCRIPT section with regular href tags.

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ShowLines Property

APNSoftTreeView.ShowLines Property

Specifies whether the TreeView renders lines for the tree. Default value is false.

[Visual Basic]
Public Property ShowLines As Boolean
[C#]
public bool ShowLines {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ShowStartingNode Property

APNSoftTreeView.ShowStartingNode Property

Gets or sets a value indicating whether the TreeView renders the starting node. Default value is true.

[Visual Basic]
Public Property ShowStartingNode As Boolean
[C#]
public bool ShowStartingNode {get; set;}

Remarks

You can set this property to determine whether the TreeView exposes the starting node as the root of the structure, or whether it starts from the child nodes of the root node instead.

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - StructureFileURL Property

APNSoftTreeView.StructureFileURL Property

Gets or sets the URL to the structure file. If the property is not specified, component uses internal default structure. The property value can be an absolute or relative URI. TreeView has support to use the Web.sitemap file as a standard TreeView structure.

[Visual Basic]
Public Property StructureFileURL As String
[C#]
public string StructureFileURL {get; set;}

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - APNSoftTreeView Methods

APNSoftTreeView Methods

The methods of the APNSoftTreeView class are listed below. For a complete list of APNSoftTreeView class members, see the APNSoftTreeView Members topic.

Public Instance Methods

DataBind | Creates a binding between the TreeView control and a data source.
GetCheckedItems | Returns all checked items in the TreeView control.
GetSelectedItem | Returns the selected Item.

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - APNSoftTreeView.DataBind Method

APNSoftTreeView.DataBind Method

Creates a binding between the TreeView control and a data source.

[Visual Basic]
Overrides Public Sub DataBind()
[C#]
public override void DataBind();

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - APNSoftTreeView.GetCheckedItems Method

APNSoftTreeView.GetCheckedItems Method

Returns all checked items in the TreeView control.

[Visual Basic]
Public Function GetCheckedItems() As ArrayList
[C#]
public ArrayList GetCheckedItems();

Return Value

All checked items.

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - APNSoftTreeView.GetSelectedItem Method

APNSoftTreeView.GetSelectedItem Method

Returns the selected Item.

[Visual Basic]
Public Function GetSelectedItem() As TreeViewElement
[C#]
public TreeViewElement GetSelectedItem();

Return Value

The selected Item.

Remarks

When the form is returned after a postback, the Selected Item can be defined by this method.

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - APNSoftTreeView Events

APNSoftTreeView Events

The events of the APNSoftTreeView class are listed below. For a complete list of APNSoftTreeView class members, see the APNSoftTreeView Members topic.

Public Instance Events

OnItemClick Occurs on the server side when the item is clicked.

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - APNSoftTreeView.OnItemClick Event

APNSoftTreeView.OnItemClick Event

Occurs on the server side when the item is clicked.

[Visual Basic]
Public Event OnItemClick As TreeViewEventHandler
[C#]
public event TreeViewEventHandler OnItemClick;

See Also

APNSoftTreeView Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElement Class

ComboBoxElement Class

Represents the part of a ComboBoxElementCollection.

For a list of all members of this type, see ComboBoxElement Members.

System.Object
APNSoft.WebControls.APNSoftElement
APNSoft.WebControls.ComboBoxElement

[Visual Basic]
Public Class ComboBoxElement
Inherits APNSoftElement
[C#]
public class ComboBoxElement : APNSoftElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

ComboBoxElement Members | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElement Members

ComboBoxElement Members

ComboBoxElement overview

Public Instance Properties

AutoPostBackOnItemClick (inherited from APNSoftElement) | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
ClientSideOnItemClick (inherited from APNSoftElement) | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
HasNext | Gets a value indicating whether this element has an element immediately following it.
HasPrevious | Gets a value indicating whether this element has an element immediately preceding it.
href (inherited from APNSoftElement) | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon (inherited from APNSoftElement) | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight (inherited from APNSoftElement) | Gets or sets the pixel height of the item's icon.
iconOver | Gets or sets the name of the icon for hovered item.
iconWidth (inherited from APNSoftElement) | Gets or sets the pixel width of the item's icon.
id (inherited from APNSoftElement) | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
leftSpan | Gets or sets the blank space in pixels at the left side of the current Item.
selected | Gets or sets a value indicating whether the item is selected. Default value is false.
target (inherited from APNSoftElement) | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
title (inherited from APNSoftElement) | Gets or sets the text (caption) displayed for the item.
Type (inherited from APNSoftElement) | Gets or sets a type of the Element.

Public Instance Methods

Add | Overloaded. Adds a new element. New element is added after the current element.
AddItem | Overloaded. Adds a new item element. New item is added after the current element.
AddSeparator | Overloaded. Adds a new separator element. New separator is added after the current element.
Clone | Overloaded. Creates a duplicate of this element.
MoveBackward (inherited from APNSoftElement) | Moves the element backward by one position in the current element group.
MoveForward (inherited from APNSoftElement) | Moves the element forward by one position in the current element group.
Remove (inherited from APNSoftElement) | Removes specified element from the collection.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElement Properties

ComboBoxElement Properties

The properties of the ComboBoxElement class are listed below. For a complete list of ComboBoxElement class members, see the ComboBoxElement Members topic.

Public Instance Properties

AutoPostBackOnItemClick (inherited from APNSoftElement) | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
ClientSideOnItemClick (inherited from APNSoftElement) | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
HasNext | Gets a value indicating whether this element has an element immediately following it.
HasPrevious | Gets a value indicating whether this element has an element immediately preceding it.
href (inherited from APNSoftElement) | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon (inherited from APNSoftElement) | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight (inherited from APNSoftElement) | Gets or sets the pixel height of the item's icon.
iconOver | Gets or sets the name of the icon for hovered item.
iconWidth (inherited from APNSoftElement) | Gets or sets the pixel width of the item's icon.
id (inherited from APNSoftElement) | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
leftSpan | Gets or sets the blank space in pixels at the left side of the current Item.
selected | Gets or sets a value indicating whether the item is selected. Default value is false.
target (inherited from APNSoftElement) | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
title (inherited from APNSoftElement) | Gets or sets the text (caption) displayed for the item.
Type (inherited from APNSoftElement) | Gets or sets a type of the Element.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - HasNext Property

ComboBoxElement.HasNext Property

Gets a value indicating whether this element has an element immediately following it.

[Visual Basic]
Public ReadOnly Property HasNext As Boolean
[C#]
public bool HasNext {get;}

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - HasPrevious Property

ComboBoxElement.HasPrevious Property

Gets a value indicating whether this element has an element immediately preceding it.

[Visual Basic]
Public ReadOnly Property HasPrevious As Boolean
[C#]
public bool HasPrevious {get;}

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - iconOver Property

ComboBoxElement.iconOver Property

Gets or sets the name of the icon for hovered item.

[Visual Basic]
Public Property iconOver As String
[C#]
public string iconOver {get; set;}

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - leftSpan Property

ComboBoxElement.leftSpan Property

Gets or sets the blank space in pixels at the left side of the current Item.

[Visual Basic]
Public Property leftSpan As Integer
[C#]
public int leftSpan {get; set;}

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - selected Property

ComboBoxElement.selected Property

Gets or sets a value indicating whether the item is selected. Default value is false.

[Visual Basic]
Public Property selected As Boolean
[C#]
public bool selected {get; set;}

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElement Methods

ComboBoxElement Methods

The methods of the ComboBoxElement class are listed below. For a complete list of ComboBoxElement class members, see the ComboBoxElement Members topic.

Public Instance Methods

Add | Overloaded. Adds a new element. New element is added after the current element.
AddItem | Overloaded. Adds a new item element. New item is added after the current element.
AddSeparator | Overloaded. Adds a new separator element. New separator is added after the current element.
Clone | Overloaded. Creates a duplicate of this element.
MoveBackward (inherited from APNSoftElement) | Moves the element backward by one position in the current element group.
MoveForward (inherited from APNSoftElement) | Moves the element forward by one position in the current element group.
Remove (inherited from APNSoftElement) | Removes specified element from the collection.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - Add Method

ComboBoxElement.Add Method

Adds a new element. New element is added after the current element.

Overload List

Adds a new element. New element is added after the current element.

public ComboBoxElement Add(Types);

Adds a new element. New element is added after the current element.

public ComboBoxElement Add(string,Types);

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElement.Add Method (Types)

ComboBoxElement.Add Method (Types)

Adds a new element. New element is added after the current element.

[Visual Basic]
Overloads Public Function Add( _
ByVal Type As Types _
) As ComboBoxElement
[C#]
public ComboBoxElement Add(
Types Type
);

Parameters

Type
Type of the new element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace | ComboBoxElement.Add Overload List


ASP.NET ComboBox Control - ComboBoxElement.Add Method (String, Types)

ComboBoxElement.Add Method (String, Types)

Adds a new element. New element is added after the current element.

[Visual Basic]
Overloads Public Function Add( _
ByVal NewID As String, _
ByVal Type As Types _
) As ComboBoxElement
[C#]
public ComboBoxElement Add(
string NewID,
Types Type
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.

Return Value

New element.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace | ComboBoxElement.Add Overload List


ASP.NET ComboBox Control - AddItem Method

ComboBoxElement.AddItem Method

Adds a new item element. New item is added after the current element.

Overload List

Adds a new item element. New item is added after the current element.

public ComboBoxElement AddItem(string);

Adds a new item element. New item is added after the current element.

public ComboBoxElement AddItem(string,string);

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElement.AddItem Method (String)

ComboBoxElement.AddItem Method (String)

Adds a new item element. New item is added after the current element.

[Visual Basic]
Overloads Public Function AddItem( _
ByVal Title As String _
) As ComboBoxElement
[C#]
public ComboBoxElement AddItem(
string Title
);

Parameters

Title
The text (caption) displayed for the item.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace | ComboBoxElement.AddItem Overload List


ASP.NET ComboBox Control - ComboBoxElement.AddItem Method (String, String)

ComboBoxElement.AddItem Method (String, String)

Adds a new item element. New item is added after the current element.

[Visual Basic]
Overloads Public Function AddItem( _
ByVal NewID As String, _
ByVal Title As String _
) As ComboBoxElement
[C#]
public ComboBoxElement AddItem(
string NewID,
string Title
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.

Return Value

New item element.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace | ComboBoxElement.AddItem Overload List


ASP.NET ComboBox Control - AddSeparator Method

ComboBoxElement.AddSeparator Method

Adds a new separator element. New separator is added after the current element.

Overload List

Adds a new separator element. New separator is added after the current element.

public ComboBoxElement AddSeparator();

Adds a new separator element. New separator is added after the current element.

public ComboBoxElement AddSeparator(string);

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElement.AddSeparator Method ()

ComboBoxElement.AddSeparator Method ()

Adds a new separator element. New separator is added after the current element.

[Visual Basic]
Overloads Public Function AddSeparator() As ComboBoxElement
[C#]
public ComboBoxElement AddSeparator();

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace | ComboBoxElement.AddSeparator Overload List


ASP.NET ComboBox Control - ComboBoxElement.AddSeparator Method (String)

ComboBoxElement.AddSeparator Method (String)

Adds a new separator element. New separator is added after the current element.

[Visual Basic]
Overloads Public Function AddSeparator( _
ByVal NewID As String _
) As ComboBoxElement
[C#]
public ComboBoxElement AddSeparator(
string NewID
);

Parameters

NewID
ID of the new separator.

Return Value

New separator element.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace | ComboBoxElement.AddSeparator Overload List


ASP.NET ComboBox Control - Clone Method

ComboBoxElement.Clone Method

Creates a duplicate of this element.

Overload List

Creates a duplicate of this element.

public ComboBoxElement Clone();

Creates a duplicate of this element.

public ComboBoxElement Clone(string);

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElement.Clone Method ()

ComboBoxElement.Clone Method ()

Creates a duplicate of this element.

[Visual Basic]
Overloads Public Function Clone() As ComboBoxElement
[C#]
public ComboBoxElement Clone();

Return Value

The cloned element.

Remarks

Element ID is generated automatically.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace | ComboBoxElement.Clone Overload List


ASP.NET ComboBox Control - ComboBoxElement.Clone Method (String)

ComboBoxElement.Clone Method (String)

Creates a duplicate of this element.

[Visual Basic]
Overloads Public Function Clone( _
ByVal NewID As String _
) As ComboBoxElement
[C#]
public ComboBoxElement Clone(
string NewID
);

Parameters

NewID
ID of the cloned element.

Return Value

The cloned element.

See Also

ComboBoxElement Class | APNSoft.WebControls Namespace | ComboBoxElement.Clone Overload List


ASP.NET ComboBox Control - ComboBoxElementCollection Class

ComboBoxElementCollection Class

Represents the collection of elements.

For a list of all members of this type, see ComboBoxElementCollection Members.

System.Object
APNSoft.WebControls.APNSoftElementCollection
APNSoft.WebControls.ComboBoxElementCollection

[Visual Basic]
Public Class ComboBoxElementCollection
Inherits APNSoftElementCollection
[C#]
public class ComboBoxElementCollection : APNSoftElementCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

ComboBoxElementCollection Members | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElementCollection Members

ComboBoxElementCollection Members

ComboBoxElementCollection overview

Public Instance Properties

Count (inherited from APNSoftElementCollection) | Gets the number of elements in the collection.
Item | Overloaded. Gets the specified ComboBoxElement from the collection.

Public Instance Methods

Add | Overloaded. Adds a new element to the collection.
AddItem | Overloaded. Adds a new item to the collection.
AddSeparator | Overloaded. Adds a new separator to the collection.
Clear (inherited from APNSoftElementCollection) | Removes all elements from the collection.
Contains (inherited from APNSoftElementCollection) | Determines whether an element is in the collection.
Init (inherited from APNSoftElementCollection) | Initializes the collection.
Remove (inherited from APNSoftElementCollection) | Removes a specific element from the collection.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElementCollection Properties

ComboBoxElementCollection Properties

The properties of the ComboBoxElementCollection class are listed below. For a complete list of ComboBoxElementCollection class members, see the ComboBoxElementCollection Members topic.

Public Instance Properties

Count (inherited from APNSoftElementCollection) | Gets the number of elements in the collection.
Item | Overloaded. Gets the specified ComboBoxElement from the collection.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - Item Property

ComboBoxElementCollection.Item Property

Gets the specified ComboBoxElement from the collection.

Overload List

Gets the specified ComboBoxElement from the collection.

public virtual ComboBoxElement this[int] {get;}

Gets the specified ComboBoxElement from the collection.

public virtual ComboBoxElement this[string] {get;}

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - Item Property (Int32)

ComboBoxElementCollection.Item Property (Int32)

Gets the specified ComboBoxElement from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As ComboBoxElement
[C#]
public virtual ComboBoxElement this[
int index
] {get;}

Parameters

index
Element index.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace | ComboBoxElementCollection.Item Overload List


ASP.NET ComboBox Control - Item Property (String)

ComboBoxElementCollection.Item Property (String)

Gets the specified ComboBoxElement from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal id As String _
) As ComboBoxElement
[C#]
public virtual ComboBoxElement this[
string id
] {get;}

Parameters

id
The string identifying the Element.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace | ComboBoxElementCollection.Item Overload List


ASP.NET ComboBox Control - ComboBoxElementCollection Methods

ComboBoxElementCollection Methods

The methods of the ComboBoxElementCollection class are listed below. For a complete list of ComboBoxElementCollection class members, see the ComboBoxElementCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a new element to the collection.
AddItem | Overloaded. Adds a new item to the collection.
AddSeparator | Overloaded. Adds a new separator to the collection.
Clear (inherited from APNSoftElementCollection) | Removes all elements from the collection.
Contains (inherited from APNSoftElementCollection) | Determines whether an element is in the collection.
Init (inherited from APNSoftElementCollection) | Initializes the collection.
Remove (inherited from APNSoftElementCollection) | Removes a specific element from the collection.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - Add Method

ComboBoxElementCollection.Add Method

Adds a new element to the collection.

Overload List

Adds a new element to the collection.

public ComboBoxElement Add(Types);

Adds a new element to the collection.

public ComboBoxElement Add(string,Types);

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElementCollection.Add Method (Types)

ComboBoxElementCollection.Add Method (Types)

Adds a new element to the collection.

[Visual Basic]
Overloads Public Function Add( _
ByVal Type As Types _
) As ComboBoxElement
[C#]
public ComboBoxElement Add(
Types Type
);

Parameters

Type
Type of the new element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace | ComboBoxElementCollection.Add Overload List


ASP.NET ComboBox Control - ComboBoxElementCollection.Add Method (String, Types)

ComboBoxElementCollection.Add Method (String, Types)

Adds a new element to the collection.

[Visual Basic]
Overloads Public Function Add( _
ByVal NewID As String, _
ByVal Type As Types _
) As ComboBoxElement
[C#]
public ComboBoxElement Add(
string NewID,
Types Type
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.

Return Value

New element.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace | ComboBoxElementCollection.Add Overload List


ASP.NET ComboBox Control - AddItem Method

ComboBoxElementCollection.AddItem Method

Adds a new item to the collection.

Overload List

Adds a new item to the collection.

public ComboBoxElement AddItem(string);

Adds a new item to the collection.

public ComboBoxElement AddItem(string,string);

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElementCollection.AddItem Method (String)

ComboBoxElementCollection.AddItem Method (String)

Adds a new item to the collection.

[Visual Basic]
Overloads Public Function AddItem( _
ByVal Title As String _
) As ComboBoxElement
[C#]
public ComboBoxElement AddItem(
string Title
);

Parameters

Title
The text (caption) displayed for the item.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace | ComboBoxElementCollection.AddItem Overload List


ASP.NET ComboBox Control - ComboBoxElementCollection.AddItem Method (String, String)

ComboBoxElementCollection.AddItem Method (String, String)

Adds a new item to the collection.

[Visual Basic]
Overloads Public Function AddItem( _
ByVal NewID As String, _
ByVal Title As String _
) As ComboBoxElement
[C#]
public ComboBoxElement AddItem(
string NewID,
string Title
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.

Return Value

New item element.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace | ComboBoxElementCollection.AddItem Overload List


ASP.NET ComboBox Control - AddSeparator Method

ComboBoxElementCollection.AddSeparator Method

Adds a new separator to the collection.

Overload List

Adds a new separator to the collection.

public ComboBoxElement AddSeparator();

Adds a new separator to the collection.

public ComboBoxElement AddSeparator(string);

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxElementCollection.AddSeparator Method ()

ComboBoxElementCollection.AddSeparator Method ()

Adds a new separator to the collection.

[Visual Basic]
Overloads Public Function AddSeparator() As ComboBoxElement
[C#]
public ComboBoxElement AddSeparator();

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace | ComboBoxElementCollection.AddSeparator Overload List


ASP.NET ComboBox Control - ComboBoxElementCollection.AddSeparator Method (String)

ComboBoxElementCollection.AddSeparator Method (String)

Adds a new separator to the collection.

[Visual Basic]
Overloads Public Function AddSeparator( _
ByVal NewID As String _
) As ComboBoxElement
[C#]
public ComboBoxElement AddSeparator(
string NewID
);

Parameters

NewID
ID of the new separator.

Return Value

New separator element.

See Also

ComboBoxElementCollection Class | APNSoft.WebControls Namespace | ComboBoxElementCollection.AddSeparator Overload List


ASP.NET ComboBox Control - ComboBoxEventArgs Class

ComboBoxEventArgs Class

Provides data for command events of the ComboBox control.

For a list of all members of this type, see ComboBoxEventArgs Members.

System.Object
System.EventArgs
APNSoft.WebControls.ComboBoxEventArgs

[Visual Basic]
Public Class ComboBoxEventArgs
Inherits EventArgs
[C#]
public class ComboBoxEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

ComboBoxEventArgs Members | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxEventArgs Members

ComboBoxEventArgs Members

ComboBoxEventArgs overview

Public Instance Constructors

ComboBoxEventArgs Constructor Initializes a new instance of the ComboBoxEventArgs class.

Public Instance Fields

ComboBoxElement | Gets the referenced element in the ComboBox control when the event is raised.
ComponentID | Gets the ComboBox ID when the event is raised.
ItemID | Gets the ID of the referenced item in the ComboBox control when the event is raised.

See Also

ComboBoxEventArgs Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxEventArgs Constructor

ComboBoxEventArgs Constructor

Initializes a new instance of the ComboBoxEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public ComboBoxEventArgs();

See Also

ComboBoxEventArgs Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxEventArgs Fields

ComboBoxEventArgs Fields

The fields of the ComboBoxEventArgs class are listed below. For a complete list of ComboBoxEventArgs class members, see the ComboBoxEventArgs Members topic.

Public Instance Fields

ComboBoxElement | Gets the referenced element in the ComboBox control when the event is raised.
ComponentID | Gets the ComboBox ID when the event is raised.
ItemID | Gets the ID of the referenced item in the ComboBox control when the event is raised.

See Also

ComboBoxEventArgs Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxEventArgs.ComboBoxElement Field

ComboBoxEventArgs.ComboBoxElement Field

Gets the referenced element in the ComboBox control when the event is raised.

[Visual Basic]
Public ComboBoxElement As ComboBoxElement
[C#]
public ComboBoxElement ComboBoxElement;

See Also

ComboBoxEventArgs Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxEventArgs.ComponentID Field

ComboBoxEventArgs.ComponentID Field

Gets the ComboBox ID when the event is raised.

[Visual Basic]
Public ComponentID As String
[C#]
public string ComponentID;

See Also

ComboBoxEventArgs Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxEventArgs.ItemID Field

ComboBoxEventArgs.ItemID Field

Gets the ID of the referenced item in the ComboBox control when the event is raised.

[Visual Basic]
Public ItemID As String
[C#]
public string ItemID;

See Also

ComboBoxEventArgs Class | APNSoft.WebControls Namespace


ASP.NET ComboBox Control - ComboBoxEventHandler Delegate

ComboBoxEventHandler Delegate

Represents the method that will handle command events of a ComboBox.

[Visual Basic]
Public Delegate Sub ComboBoxEventHandler( _
ByVal sender As Object, _
ByVal e As ComboBoxEventArgs _
)
[C#]
public delegate void ComboBoxEventHandler(
object sender,
ComboBoxEventArgs e
);

Parameters

sender
The source of the event.
e
A ComboBoxEventArgs than contains the event data.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET DataGrid Control - DataGridEventArgs Class

DataGridEventArgs Class

Provides data for command events of the DataGrid control.

For a list of all members of this type, see DataGridEventArgs Members.

System.Object
System.EventArgs
APNSoft.WebControls.DataGridEventArgs

[Visual Basic]
Public Class DataGridEventArgs
Inherits EventArgs
[C#]
public class DataGridEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

DataGridEventArgs Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - DataGridEventArgs Members

DataGridEventArgs Members

DataGridEventArgs overview

Public Instance Constructors

DataGridEventArgs Constructor Initializes a new instance of the DataGridEventArgs class.

Public Instance Properties

CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - DataGridEventArgs Constructor

DataGridEventArgs Constructor

Initializes a new instance of the DataGridEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public DataGridEventArgs();

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - DataGridEventArgs Properties

DataGridEventArgs Properties

The properties of the DataGridEventArgs class are listed below. For a complete list of DataGridEventArgs class members, see the DataGridEventArgs Members topic.

Public Instance Properties

CellValue | Gets the cell value when the event is raised.
EditFormFields | Gets a Hashtable object that represents fields in the Edit Form.
ExportBytes | Gets or sets a sequence of bytes for the response.
ExportContentType | Gets or sets the content type for the response.
ExportData | Gets or sets the data to export when the event is raised.
ExportFileName | Gets or sets the name of the file that is the data to export.
ExportShowHeader | Gets or sets a value indicating whether the header row is displayed in the data to export.
GridColumn | Gets the referenced column in the DataGrid control when the event is raised.
GridRow | Gets the referenced row in the DataGrid control when the event is raised.
GridRowKeyValue | Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.
PageNumber | Gets the page number when the event is raised.
Parameter | Gets or sets a value of parameter when the event is raised.

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - CellValue Property

DataGridEventArgs.CellValue Property

Gets the cell value when the event is raised.

[Visual Basic]
Public Property CellValue As String
[C#]
public string CellValue {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - EditFormFields Property

DataGridEventArgs.EditFormFields Property

Gets a Hashtable object that represents fields in the Edit Form.

[Visual Basic]
Public Property EditFormFields As Hashtable
[C#]
public System.Collections.Hashtable EditFormFields {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ExportBytes Property

DataGridEventArgs.ExportBytes Property

Gets or sets a sequence of bytes for the response.

[Visual Basic]
Public Property ExportBytes As Byte()
[C#]
public byte[] ExportBytes {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ExportContentType Property

DataGridEventArgs.ExportContentType Property

Gets or sets the content type for the response.

[Visual Basic]
Public Property ExportContentType As String
[C#]
public string ExportContentType {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ExportData Property

DataGridEventArgs.ExportData Property

Gets or sets the data to export when the event is raised.

[Visual Basic]
Public Property ExportData As String
[C#]
public string ExportData {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ExportFileName Property

DataGridEventArgs.ExportFileName Property

Gets or sets the name of the file that is the data to export.

[Visual Basic]
Public Property ExportFileName As String
[C#]
public string ExportFileName {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ExportShowHeader Property

DataGridEventArgs.ExportShowHeader Property

Gets or sets a value indicating whether the header row is displayed in the data to export.

[Visual Basic]
Public Property ExportShowHeader As Boolean
[C#]
public bool ExportShowHeader {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn Property

DataGridEventArgs.GridColumn Property

Gets the referenced column in the DataGrid control when the event is raised.

[Visual Basic]
Public Property GridColumn As GridColumn
[C#]
public GridColumn GridColumn {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridRow Property

DataGridEventArgs.GridRow Property

Gets the referenced row in the DataGrid control when the event is raised.

[Visual Basic]
Public Property GridRow As GridRow
[C#]
public GridRow GridRow {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridRowKeyValue Property

DataGridEventArgs.GridRowKeyValue Property

Gets or sets a value of the key field in selected record. This property is commonly used in a handler for an event, such as InsertCommand or UpdateCommand, to set a new key value for the selected record. It helps component to highlight appropriate row after INSERT/UPDATE.

[Visual Basic]
Public Property GridRowKeyValue As String
[C#]
public string GridRowKeyValue {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - PageNumber Property

DataGridEventArgs.PageNumber Property

Gets the page number when the event is raised.

[Visual Basic]
Public Property PageNumber As Integer
[C#]
public int PageNumber {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Parameter Property

DataGridEventArgs.Parameter Property

Gets or sets a value of parameter when the event is raised.

[Visual Basic]
Public Property Parameter As String
[C#]
public string Parameter {get; set;}

See Also

DataGridEventArgs Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - DataGridEventHandler Delegate

DataGridEventHandler Delegate

Represents the method that will handle command events of a DataGrid.

[Visual Basic]
Public Delegate Sub DataGridEventHandler( _
ByVal sender As Object, _
ByVal e As DataGridEventArgs _
)
[C#]
public delegate void DataGridEventHandler(
object sender,
DataGridEventArgs e
);

Parameters

sender
The source of the event.
e
A DataGridEventArgs than contains the event data.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridBottomBar Class

GridBottomBar Class

Represents the Bottom Bar.

For a list of all members of this type, see GridBottomBar Members.

System.Object
APNSoft.WebControls.GridBottomBar

[Visual Basic]
Public Class GridBottomBar
[C#]
public class GridBottomBar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridBottomBar Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridBottomBar Members

GridBottomBar Members

GridBottomBar overview

Public Instance Constructors

GridBottomBar Constructor Initializes a new instance of the GridBottomBar class.

Public Instance Properties

Template | Gets or sets the path to the template file of the Bottom Bar. The property value can be an absolute or relative URI.
Visible | Gets or sets a value indicating whether the Bottom Bar will be visible or not.

See Also

GridBottomBar Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridBottomBar Constructor

GridBottomBar Constructor

Initializes a new instance of the GridBottomBar class.

[Visual Basic]
Public Sub New()
[C#]
public GridBottomBar();

See Also

GridBottomBar Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridBottomBar Properties

GridBottomBar Properties

The properties of the GridBottomBar class are listed below. For a complete list of GridBottomBar class members, see the GridBottomBar Members topic.

Public Instance Properties

Template | Gets or sets the path to the template file of the Bottom Bar. The property value can be an absolute or relative URI.
Visible | Gets or sets a value indicating whether the Bottom Bar will be visible or not.

See Also

GridBottomBar Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Template Property

GridBottomBar.Template Property

Gets or sets the path to the template file of the Bottom Bar. The property value can be an absolute or relative URI.

[Visual Basic]
Public Property Template As String
[C#]
public string Template {get; set;}

See Also

GridBottomBar Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Visible Property

GridBottomBar.Visible Property

Gets or sets a value indicating whether the Bottom Bar will be visible or not.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

GridBottomBar Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridCell Class

GridCell Class

Represents the part of a GridCellCollection.

For a list of all members of this type, see GridCell Members.

System.Object
APNSoft.WebControls.GridCell

[Visual Basic]
Public Class GridCell
[C#]
public class GridCell

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridCell Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridCell Members

GridCell Members

GridCell overview

Public Instance Properties

ColumnName | The name of the cell's column.
Value | Cell value.

See Also

GridCell Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridCell Properties

GridCell Properties

The properties of the GridCell class are listed below. For a complete list of GridCell class members, see the GridCell Members topic.

Public Instance Properties

ColumnName | The name of the cell's column.
Value | Cell value.

See Also

GridCell Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ColumnName Property

GridCell.ColumnName Property

The name of the cell's column.

[Visual Basic]
Public ReadOnly Property ColumnName As String
[C#]
public string ColumnName {get;}

See Also

GridCell Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Value Property

GridCell.Value Property

Cell value.

[Visual Basic]
Public Property Value As Object
[C#]
public object Value {get; set;}

See Also

GridCell Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridCellCollection Class

GridCellCollection Class

Represents the collection of cells in one row.

For a list of all members of this type, see GridCellCollection Members.

System.Object
APNSoft.WebControls.GridCellCollection

[Visual Basic]
Public Class GridCellCollection
[C#]
public class GridCellCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridCellCollection Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridCellCollection Members

GridCellCollection Members

GridCellCollection overview

Public Instance Properties

Count | The number of cells in the collection.
Item | Overloaded. Gets the specified GridCell from the collection.

See Also

GridCellCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridCellCollection Properties

GridCellCollection Properties

The properties of the GridCellCollection class are listed below. For a complete list of GridCellCollection class members, see the GridCellCollection Members topic.

Public Instance Properties

Count | The number of cells in the collection.
Item | Overloaded. Gets the specified GridCell from the collection.

See Also

GridCellCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Count Property

GridCellCollection.Count Property

The number of cells in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}

See Also

GridCellCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Item Property

GridCellCollection.Item Property

Gets the specified GridCell from the collection.

Overload List

Gets the specified GridCell from the collection.

public virtual GridCell this[int] {get;}

Gets the specified GridCell from the collection.

public virtual GridCell this[string] {get;}

See Also

GridCellCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Item Property (Int32)

GridCellCollection.Item Property (Int32)

Gets the specified GridCell from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As GridCell
[C#]
public virtual GridCell this[
int index
] {get;}

Parameters

index
Column index.

See Also

GridCellCollection Class | APNSoft.WebControls Namespace | GridCellCollection.Item Overload List


ASP.NET DataGrid Control - Item Property (String)

GridCellCollection.Item Property (String)

Gets the specified GridCell from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal name As String _
) As GridCell
[C#]
public virtual GridCell this[
string name
] {get;}

Parameters

name
The name of the cell's column.

See Also

GridCellCollection Class | APNSoft.WebControls Namespace | GridCellCollection.Item Overload List


ASP.NET DataGrid Control - GridColumn Class

GridColumn Class

Represents the part of a GridColumnCollection.

For a list of all members of this type, see GridColumn Members.

System.Object
APNSoft.WebControls.GridColumn

[Visual Basic]
Public Class GridColumn
[C#]
public class GridColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridColumn Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn Members

GridColumn Members

GridColumn overview

Public Static (Shared) Fields

COLUMN_WIDTH_MAX | The minimum width of the DataGrid.
COLUMN_WIDTH_MIN | The maximum width of the DataGrid.

Public Instance Properties

CellEditingEnabled | Gets or sets a value specifying whether the cell editing for this column is enabled. Triggered by clicking twice on a cell. Default value is true.
ColumnName | The name of the column in the GridColumnCollection.
CssClass | Gets or sets the Cascading Style Sheet (CSS) class for the values displayed in the column. All custom classes must be included in the skin's CSS file.
DataType | Gets or sets the type of data stored in the column.
Exportable | Gets or sets a value indicating whether the column data will be exported to Excel or not.
Fixed | Gets or sets a value that indicates whether the column is fixed. Fixed columns stay on the left side of the grid and do not scroll when the grid scrolls. Default value is false.
FixedColumnMark | Gets or sets a mark for the fixed column. By default, the fixed column marked with the asterisk *.
FormatOrder | Gets or sets a value that enables you to specify the order in which the cell value to be formatted.
FormatProvider | An IFormatProvider that supplies culture-specific formatting information.
FormatString | The format string. Component converts the cell value to its equivalent string representation according to the specified format string.
FormatType | Represents type declarations: class types, interface types, array types, value types, and enumeration types.
HeaderText | The text displayed in the header section of the column.
LineNumbers | Gets or sets a value indicating whether the column will be filled with line numbers. Default value is false.
OrderIndex | Gets or sets the order index of a column in the collection of columns. Range: from -1000 to 1000. The default value is 0. A column with greater order index is always displayed after a column with lower order index. Two columns with the same order index are positioned according to source order.
Resizable | Gets or sets a value that indicates whether the column can be resized.
Sortable | Gets or sets a value that indicates whether the column can be sorted.
Sorted | Gets or sets a value that indicates whether the column data is sorted. Default value is Unsorted.
Summary | Gets or sets the summary data for the column.
Template | Gets or sets the path to the template file of the column. The property value can be an absolute or relative URI.
Visible | Gets or sets a value indicating whether the column is displayed. Default value is true.
Width | Gets or sets the width (in pixels) of the column.

Public Instance Methods

Average | Computes the average of column values.
Maximum | Computes the Maximum of column values.
Minimum | Computes the Minimum of column values.
SetTemplateVariable | This method is used to set a value for user-defined variable in the column template.
Sum | Computes the sum of column values.

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn Fields

GridColumn Fields

The fields of the GridColumn class are listed below. For a complete list of GridColumn class members, see the GridColumn Members topic.

Public Static (Shared) Fields

COLUMN_WIDTH_MAX | The minimum width of the DataGrid.
COLUMN_WIDTH_MIN | The maximum width of the DataGrid.

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn.COLUMN_WIDTH_MAX Field

GridColumn.COLUMN_WIDTH_MAX Field

The minimum width of the DataGrid.

[Visual Basic]
Public Const COLUMN_WIDTH_MAX As Integer = 1024
[C#]
public const int COLUMN_WIDTH_MAX = 1024;

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn.COLUMN_WIDTH_MIN Field

GridColumn.COLUMN_WIDTH_MIN Field

The maximum width of the DataGrid.

[Visual Basic]
Public Const COLUMN_WIDTH_MIN As Integer = 12
[C#]
public const int COLUMN_WIDTH_MIN = 12;

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn Properties

GridColumn Properties

The properties of the GridColumn class are listed below. For a complete list of GridColumn class members, see the GridColumn Members topic.

Public Instance Properties

CellEditingEnabled | Gets or sets a value specifying whether the cell editing for this column is enabled. Triggered by clicking twice on a cell. Default value is true.
ColumnName | The name of the column in the GridColumnCollection.
CssClass | Gets or sets the Cascading Style Sheet (CSS) class for the values displayed in the column. All custom classes must be included in the skin's CSS file.
DataType | Gets or sets the type of data stored in the column.
Exportable | Gets or sets a value indicating whether the column data will be exported to Excel or not.
Fixed | Gets or sets a value that indicates whether the column is fixed. Fixed columns stay on the left side of the grid and do not scroll when the grid scrolls. Default value is false.
FixedColumnMark | Gets or sets a mark for the fixed column. By default, the fixed column marked with the asterisk *.
FormatOrder | Gets or sets a value that enables you to specify the order in which the cell value to be formatted.
FormatProvider | An IFormatProvider that supplies culture-specific formatting information.
FormatString | The format string. Component converts the cell value to its equivalent string representation according to the specified format string.
FormatType | Represents type declarations: class types, interface types, array types, value types, and enumeration types.
HeaderText | The text displayed in the header section of the column.
LineNumbers | Gets or sets a value indicating whether the column will be filled with line numbers. Default value is false.
OrderIndex | Gets or sets the order index of a column in the collection of columns. Range: from -1000 to 1000. The default value is 0. A column with greater order index is always displayed after a column with lower order index. Two columns with the same order index are positioned according to source order.
Resizable | Gets or sets a value that indicates whether the column can be resized.
Sortable | Gets or sets a value that indicates whether the column can be sorted.
Sorted | Gets or sets a value that indicates whether the column data is sorted. Default value is Unsorted.
Summary | Gets or sets the summary data for the column.
Template | Gets or sets the path to the template file of the column. The property value can be an absolute or relative URI.
Visible | Gets or sets a value indicating whether the column is displayed. Default value is true.
Width | Gets or sets the width (in pixels) of the column.

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - CellEditingEnabled Property

GridColumn.CellEditingEnabled Property

Gets or sets a value specifying whether the cell editing for this column is enabled. Triggered by clicking twice on a cell. Default value is true.

[Visual Basic]
Public Property CellEditingEnabled As Boolean
[C#]
public bool CellEditingEnabled {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - ColumnName Property

GridColumn.ColumnName Property

The name of the column in the GridColumnCollection.

[Visual Basic]
Public ReadOnly Property ColumnName As String
[C#]
public string ColumnName {get;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - CssClass Property

GridColumn.CssClass Property

Gets or sets the Cascading Style Sheet (CSS) class for the values displayed in the column. All custom classes must be included in the skin's CSS file.

[Visual Basic]
Public Property CssClass As String
[C#]
public string CssClass {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - DataType Property

GridColumn.DataType Property

Gets or sets the type of data stored in the column.

[Visual Basic]
Public Property DataType As Type
[C#]
public System.Type DataType {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Exportable Property

GridColumn.Exportable Property

Gets or sets a value indicating whether the column data will be exported to Excel or not.

[Visual Basic]
Public Property Exportable As Boolean
[C#]
public bool Exportable {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Fixed Property

GridColumn.Fixed Property

Gets or sets a value that indicates whether the column is fixed. Fixed columns stay on the left side of the grid and do not scroll when the grid scrolls. Default value is false.

[Visual Basic]
Public Property Fixed As Boolean
[C#]
public bool Fixed {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - FixedColumnMark Property

GridColumn.FixedColumnMark Property

Gets or sets a mark for the fixed column. By default, the fixed column marked with the asterisk *.

[Visual Basic]
Public Property FixedColumnMark As String
[C#]
public string FixedColumnMark {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - FormatOrder Property

GridColumn.FormatOrder Property

Gets or sets a value that enables you to specify the order in which the cell value to be formatted.

[Visual Basic]
Public Property FormatOrder As FormatOrderValues
[C#]
public GridColumn.FormatOrderValues FormatOrder {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - FormatProvider Property

GridColumn.FormatProvider Property

An IFormatProvider that supplies culture-specific formatting information.

[Visual Basic]
Public Property FormatProvider As IFormatProvider
[C#]
public System.IFormatProvider FormatProvider {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - FormatString Property

GridColumn.FormatString Property

The format string. Component converts the cell value to its equivalent string representation according to the specified format string.

[Visual Basic]
Public Property FormatString As String
[C#]
public string FormatString {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - FormatType Property

GridColumn.FormatType Property

Represents type declarations: class types, interface types, array types, value types, and enumeration types.

[Visual Basic]
Public Property FormatType As Type
[C#]
public System.Type FormatType {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - HeaderText Property

GridColumn.HeaderText Property

The text displayed in the header section of the column.

[Visual Basic]
Public Property HeaderText As String
[C#]
public string HeaderText {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - LineNumbers Property

GridColumn.LineNumbers Property

Gets or sets a value indicating whether the column will be filled with line numbers. Default value is false.

[Visual Basic]
Public Property LineNumbers As Boolean
[C#]
public bool LineNumbers {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - OrderIndex Property

GridColumn.OrderIndex Property

Gets or sets the order index of a column in the collection of columns. Range: from -1000 to 1000. The default value is 0. A column with greater order index is always displayed after a column with lower order index. Two columns with the same order index are positioned according to source order.

[Visual Basic]
Public Property OrderIndex As Integer
[C#]
public int OrderIndex {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Resizable Property

GridColumn.Resizable Property

Gets or sets a value that indicates whether the column can be resized.

[Visual Basic]
Public Property Resizable As Boolean
[C#]
public bool Resizable {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Sortable Property

GridColumn.Sortable Property

Gets or sets a value that indicates whether the column can be sorted.

[Visual Basic]
Public Property Sortable As Boolean
[C#]
public bool Sortable {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Sorted Property

GridColumn.Sorted Property

Gets or sets a value that indicates whether the column data is sorted. Default value is Unsorted.

[Visual Basic]
Public Property Sorted As SortedValues
[C#]
public GridColumn.SortedValues Sorted {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Summary Property

GridColumn.Summary Property

Gets or sets the summary data for the column.

[Visual Basic]
Public Property Summary As String
[C#]
public string Summary {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Template Property

GridColumn.Template Property

Gets or sets the path to the template file of the column. The property value can be an absolute or relative URI.

[Visual Basic]
Public Property Template As String
[C#]
public string Template {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Visible Property

GridColumn.Visible Property

Gets or sets a value indicating whether the column is displayed. Default value is true.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Width Property

GridColumn.Width Property

Gets or sets the width (in pixels) of the column.

[Visual Basic]
Public Property Width As Unit
[C#]
public System.Web.UI.WebControls.Unit Width {get; set;}

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn Methods

GridColumn Methods

The methods of the GridColumn class are listed below. For a complete list of GridColumn class members, see the GridColumn Members topic.

Public Instance Methods

Average | Computes the average of column values.
Maximum | Computes the Maximum of column values.
Minimum | Computes the Minimum of column values.
SetTemplateVariable | This method is used to set a value for user-defined variable in the column template.
Sum | Computes the sum of column values.

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn.Average Method

GridColumn.Average Method

Computes the average of column values.

[Visual Basic]
Public Function Average() As Object
[C#]
public object Average();

Return Value

The average of the values in the column.

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn.Maximum Method

GridColumn.Maximum Method

Computes the Maximum of column values.

[Visual Basic]
Public Function Maximum() As Object
[C#]
public object Maximum();

Return Value

The Maximum of the values in the column.

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn.Minimum Method

GridColumn.Minimum Method

Computes the Minimum of column values.

[Visual Basic]
Public Function Minimum() As Object
[C#]
public object Minimum();

Return Value

The Minimum of the values in the column.

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn.SetTemplateVariable Method

GridColumn.SetTemplateVariable Method

This method is used to set a value for user-defined variable in the column template.

[Visual Basic]
Public Sub SetTemplateVariable( _
ByVal Variable As String, _
ByVal Value As String _
)
[C#]
public void SetTemplateVariable(
string Variable,
string Value
);

Parameters

Variable
The variable.
Value
The value of the variable to set.

Example

[C#]
dg1.Columns["Manager"].SetTemplateVariable("$Manager$", "Bill");

[Visual Basic]
dg1.Columns("Manager").SetTemplateVariable("$Manager$", "Bill")

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn.Sum Method

GridColumn.Sum Method

Computes the sum of column values.

[Visual Basic]
Public Function Sum() As Object
[C#]
public object Sum();

Return Value

The sum of the values in the column.

See Also

GridColumn Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn.FormatOrderValues Enumeration

GridColumn.FormatOrderValues Enumeration

Values for the FormatOrder property.

[Visual Basic]
Public Enum GridColumn.FormatOrderValues
[C#]
public enum GridColumn.FormatOrderValues

Members

Member Name | Description
FormatString_Template | At first, data is formatted according to FormatString property, and then a template is applied, which is defined by the Template property.
Template_FormatString | At first, a template is applied to data according to the Template property, and then goes the formatting according to the FormatString property.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumn.SortedValues Enumeration

GridColumn.SortedValues Enumeration

Values for the Sorted property.

[Visual Basic]
Public Enum GridColumn.SortedValues
[C#]
public enum GridColumn.SortedValues

Members

Member Name | Description
Ascending | Ascending order.
Descending | Descending order.
Unsorted | Unsorted data.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumnCollection Class

GridColumnCollection Class

Represents the collection of grid columns.

For a list of all members of this type, see GridColumnCollection Members.

System.Object
APNSoft.WebControls.GridColumnCollection

[Visual Basic]
Public Class GridColumnCollection
[C#]
public class GridColumnCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridColumnCollection Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumnCollection Members

GridColumnCollection Members

GridColumnCollection overview

Public Instance Properties

Count | The number of columns in the collection.
CountVisible | The number of visible columns in the collection.
Item | Overloaded. Gets the specified GridColumn from the collection.

See Also

GridColumnCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridColumnCollection Properties

GridColumnCollection Properties

The properties of the GridColumnCollection class are listed below. For a complete list of GridColumnCollection class members, see the GridColumnCollection Members topic.

Public Instance Properties

Count | The number of columns in the collection.
CountVisible | The number of visible columns in the collection.
Item | Overloaded. Gets the specified GridColumn from the collection.

See Also

GridColumnCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Count Property

GridColumnCollection.Count Property

The number of columns in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}

See Also

GridColumnCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - CountVisible Property

GridColumnCollection.CountVisible Property

The number of visible columns in the collection.

[Visual Basic]
Public ReadOnly Property CountVisible As Integer
[C#]
public int CountVisible {get;}

See Also

GridColumnCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Item Property

GridColumnCollection.Item Property

Gets the specified GridColumn from the collection.

Overload List

Gets the specified GridColumn from the collection.

public virtual GridColumn this[int] {get;}

Gets the specified GridColumn from the collection.

public virtual GridColumn this[string] {get;}

See Also

GridColumnCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Item Property (Int32)

GridColumnCollection.Item Property (Int32)

Gets the specified GridColumn from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As GridColumn
[C#]
public virtual GridColumn this[
int index
] {get;}

Parameters

index
Column index.

See Also

GridColumnCollection Class | APNSoft.WebControls Namespace | GridColumnCollection.Item Overload List


ASP.NET DataGrid Control - Item Property (String)

GridColumnCollection.Item Property (String)

Gets the specified GridColumn from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal name As String _
) As GridColumn
[C#]
public virtual GridColumn this[
string name
] {get;}

Parameters

name
Column name.

See Also

GridColumnCollection Class | APNSoft.WebControls Namespace | GridColumnCollection.Item Overload List


ASP.NET DataGrid Control - GridContextMenuHeader Class

GridContextMenuHeader Class

Represents the Context Menu for Header.

For a list of all members of this type, see GridContextMenuHeader Members.

System.Object
APNSoft.WebControls.GridContextMenuHeader

[Visual Basic]
Public Class GridContextMenuHeader
[C#]
public class GridContextMenuHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridContextMenuHeader Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridContextMenuHeader Members

GridContextMenuHeader Members

GridContextMenuHeader overview

Public Instance Constructors

GridContextMenuHeader Constructor Initializes a new instance of the GridContextMenuHeader class.

Public Instance Properties

AutoClose | Gets or sets a value indicating whether the Context Menu is closed automatically. If AutoClose option is enabled, the Context Menu will be closed automatically when the user clicks an item in the Context Menu. Default value is true.
Template | Gets or sets a raw XML string or path to the template file for context menu.

See Also

GridContextMenuHeader Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridContextMenuHeader Constructor

GridContextMenuHeader Constructor

Initializes a new instance of the GridContextMenuHeader class.

[Visual Basic]
Public Sub New()
[C#]
public GridContextMenuHeader();

See Also

GridContextMenuHeader Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridContextMenuHeader Properties

GridContextMenuHeader Properties

The properties of the GridContextMenuHeader class are listed below. For a complete list of GridContextMenuHeader class members, see the GridContextMenuHeader Members topic.

Public Instance Properties

AutoClose | Gets or sets a value indicating whether the Context Menu is closed automatically. If AutoClose option is enabled, the Context Menu will be closed automatically when the user clicks an item in the Context Menu. Default value is true.
Template | Gets or sets a raw XML string or path to the template file for context menu.

See Also

GridContextMenuHeader Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - AutoClose Property

GridContextMenuHeader.AutoClose Property

Gets or sets a value indicating whether the Context Menu is closed automatically. If AutoClose option is enabled, the Context Menu will be closed automatically when the user clicks an item in the Context Menu. Default value is true.

[Visual Basic]
Public Property AutoClose As Boolean
[C#]
public bool AutoClose {get; set;}

See Also

GridContextMenuHeader Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Template Property

GridContextMenuHeader.Template Property

Gets or sets a raw XML string or path to the template file for context menu.

[Visual Basic]
Public Property Template As String
[C#]
public string Template {get; set;}

See Also

GridContextMenuHeader Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridContextMenuRow Class

GridContextMenuRow Class

Represents the Context Menu for Row.

For a list of all members of this type, see GridContextMenuRow Members.

System.Object
APNSoft.WebControls.GridContextMenuRow

[Visual Basic]
Public Class GridContextMenuRow
[C#]
public class GridContextMenuRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridContextMenuRow Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridContextMenuRow Members

GridContextMenuRow Members

GridContextMenuRow overview

Public Instance Constructors

GridContextMenuRow Constructor Initializes a new instance of the GridContextMenuRow class.

Public Instance Properties

AutoClose | Gets or sets a value indicating whether the Context Menu is closed automatically. If AutoClose option is enabled, the Context Menu will be closed automatically when the user clicks an item in the Context Menu. Default value is true.
Template | Gets or sets a raw XML string or path to the template file for context menu.

See Also

GridContextMenuRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridContextMenuRow Constructor

GridContextMenuRow Constructor

Initializes a new instance of the GridContextMenuRow class.

[Visual Basic]
Public Sub New()
[C#]
public GridContextMenuRow();

See Also

GridContextMenuRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridContextMenuRow Properties

GridContextMenuRow Properties

The properties of the GridContextMenuRow class are listed below. For a complete list of GridContextMenuRow class members, see the GridContextMenuRow Members topic.

Public Instance Properties

AutoClose | Gets or sets a value indicating whether the Context Menu is closed automatically. If AutoClose option is enabled, the Context Menu will be closed automatically when the user clicks an item in the Context Menu. Default value is true.
Template | Gets or sets a raw XML string or path to the template file for context menu.

See Also

GridContextMenuRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - AutoClose Property

GridContextMenuRow.AutoClose Property

Gets or sets a value indicating whether the Context Menu is closed automatically. If AutoClose option is enabled, the Context Menu will be closed automatically when the user clicks an item in the Context Menu. Default value is true.

[Visual Basic]
Public Property AutoClose As Boolean
[C#]
public bool AutoClose {get; set;}

See Also

GridContextMenuRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Template Property

GridContextMenuRow.Template Property

Gets or sets a raw XML string or path to the template file for context menu.

[Visual Basic]
Public Property Template As String
[C#]
public string Template {get; set;}

See Also

GridContextMenuRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridEditForm Class

GridEditForm Class

Represents the Edit Form.

For a list of all members of this type, see GridEditForm Members.

System.Object
APNSoft.WebControls.GridEditForm

[Visual Basic]
Public Class GridEditForm
[C#]
public class GridEditForm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridEditForm Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridEditForm Members

GridEditForm Members

GridEditForm overview

Public Instance Constructors

GridEditForm Constructor Initializes a new instance of the GridGridEditForm class.

Public Instance Properties

Path | Gets or sets the virtual path to a User Control file which is used as a form for Insert/Update a row.
PositionInsert | Gets or sets the position of the Edit Form, which is opened to insert new record.
PositionUpdate | Gets or sets the position of the Edit Form, which is opened to update an existed record.

See Also

GridEditForm Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridEditForm Constructor

GridEditForm Constructor

Initializes a new instance of the GridGridEditForm class.

[Visual Basic]
Public Sub New()
[C#]
public GridEditForm();

See Also

GridEditForm Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridEditForm Properties

GridEditForm Properties

The properties of the GridEditForm class are listed below. For a complete list of GridEditForm class members, see the GridEditForm Members topic.

Public Instance Properties

Path | Gets or sets the virtual path to a User Control file which is used as a form for Insert/Update a row.
PositionInsert | Gets or sets the position of the Edit Form, which is opened to insert new record.
PositionUpdate | Gets or sets the position of the Edit Form, which is opened to update an existed record.

See Also

GridEditForm Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Path Property

GridEditForm.Path Property

Gets or sets the virtual path to a User Control file which is used as a form for Insert/Update a row.

[Visual Basic]
Public Property Path As String
[C#]
public string Path {get; set;}

See Also

GridEditForm Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - PositionInsert Property

GridEditForm.PositionInsert Property

Gets or sets the position of the Edit Form, which is opened to insert new record.

[Visual Basic]
Public Property PositionInsert As PositionValues
[C#]
public GridEditForm.PositionValues PositionInsert {get; set;}

See Also

GridEditForm Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - PositionUpdate Property

GridEditForm.PositionUpdate Property

Gets or sets the position of the Edit Form, which is opened to update an existed record.

[Visual Basic]
Public Property PositionUpdate As PositionValues
[C#]
public GridEditForm.PositionValues PositionUpdate {get; set;}

See Also

GridEditForm Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridEditForm.PositionValues Enumeration

GridEditForm.PositionValues Enumeration

Values for the properties: PositionInsert and PositionUpdate.

[Visual Basic]
Public Enum GridEditForm.PositionValues
[C#]
public enum GridEditForm.PositionValues

Members

Member Name | Description
CenterOfScreen | The Edit Form is positioned in the center of the screen.
BelowTheRow | The Edit Form is positioned below the current row. Used for the PositionUpdate property only.
TopLeftCornerOfGrid | The Edit Form is positioned at the top left corner of the DataGrid.
TopLeftCornerOfScreen | The Edit Form is positioned at the top left corner of the screen.
CenterOfGrid | The Edit Form is positioned in the center of the DataGrid.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridRow Class

GridRow Class

Represents the part of a GridRowCollection.

For a list of all members of this type, see GridRow Members.

System.Object
APNSoft.WebControls.GridRow

[Visual Basic]
Public Class GridRow
[C#]
public class GridRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridRow Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridRow Members

GridRow Members

GridRow overview

Public Instance Properties

Cells | The collection of cells.
CssClass | Gets or sets the Cascading Style Sheet (CSS) class for the values displayed in the row. All custom classes must be included in the skin's CSS file.
RowID | Gets or sets an ID for the row.
RowIndex | Gets or sets the row index.
Selected | Gets or sets a Boolean value that indicates whether the row is selected. Default value is false.
Visible | Gets or sets a value indicating whether the row is displayed. Default value is true.
VisibleByFilter | Gets a value indicating whether the row is visible after applying the filter.

See Also

GridRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridRow Properties

GridRow Properties

The properties of the GridRow class are listed below. For a complete list of GridRow class members, see the GridRow Members topic.

Public Instance Properties

Cells | The collection of cells.
CssClass | Gets or sets the Cascading Style Sheet (CSS) class for the values displayed in the row. All custom classes must be included in the skin's CSS file.
RowID | Gets or sets an ID for the row.
RowIndex | Gets or sets the row index.
Selected | Gets or sets a Boolean value that indicates whether the row is selected. Default value is false.
Visible | Gets or sets a value indicating whether the row is displayed. Default value is true.
VisibleByFilter | Gets a value indicating whether the row is visible after applying the filter.

See Also

GridRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Cells Property

GridRow.Cells Property

The collection of cells.

[Visual Basic]
Public ReadOnly Property Cells As GridCellCollection
[C#]
public GridCellCollection Cells {get;}

See Also

GridRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - CssClass Property

GridRow.CssClass Property

Gets or sets the Cascading Style Sheet (CSS) class for the values displayed in the row. All custom classes must be included in the skin's CSS file.

[Visual Basic]
Public Property CssClass As String
[C#]
public string CssClass {get; set;}

See Also

GridRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - RowID Property

GridRow.RowID Property

Gets or sets an ID for the row.

[Visual Basic]
Public Property RowID As String
[C#]
public string RowID {get; set;}

See Also

GridRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - RowIndex Property

GridRow.RowIndex Property

Gets or sets the row index.

[Visual Basic]
Public Property RowIndex As Integer
[C#]
public int RowIndex {get; set;}

See Also

GridRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Selected Property

GridRow.Selected Property

Gets or sets a Boolean value that indicates whether the row is selected. Default value is false.

[Visual Basic]
Public Property Selected As Boolean
[C#]
public bool Selected {get; set;}

See Also

GridRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Visible Property

GridRow.Visible Property

Gets or sets a value indicating whether the row is displayed. Default value is true.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

GridRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - VisibleByFilter Property

GridRow.VisibleByFilter Property

Gets a value indicating whether the row is visible after applying the filter.

[Visual Basic]
Public ReadOnly Property VisibleByFilter As Boolean
[C#]
public bool VisibleByFilter {get;}

See Also

GridRow Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridRowCollection Class

GridRowCollection Class

Represents the collection of grid rows.

For a list of all members of this type, see GridRowCollection Members.

System.Object
APNSoft.WebControls.GridRowCollection

[Visual Basic]
Public Class GridRowCollection
[C#]
public class GridRowCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

GridRowCollection Members | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridRowCollection Members

GridRowCollection Members

GridRowCollection overview

Public Instance Properties

Count | The number of rows in the collection.
CountVisible | The number of visible rows in the collection.
Item | Overloaded. Gets the specified GridRow from the collection.

See Also

GridRowCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - GridRowCollection Properties

GridRowCollection Properties

The properties of the GridRowCollection class are listed below. For a complete list of GridRowCollection class members, see the GridRowCollection Members topic.

Public Instance Properties

Count | The number of rows in the collection.
CountVisible | The number of visible rows in the collection.
Item | Overloaded. Gets the specified GridRow from the collection.

See Also

GridRowCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Count Property

GridRowCollection.Count Property

The number of rows in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}

See Also

GridRowCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - CountVisible Property

GridRowCollection.CountVisible Property

The number of visible rows in the collection.

[Visual Basic]
Public ReadOnly Property CountVisible As Integer
[C#]
public int CountVisible {get;}

See Also

GridRowCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Item Property

GridRowCollection.Item Property

Gets the specified GridRow from the collection.

Overload List

Gets the specified GridRow from the collection.

public virtual GridRow this[int] {get;}

Gets the specified GridRow from the collection.

public virtual GridRow this[string] {get;}

See Also

GridRowCollection Class | APNSoft.WebControls Namespace


ASP.NET DataGrid Control - Item Property (Int32)

GridRowCollection.Item Property (Int32)

Gets the specified GridRow from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As GridRow
[C#]
public virtual GridRow this[
int index
] {get;}

Parameters

index
Row index.

See Also

GridRowCollection Class | APNSoft.WebControls Namespace | GridRowCollection.Item Overload List


ASP.NET DataGrid Control - Item Property (String)

GridRowCollection.Item Property (String)

Gets the specified GridRow from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal ID As String _
) As GridRow
[C#]
public virtual GridRow this[
string ID
] {get;}

Parameters

ID
Row ID.

See Also

GridRowCollection Class | APNSoft.WebControls Namespace | GridRowCollection.Item Overload List


ASP.NET Include Control - IncludeEventArgs Class

IncludeEventArgs Class

Provides data for command events of the Include control.

For a list of all members of this type, see IncludeEventArgs Members.

System.Object
System.EventArgs
APNSoft.WebControls.IncludeEventArgs

[Visual Basic]
Public Class IncludeEventArgs
Inherits EventArgs
[C#]
public class IncludeEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

IncludeEventArgs Members | APNSoft.WebControls Namespace


ASP.NET Include Control - IncludeEventArgs Members

IncludeEventArgs Members

IncludeEventArgs overview

Public Instance Constructors

IncludeEventArgs Constructor Initializes a new instance of the IncludeEventArgs class.

Public Instance Fields

ComponentID | Gets the Include ID when the event is raised.
Contents | The contents of included file.

See Also

IncludeEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Include Control - IncludeEventArgs Constructor

IncludeEventArgs Constructor

Initializes a new instance of the IncludeEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public IncludeEventArgs();

See Also

IncludeEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Include Control - IncludeEventArgs Fields

IncludeEventArgs Fields

The fields of the IncludeEventArgs class are listed below. For a complete list of IncludeEventArgs class members, see the IncludeEventArgs Members topic.

Public Instance Fields

ComponentID | Gets the Include ID when the event is raised.
Contents | The contents of included file.

See Also

IncludeEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Include Control - IncludeEventArgs.ComponentID Field

IncludeEventArgs.ComponentID Field

Gets the Include ID when the event is raised.

[Visual Basic]
Public ComponentID As String
[C#]
public string ComponentID;

See Also

IncludeEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Include Control - IncludeEventArgs.Contents Field

IncludeEventArgs.Contents Field

The contents of included file.

[Visual Basic]
Public Contents As String
[C#]
public string Contents;

See Also

IncludeEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Include Control - IncludeEventHandler Delegate

IncludeEventHandler Delegate

Represents the method that will handle command events of an Include.

[Visual Basic]
Public Delegate Sub IncludeEventHandler( _
ByVal sender As Object, _
ByVal e As IncludeEventArgs _
)
[C#]
public delegate void IncludeEventHandler(
object sender,
IncludeEventArgs e
);

Parameters

sender
Include object that is considered as initiator of the event.
e
Event arguments of the IncludeEventArgs type.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement Class

MenuElement Class

Represents the part of a MenuElementCollection.

For a list of all members of this type, see MenuElement Members.

System.Object
APNSoft.WebControls.APNSoftElement
APNSoft.WebControls.MenuElement

[Visual Basic]
Public Class MenuElement
Inherits APNSoftElement
[C#]
public class MenuElement : APNSoftElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

MenuElement Members | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement Members

MenuElement Members

MenuElement overview

Public Instance Properties

AutoPostBackOnItemClick (inherited from APNSoftElement) | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
ChildElements | Gets all the child elements of the element.
ClientSideOnItemClick (inherited from APNSoftElement) | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
CSS_ItemHoveredTD | Gets or sets the name of the CSS class used for precise item customization. It is applied to the hovered item TD.
CSS_ItemSelectedTD | Gets or sets the name of the CSS class used for precise item customization. It is applied to the selected item TD.
CSS_ItemTD | Gets or sets the name of the CSS class used for precise item customization. It is applied to the item TD.
CSS_SeparatorTD | Gets or sets the name of the CSS class used for precise separator customization. It is applied to the separator TD.
CSS_SubMenuDIV | Gets or sets the name of the CSS class used for precise submenu customization. It is applied to the submenu DIV.
HasChildElements | Gets a value indicating whether this element has any child elements.
HasNextSibling | Gets a value indicating whether this element has a sibling element immediately following it.
HasParentElement | Gets a value indicating whether this element has parent element.
HasPreviousSibling | Gets a value indicating whether this element has a sibling element immediately preceding it.
href (inherited from APNSoftElement) | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon (inherited from APNSoftElement) | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight (inherited from APNSoftElement) | Gets or sets the pixel height of the item's icon.
iconOver | Gets or sets the name of the icon for hovered item.
iconWidth (inherited from APNSoftElement) | Gets or sets the pixel width of the item's icon.
id (inherited from APNSoftElement) | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
image | Gets or sets the name of the picture, used as one menu element.
imageHeight | Gets or sets the pixel height of the element image.
imageOver | Gets or sets the name of the picture, used for hovered item.
imageWidth | Gets or sets the pixel width of the element image.
NextSibling | Gets the element immediately following this element.
ParentElement | Gets the parent of this element (for elements that can have parents).
PreviousSibling | Gets the element immediately preceding this element.
roles | Gets or sets a collection of user roles that are associated with the Menu Element.
selected | Gets or sets a value indicating whether the item is selected. Default value is false.
SubMenuMarginLeft | Gets or sets the width of the left margin of the submenu.
SubMenuMarginTop | Gets or sets the width of the top margin of the submenu.
target (inherited from APNSoftElement) | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
Template | Gets or sets the path to the template file for the Element. The property value can be an absolute or relative URI.
title (inherited from APNSoftElement) | Gets or sets the text (caption) displayed for the item.
tooltip | Gets or sets the tooltip text for the menu item.
Type (inherited from APNSoftElement) | Gets or sets a type of the Element.

Public Instance Methods

AddChild | Overloaded. Adds a new element to the end of the list of child elements.
AddChildItem | Overloaded. Adds a new item to the end of the list of child elements.
AddChildSeparator | Overloaded. Adds a new separator to the end of the list of child elements.
AddSibling | Overloaded. Adds a new element as a sibling to the current element. New element is added after the current element.
AddSiblingItem | Overloaded. Adds a new item as a sibling to the current element. New item is added after the current element.
AddSiblingSeparator | Overloaded. Adds a new separator as a sibling to the current element. New separator is added after the current element.
Clone | Overloaded. Creates a duplicate of this element. Child elements are not duplicated.
CloneToParent | Overloaded. Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.
CloneToRoot | Overloaded. Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.
MoveBackward (inherited from APNSoftElement) | Moves the element backward by one position in the current element group.
MoveForward (inherited from APNSoftElement) | Moves the element forward by one position in the current element group.
MoveToParent | Moves the element to specified parent element.
MoveToRoot | Moves the element to the root.
Remove (inherited from APNSoftElement) | Removes specified element from the collection.
RemoveChilds | Removes child elements.

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement Properties

MenuElement Properties

The properties of the MenuElement class are listed below. For a complete list of MenuElement class members, see the MenuElement Members topic.

Public Instance Properties

AutoPostBackOnItemClick (inherited from APNSoftElement) | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
ChildElements | Gets all the child elements of the element.
ClientSideOnItemClick (inherited from APNSoftElement) | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
CSS_ItemHoveredTD | Gets or sets the name of the CSS class used for precise item customization. It is applied to the hovered item TD.
CSS_ItemSelectedTD | Gets or sets the name of the CSS class used for precise item customization. It is applied to the selected item TD.
CSS_ItemTD | Gets or sets the name of the CSS class used for precise item customization. It is applied to the item TD.
CSS_SeparatorTD | Gets or sets the name of the CSS class used for precise separator customization. It is applied to the separator TD.
CSS_SubMenuDIV | Gets or sets the name of the CSS class used for precise submenu customization. It is applied to the submenu DIV.
HasChildElements | Gets a value indicating whether this element has any child elements.
HasNextSibling | Gets a value indicating whether this element has a sibling element immediately following it.
HasParentElement | Gets a value indicating whether this element has parent element.
HasPreviousSibling | Gets a value indicating whether this element has a sibling element immediately preceding it.
href (inherited from APNSoftElement) | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon (inherited from APNSoftElement) | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight (inherited from APNSoftElement) | Gets or sets the pixel height of the item's icon.
iconOver | Gets or sets the name of the icon for hovered item.
iconWidth (inherited from APNSoftElement) | Gets or sets the pixel width of the item's icon.
id (inherited from APNSoftElement) | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
image | Gets or sets the name of the picture, used as one menu element.
imageHeight | Gets or sets the pixel height of the element image.
imageOver | Gets or sets the name of the picture, used for hovered item.
imageWidth | Gets or sets the pixel width of the element image.
NextSibling | Gets the element immediately following this element.
ParentElement | Gets the parent of this element (for elements that can have parents).
PreviousSibling | Gets the element immediately preceding this element.
roles | Gets or sets a collection of user roles that are associated with the Menu Element.
selected | Gets or sets a value indicating whether the item is selected. Default value is false.
SubMenuMarginLeft | Gets or sets the width of the left margin of the submenu.
SubMenuMarginTop | Gets or sets the width of the top margin of the submenu.
target (inherited from APNSoftElement) | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
Template | Gets or sets the path to the template file for the Element. The property value can be an absolute or relative URI.
title (inherited from APNSoftElement) | Gets or sets the text (caption) displayed for the item.
tooltip | Gets or sets the tooltip text for the menu item.
Type (inherited from APNSoftElement) | Gets or sets a type of the Element.

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - ChildElements Property

MenuElement.ChildElements Property

Gets all the child elements of the element.

[Visual Basic]
Public ReadOnly Property ChildElements As ArrayList
[C#]
public System.Collections.ArrayList ChildElements {get;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - CSS_ItemHoveredTD Property

MenuElement.CSS_ItemHoveredTD Property

Gets or sets the name of the CSS class used for precise item customization. It is applied to the hovered item TD.

[Visual Basic]
Public Property CSS_ItemHoveredTD As String
[C#]
public string CSS_ItemHoveredTD {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - CSS_ItemSelectedTD Property

MenuElement.CSS_ItemSelectedTD Property

Gets or sets the name of the CSS class used for precise item customization. It is applied to the selected item TD.

[Visual Basic]
Public Property CSS_ItemSelectedTD As String
[C#]
public string CSS_ItemSelectedTD {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - CSS_ItemTD Property

MenuElement.CSS_ItemTD Property

Gets or sets the name of the CSS class used for precise item customization. It is applied to the item TD.

[Visual Basic]
Public Property CSS_ItemTD As String
[C#]
public string CSS_ItemTD {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - CSS_SeparatorTD Property

MenuElement.CSS_SeparatorTD Property

Gets or sets the name of the CSS class used for precise separator customization. It is applied to the separator TD.

[Visual Basic]
Public Property CSS_SeparatorTD As String
[C#]
public string CSS_SeparatorTD {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - CSS_SubMenuDIV Property

MenuElement.CSS_SubMenuDIV Property

Gets or sets the name of the CSS class used for precise submenu customization. It is applied to the submenu DIV.

[Visual Basic]
Public Property CSS_SubMenuDIV As String
[C#]
public string CSS_SubMenuDIV {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - HasChildElements Property

MenuElement.HasChildElements Property

Gets a value indicating whether this element has any child elements.

[Visual Basic]
Public ReadOnly Property HasChildElements As Boolean
[C#]
public bool HasChildElements {get;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - HasNextSibling Property

MenuElement.HasNextSibling Property

Gets a value indicating whether this element has a sibling element immediately following it.

[Visual Basic]
Public ReadOnly Property HasNextSibling As Boolean
[C#]
public bool HasNextSibling {get;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - HasParentElement Property

MenuElement.HasParentElement Property

Gets a value indicating whether this element has parent element.

[Visual Basic]
Public ReadOnly Property HasParentElement As Boolean
[C#]
public bool HasParentElement {get;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - HasPreviousSibling Property

MenuElement.HasPreviousSibling Property

Gets a value indicating whether this element has a sibling element immediately preceding it.

[Visual Basic]
Public ReadOnly Property HasPreviousSibling As Boolean
[C#]
public bool HasPreviousSibling {get;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - iconOver Property

MenuElement.iconOver Property

Gets or sets the name of the icon for hovered item.

[Visual Basic]
Public Property iconOver As String
[C#]
public string iconOver {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - image Property

MenuElement.image Property

Gets or sets the name of the picture, used as one menu element.

[Visual Basic]
Public Property image As String
[C#]
public string image {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - imageHeight Property

MenuElement.imageHeight Property

Gets or sets the pixel height of the element image.

[Visual Basic]
Public Property imageHeight As Integer
[C#]
public int imageHeight {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - imageOver Property

MenuElement.imageOver Property

Gets or sets the name of the picture, used for hovered item.

[Visual Basic]
Public Property imageOver As String
[C#]
public string imageOver {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - imageWidth Property

MenuElement.imageWidth Property

Gets or sets the pixel width of the element image.

[Visual Basic]
Public Property imageWidth As Integer
[C#]
public int imageWidth {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - NextSibling Property

MenuElement.NextSibling Property

Gets the element immediately following this element.

[Visual Basic]
Public ReadOnly Property NextSibling As MenuElement
[C#]
public MenuElement NextSibling {get;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - ParentElement Property

MenuElement.ParentElement Property

Gets the parent of this element (for elements that can have parents).

[Visual Basic]
Public ReadOnly Property ParentElement As MenuElement
[C#]
public MenuElement ParentElement {get;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - PreviousSibling Property

MenuElement.PreviousSibling Property

Gets the element immediately preceding this element.

[Visual Basic]
Public ReadOnly Property PreviousSibling As MenuElement
[C#]
public MenuElement PreviousSibling {get;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - roles Property

MenuElement.roles Property

Gets or sets a collection of user roles that are associated with the Menu Element.

[Visual Basic]
Public Property roles As String
[C#]
public string roles {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - selected Property

MenuElement.selected Property

Gets or sets a value indicating whether the item is selected. Default value is false.

[Visual Basic]
Public Property selected As Boolean
[C#]
public bool selected {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - SubMenuMarginLeft Property

MenuElement.SubMenuMarginLeft Property

Gets or sets the width of the left margin of the submenu.

[Visual Basic]
Public Property SubMenuMarginLeft As Integer
[C#]
public int SubMenuMarginLeft {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - SubMenuMarginTop Property

MenuElement.SubMenuMarginTop Property

Gets or sets the width of the top margin of the submenu.

[Visual Basic]
Public Property SubMenuMarginTop As Integer
[C#]
public int SubMenuMarginTop {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - Template Property

MenuElement.Template Property

Gets or sets the path to the template file for the Element. The property value can be an absolute or relative URI.

[Visual Basic]
Public Property Template As String
[C#]
public string Template {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - tooltip Property

MenuElement.tooltip Property

Gets or sets the tooltip text for the menu item.

[Visual Basic]
Public Property tooltip As String
[C#]
public string tooltip {get; set;}

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement Methods

MenuElement Methods

The methods of the MenuElement class are listed below. For a complete list of MenuElement class members, see the MenuElement Members topic.

Public Instance Methods

AddChild | Overloaded. Adds a new element to the end of the list of child elements.
AddChildItem | Overloaded. Adds a new item to the end of the list of child elements.
AddChildSeparator | Overloaded. Adds a new separator to the end of the list of child elements.
AddSibling | Overloaded. Adds a new element as a sibling to the current element. New element is added after the current element.
AddSiblingItem | Overloaded. Adds a new item as a sibling to the current element. New item is added after the current element.
AddSiblingSeparator | Overloaded. Adds a new separator as a sibling to the current element. New separator is added after the current element.
Clone | Overloaded. Creates a duplicate of this element. Child elements are not duplicated.
CloneToParent | Overloaded. Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.
CloneToRoot | Overloaded. Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.
MoveBackward (inherited from APNSoftElement) | Moves the element backward by one position in the current element group.
MoveForward (inherited from APNSoftElement) | Moves the element forward by one position in the current element group.
MoveToParent | Moves the element to specified parent element.
MoveToRoot | Moves the element to the root.
Remove (inherited from APNSoftElement) | Removes specified element from the collection.
RemoveChilds | Removes child elements.

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - AddChild Method

MenuElement.AddChild Method

Adds a new element to the end of the list of child elements.

Overload List

Adds a new element to the end of the list of child elements.

public MenuElement AddChild(Types);

Adds a new element to the end of the list of child elements.

public MenuElement AddChild(string,Types);

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.AddChild Method (Types)

MenuElement.AddChild Method (Types)

Adds a new element to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChild( _
ByVal Type As Types _
) As MenuElement
[C#]
public MenuElement AddChild(
Types Type
);

Parameters

Type
Type of the new element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddChild Overload List


ASP.NET Menu Control - MenuElement.AddChild Method (String, Types)

MenuElement.AddChild Method (String, Types)

Adds a new element to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChild( _
ByVal NewID As String, _
ByVal Type As Types _
) As MenuElement
[C#]
public MenuElement AddChild(
string NewID,
Types Type
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.

Return Value

New element.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddChild Overload List


ASP.NET Menu Control - AddChildItem Method

MenuElement.AddChildItem Method

Adds a new item to the end of the list of child elements.

Overload List

Adds a new item to the end of the list of child elements.

public MenuElement AddChildItem(string);

Adds a new item to the end of the list of child elements.

public MenuElement AddChildItem(string,string);

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.AddChildItem Method (String)

MenuElement.AddChildItem Method (String)

Adds a new item to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChildItem( _
ByVal Title As String _
) As MenuElement
[C#]
public MenuElement AddChildItem(
string Title
);

Parameters

Title
The text (caption) displayed for the item.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddChildItem Overload List


ASP.NET Menu Control - MenuElement.AddChildItem Method (String, String)

MenuElement.AddChildItem Method (String, String)

Adds a new item to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChildItem( _
ByVal NewID As String, _
ByVal Title As String _
) As MenuElement
[C#]
public MenuElement AddChildItem(
string NewID,
string Title
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.

Return Value

New item element.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddChildItem Overload List


ASP.NET Menu Control - AddChildSeparator Method

MenuElement.AddChildSeparator Method

Adds a new separator to the end of the list of child elements.

Overload List

Adds a new separator to the end of the list of child elements.

public MenuElement AddChildSeparator();

Adds a new separator to the end of the list of child elements.

public MenuElement AddChildSeparator(string);

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.AddChildSeparator Method ()

MenuElement.AddChildSeparator Method ()

Adds a new separator to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChildSeparator() As MenuElement
[C#]
public MenuElement AddChildSeparator();

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddChildSeparator Overload List


ASP.NET Menu Control - MenuElement.AddChildSeparator Method (String)

MenuElement.AddChildSeparator Method (String)

Adds a new separator to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChildSeparator( _
ByVal NewID As String _
) As MenuElement
[C#]
public MenuElement AddChildSeparator(
string NewID
);

Parameters

NewID
ID of the new separator.

Return Value

New separator element.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddChildSeparator Overload List


ASP.NET Menu Control - AddSibling Method

MenuElement.AddSibling Method

Adds a new element as a sibling to the current element. New element is added after the current element.

Overload List

Adds a new element as a sibling to the current element. New element is added after the current element.

public MenuElement AddSibling(Types);

Adds a new element as a sibling to the current element. New element is added after the current element.

public MenuElement AddSibling(string,Types);

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.AddSibling Method (Types)

MenuElement.AddSibling Method (Types)

Adds a new element as a sibling to the current element. New element is added after the current element.

[Visual Basic]
Overloads Public Function AddSibling( _
ByVal Type As Types _
) As MenuElement
[C#]
public MenuElement AddSibling(
Types Type
);

Parameters

Type
Type of the new element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddSibling Overload List


ASP.NET Menu Control - MenuElement.AddSibling Method (String, Types)

MenuElement.AddSibling Method (String, Types)

Adds a new element as a sibling to the current element. New element is added after the current element.

[Visual Basic]
Overloads Public Function AddSibling( _
ByVal NewID As String, _
ByVal Type As Types _
) As MenuElement
[C#]
public MenuElement AddSibling(
string NewID,
Types Type
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.

Return Value

New element.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddSibling Overload List


ASP.NET Menu Control - AddSiblingItem Method

MenuElement.AddSiblingItem Method

Adds a new item as a sibling to the current element. New item is added after the current element.

Overload List

Adds a new item as a sibling to the current element. New item is added after the current element.

public MenuElement AddSiblingItem(string);

Adds a new item as a sibling to the current element. New item is added after the current element.

public MenuElement AddSiblingItem(string,string);

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.AddSiblingItem Method (String)

MenuElement.AddSiblingItem Method (String)

Adds a new item as a sibling to the current element. New item is added after the current element.

[Visual Basic]
Overloads Public Function AddSiblingItem( _
ByVal Title As String _
) As MenuElement
[C#]
public MenuElement AddSiblingItem(
string Title
);

Parameters

Title
The text (caption) displayed for the item.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddSiblingItem Overload List


ASP.NET Menu Control - MenuElement.AddSiblingItem Method (String, String)

MenuElement.AddSiblingItem Method (String, String)

Adds a new item as a sibling to the current element. New item is added after the current element.

[Visual Basic]
Overloads Public Function AddSiblingItem( _
ByVal NewID As String, _
ByVal Title As String _
) As MenuElement
[C#]
public MenuElement AddSiblingItem(
string NewID,
string Title
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.

Return Value

New item element.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddSiblingItem Overload List


ASP.NET Menu Control - AddSiblingSeparator Method

MenuElement.AddSiblingSeparator Method

Adds a new separator as a sibling to the current element. New separator is added after the current element.

Overload List

Adds a new separator as a sibling to the current element. New separator is added after the current element.

public MenuElement AddSiblingSeparator();

Adds a new separator as a sibling to the current element. New separator is added after the current element.

public MenuElement AddSiblingSeparator(string);

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.AddSiblingSeparator Method ()

MenuElement.AddSiblingSeparator Method ()

Adds a new separator as a sibling to the current element. New separator is added after the current element.

[Visual Basic]
Overloads Public Function AddSiblingSeparator() As MenuElement
[C#]
public MenuElement AddSiblingSeparator();

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddSiblingSeparator Overload List


ASP.NET Menu Control - MenuElement.AddSiblingSeparator Method (String)

MenuElement.AddSiblingSeparator Method (String)

Adds a new separator as a sibling to the current element. New separator is added after the current element.

[Visual Basic]
Overloads Public Function AddSiblingSeparator( _
ByVal NewID As String _
) As MenuElement
[C#]
public MenuElement AddSiblingSeparator(
string NewID
);

Parameters

NewID
ID of the new separator.

Return Value

New separator element.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.AddSiblingSeparator Overload List


ASP.NET Menu Control - Clone Method

MenuElement.Clone Method

Creates a duplicate of this element. Child elements are not duplicated.

Overload List

Creates a duplicate of this element. Child elements are not duplicated.

public MenuElement Clone();

Creates a duplicate of this element. Child elements are not duplicated.

public MenuElement Clone(string);

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.Clone Method ()

MenuElement.Clone Method ()

Creates a duplicate of this element. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function Clone() As MenuElement
[C#]
public MenuElement Clone();

Return Value

The cloned element.

Remarks

Element ID is generated automatically.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.Clone Overload List


ASP.NET Menu Control - MenuElement.Clone Method (String)

MenuElement.Clone Method (String)

Creates a duplicate of this element. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function Clone( _
ByVal NewID As String _
) As MenuElement
[C#]
public MenuElement Clone(
string NewID
);

Parameters

NewID
ID of the cloned element.

Return Value

The cloned element.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.Clone Overload List


ASP.NET Menu Control - CloneToParent Method

MenuElement.CloneToParent Method

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

Overload List

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

public MenuElement CloneToParent(string);

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

public MenuElement CloneToParent(string,string);

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.CloneToParent Method (String)

MenuElement.CloneToParent Method (String)

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function CloneToParent( _
ByVal ParentID As String _
) As MenuElement
[C#]
public MenuElement CloneToParent(
string ParentID
);

Parameters

ParentID
ID of the element that will be parent for cloned element.

Return Value

The cloned element.

Remarks

Element ID is generated automatically.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.CloneToParent Overload List


ASP.NET Menu Control - MenuElement.CloneToParent Method (String, String)

MenuElement.CloneToParent Method (String, String)

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function CloneToParent( _
ByVal NewID As String, _
ByVal ParentID As String _
) As MenuElement
[C#]
public MenuElement CloneToParent(
string NewID,
string ParentID
);

Parameters

NewID
ID of the cloned element.
ParentID
ID of the element that will be parent for cloned element.

Return Value

The cloned element.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.CloneToParent Overload List


ASP.NET Menu Control - CloneToRoot Method

MenuElement.CloneToRoot Method

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

Overload List

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

public MenuElement CloneToRoot();

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

public MenuElement CloneToRoot(string);

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.CloneToRoot Method ()

MenuElement.CloneToRoot Method ()

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function CloneToRoot() As MenuElement
[C#]
public MenuElement CloneToRoot();

Return Value

The cloned element.

Remarks

Element ID is generated automatically.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.CloneToRoot Overload List


ASP.NET Menu Control - MenuElement.CloneToRoot Method (String)

MenuElement.CloneToRoot Method (String)

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function CloneToRoot( _
ByVal NewID As String _
) As MenuElement
[C#]
public MenuElement CloneToRoot(
string NewID
);

Parameters

NewID
ID of the cloned element.

Return Value

The cloned element.

See Also

MenuElement Class | APNSoft.WebControls Namespace | MenuElement.CloneToRoot Overload List


ASP.NET Menu Control - MenuElement.MoveToParent Method

MenuElement.MoveToParent Method

Moves the element to specified parent element.

[Visual Basic]
Public Sub MoveToParent( _
ByVal ParentID As String _
)
[C#]
new public void MoveToParent(
string ParentID
);

Parameters

ParentID
ID of the parent element.

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.MoveToRoot Method

MenuElement.MoveToRoot Method

Moves the element to the root.

[Visual Basic]
Public Sub MoveToRoot()
[C#]
new public void MoveToRoot();

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElement.RemoveChilds Method

MenuElement.RemoveChilds Method

Removes child elements.

[Visual Basic]
Public Sub RemoveChilds()
[C#]
new public void RemoveChilds();

See Also

MenuElement Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElementCollection Class

MenuElementCollection Class

Represents the collection of elements.

For a list of all members of this type, see MenuElementCollection Members.

System.Object
APNSoft.WebControls.APNSoftElementCollection
APNSoft.WebControls.MenuElementCollection

[Visual Basic]
Public Class MenuElementCollection
Inherits APNSoftElementCollection
[C#]
public class MenuElementCollection : APNSoftElementCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

MenuElementCollection Members | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElementCollection Members

MenuElementCollection Members

MenuElementCollection overview

Public Instance Properties

Count (inherited from APNSoftElementCollection) | Gets the number of elements in the collection.
Item | Overloaded. Gets the specified MenuElement from the collection.

Public Instance Methods

AddChild | Overloaded. Adds a new child element to specified parent element.
AddChildItem | Overloaded. Adds a new child item to specified parent element.
AddChildSeparator | Overloaded. Adds a new child separator to specified parent element.
AddRootItem | Overloaded. Adds a new item to the root of collection.
AddRootSeparator | Overloaded. Adds a new separator to the root of collection.
AddToRoot | Overloaded. Adds a new element to the root of collection.
Clear (inherited from APNSoftElementCollection) | Removes all elements from the collection.
Contains (inherited from APNSoftElementCollection) | Determines whether an element is in the collection.
Init (inherited from APNSoftElementCollection) | Initializes the collection.
Remove (inherited from APNSoftElementCollection) | Removes a specific element from the collection.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElementCollection Properties

MenuElementCollection Properties

The properties of the MenuElementCollection class are listed below. For a complete list of MenuElementCollection class members, see the MenuElementCollection Members topic.

Public Instance Properties

Count (inherited from APNSoftElementCollection) | Gets the number of elements in the collection.
Item | Overloaded. Gets the specified MenuElement from the collection.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - Item Property

MenuElementCollection.Item Property

Gets the specified MenuElement from the collection.

Overload List

Gets the specified MenuElement from the collection.

public virtual MenuElement this[int] {get;}

Gets the specified MenuElement from the collection.

public virtual MenuElement this[string] {get;}

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - Item Property (Int32)

MenuElementCollection.Item Property (Int32)

Gets the specified MenuElement from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As MenuElement
[C#]
public virtual MenuElement this[
int index
] {get;}

Parameters

index
Element index.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.Item Overload List


ASP.NET Menu Control - Item Property (String)

MenuElementCollection.Item Property (String)

Gets the specified MenuElement from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal id As String _
) As MenuElement
[C#]
public virtual MenuElement this[
string id
] {get;}

Parameters

id
The string identifying the Element.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.Item Overload List


ASP.NET Menu Control - MenuElementCollection Methods

MenuElementCollection Methods

The methods of the MenuElementCollection class are listed below. For a complete list of MenuElementCollection class members, see the MenuElementCollection Members topic.

Public Instance Methods

AddChild | Overloaded. Adds a new child element to specified parent element.
AddChildItem | Overloaded. Adds a new child item to specified parent element.
AddChildSeparator | Overloaded. Adds a new child separator to specified parent element.
AddRootItem | Overloaded. Adds a new item to the root of collection.
AddRootSeparator | Overloaded. Adds a new separator to the root of collection.
AddToRoot | Overloaded. Adds a new element to the root of collection.
Clear (inherited from APNSoftElementCollection) | Removes all elements from the collection.
Contains (inherited from APNSoftElementCollection) | Determines whether an element is in the collection.
Init (inherited from APNSoftElementCollection) | Initializes the collection.
Remove (inherited from APNSoftElementCollection) | Removes a specific element from the collection.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - AddChild Method

MenuElementCollection.AddChild Method

Adds a new child element to specified parent element.

Overload List

Adds a new child element to specified parent element.

public MenuElement AddChild(Types,string);

Adds a new child element to specified parent element.

public MenuElement AddChild(string,Types,string);

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElementCollection.AddChild Method (Types, String)

MenuElementCollection.AddChild Method (Types, String)

Adds a new child element to specified parent element.

[Visual Basic]
Overloads Public Function AddChild( _
ByVal Type As Types, _
ByVal ParentID As String _
) As MenuElement
[C#]
public MenuElement AddChild(
Types Type,
string ParentID
);

Parameters

Type
Type of the new element.
ParentID
ID of the parent element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddChild Overload List


ASP.NET Menu Control - MenuElementCollection.AddChild Method (String, Types, String)

MenuElementCollection.AddChild Method (String, Types, String)

Adds a new child element to specified parent element.

[Visual Basic]
Overloads Public Function AddChild( _
ByVal NewID As String, _
ByVal Type As Types, _
ByVal ParentID As String _
) As MenuElement
[C#]
public MenuElement AddChild(
string NewID,
Types Type,
string ParentID
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.
ParentID
ID of the parent element.

Return Value

New element.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddChild Overload List


ASP.NET Menu Control - AddChildItem Method

MenuElementCollection.AddChildItem Method

Adds a new child item to specified parent element.

Overload List

Adds a new child item to specified parent element.

public MenuElement AddChildItem(string,string);

Adds a new child item to specified parent element.

public MenuElement AddChildItem(string,string,string);

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElementCollection.AddChildItem Method (String, String)

MenuElementCollection.AddChildItem Method (String, String)

Adds a new child item to specified parent element.

[Visual Basic]
Overloads Public Function AddChildItem( _
ByVal Title As String, _
ByVal ParentID As String _
) As MenuElement
[C#]
public MenuElement AddChildItem(
string Title,
string ParentID
);

Parameters

Title
The text (caption) displayed for the item.
ParentID
ID of the parent element.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddChildItem Overload List


ASP.NET Menu Control - MenuElementCollection.AddChildItem Method (String, String, String)

MenuElementCollection.AddChildItem Method (String, String, String)

Adds a new child item to specified parent element.

[Visual Basic]
Overloads Public Function AddChildItem( _
ByVal NewID As String, _
ByVal Title As String, _
ByVal ParentID As String _
) As MenuElement
[C#]
public MenuElement AddChildItem(
string NewID,
string Title,
string ParentID
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.
ParentID
ID of the parent element.

Return Value

New item element.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddChildItem Overload List


ASP.NET Menu Control - AddChildSeparator Method

MenuElementCollection.AddChildSeparator Method

Adds a new child separator to specified parent element.

Overload List

Adds a new child separator to specified parent element.

public MenuElement AddChildSeparator(string);

Adds a new child separator to specified parent element.

public MenuElement AddChildSeparator(string,string);

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElementCollection.AddChildSeparator Method (String)

MenuElementCollection.AddChildSeparator Method (String)

Adds a new child separator to specified parent element.

[Visual Basic]
Overloads Public Function AddChildSeparator( _
ByVal ParentID As String _
) As MenuElement
[C#]
public MenuElement AddChildSeparator(
string ParentID
);

Parameters

ParentID
ID of the parent element.

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddChildSeparator Overload List


ASP.NET Menu Control - MenuElementCollection.AddChildSeparator Method (String, String)

MenuElementCollection.AddChildSeparator Method (String, String)

Adds a new child separator to specified parent element.

[Visual Basic]
Overloads Public Function AddChildSeparator( _
ByVal NewID As String, _
ByVal ParentID As String _
) As MenuElement
[C#]
public MenuElement AddChildSeparator(
string NewID,
string ParentID
);

Parameters

NewID
ID of the new separator.
ParentID
ID of the parent element.

Return Value

New separator element.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddChildSeparator Overload List


ASP.NET Menu Control - AddRootItem Method

MenuElementCollection.AddRootItem Method

Adds a new item to the root of collection.

Overload List

Adds a new item to the root of collection.

public MenuElement AddRootItem(string);

Adds a new item to the root of collection.

public MenuElement AddRootItem(string,string);

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElementCollection.AddRootItem Method (String)

MenuElementCollection.AddRootItem Method (String)

Adds a new item to the root of collection.

[Visual Basic]
Overloads Public Function AddRootItem( _
ByVal Title As String _
) As MenuElement
[C#]
public MenuElement AddRootItem(
string Title
);

Parameters

Title
The text (caption) displayed for the item.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddRootItem Overload List


ASP.NET Menu Control - MenuElementCollection.AddRootItem Method (String, String)

MenuElementCollection.AddRootItem Method (String, String)

Adds a new item to the root of collection.

[Visual Basic]
Overloads Public Function AddRootItem( _
ByVal NewID As String, _
ByVal Title As String _
) As MenuElement
[C#]
public MenuElement AddRootItem(
string NewID,
string Title
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.

Return Value

New item element.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddRootItem Overload List


ASP.NET Menu Control - AddRootSeparator Method

MenuElementCollection.AddRootSeparator Method

Adds a new separator to the root of collection.

Overload List

Adds a new separator to the root of collection.

public MenuElement AddRootSeparator();

Adds a new separator to the root of collection.

public MenuElement AddRootSeparator(string);

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElementCollection.AddRootSeparator Method ()

MenuElementCollection.AddRootSeparator Method ()

Adds a new separator to the root of collection.

[Visual Basic]
Overloads Public Function AddRootSeparator() As MenuElement
[C#]
public MenuElement AddRootSeparator();

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddRootSeparator Overload List


ASP.NET Menu Control - MenuElementCollection.AddRootSeparator Method (String)

MenuElementCollection.AddRootSeparator Method (String)

Adds a new separator to the root of collection.

[Visual Basic]
Overloads Public Function AddRootSeparator( _
ByVal NewID As String _
) As MenuElement
[C#]
public MenuElement AddRootSeparator(
string NewID
);

Parameters

NewID
ID of the new separator.

Return Value

New separator element.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddRootSeparator Overload List


ASP.NET Menu Control - AddToRoot Method

MenuElementCollection.AddToRoot Method

Adds a new element to the root of collection.

Overload List

Adds a new element to the root of collection.

public MenuElement AddToRoot(Types);

Adds a new element to the root of collection.

public MenuElement AddToRoot(string,Types);

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuElementCollection.AddToRoot Method (Types)

MenuElementCollection.AddToRoot Method (Types)

Adds a new element to the root of collection.

[Visual Basic]
Overloads Public Function AddToRoot( _
ByVal Type As Types _
) As MenuElement
[C#]
public MenuElement AddToRoot(
Types Type
);

Parameters

Type
Type of the new element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddToRoot Overload List


ASP.NET Menu Control - MenuElementCollection.AddToRoot Method (String, Types)

MenuElementCollection.AddToRoot Method (String, Types)

Adds a new element to the root of collection.

[Visual Basic]
Overloads Public Function AddToRoot( _
ByVal NewID As String, _
ByVal Type As Types _
) As MenuElement
[C#]
public MenuElement AddToRoot(
string NewID,
Types Type
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.

Return Value

New element.

See Also

MenuElementCollection Class | APNSoft.WebControls Namespace | MenuElementCollection.AddToRoot Overload List


ASP.NET Menu Control - MenuEventArgs Class

MenuEventArgs Class

Provides data for command events of the Menu control.

For a list of all members of this type, see MenuEventArgs Members.

System.Object
System.EventArgs
APNSoft.WebControls.MenuEventArgs

[Visual Basic]
Public Class MenuEventArgs
Inherits EventArgs
[C#]
public class MenuEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

MenuEventArgs Members | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuEventArgs Members

MenuEventArgs Members

MenuEventArgs overview

Public Instance Constructors

MenuEventArgs Constructor Initializes a new instance of the MenuEventArgs class.

Public Instance Fields

ComponentID | Gets the Menu ID when the event is raised.
ItemID | Gets the ID of the referenced item in the Menu control when the event is raised.
MenuElement | Gets the referenced element in the Menu control when the event is raised.

See Also

MenuEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuEventArgs Constructor

MenuEventArgs Constructor

Initializes a new instance of the MenuEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public MenuEventArgs();

See Also

MenuEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuEventArgs Fields

MenuEventArgs Fields

The fields of the MenuEventArgs class are listed below. For a complete list of MenuEventArgs class members, see the MenuEventArgs Members topic.

Public Instance Fields

ComponentID | Gets the Menu ID when the event is raised.
ItemID | Gets the ID of the referenced item in the Menu control when the event is raised.
MenuElement | Gets the referenced element in the Menu control when the event is raised.

See Also

MenuEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuEventArgs.ComponentID Field

MenuEventArgs.ComponentID Field

Gets the Menu ID when the event is raised.

[Visual Basic]
Public ComponentID As String
[C#]
public string ComponentID;

See Also

MenuEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuEventArgs.ItemID Field

MenuEventArgs.ItemID Field

Gets the ID of the referenced item in the Menu control when the event is raised.

[Visual Basic]
Public ItemID As String
[C#]
public string ItemID;

See Also

MenuEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuEventArgs.MenuElement Field

MenuEventArgs.MenuElement Field

Gets the referenced element in the Menu control when the event is raised.

[Visual Basic]
Public MenuElement As MenuElement
[C#]
public MenuElement MenuElement;

See Also

MenuEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Menu Control - MenuEventHandler Delegate

MenuEventHandler Delegate

Represents the method that will handle command events of a Menu.

[Visual Basic]
Public Delegate Sub MenuEventHandler( _
ByVal sender As Object, _
ByVal e As MenuEventArgs _
)
[C#]
public delegate void MenuEventHandler(
object sender,
MenuEventArgs e
);

Parameters

sender
Menu object that is considered as initiator of the event.
e
Event arguments of the MenuEventArgs type.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventArgs Class

RatingEventArgs Class

Provides data for command events of the Rating control.

For a list of all members of this type, see RatingEventArgs Members.

System.Object
System.EventArgs
APNSoft.WebControls.RatingEventArgs

[Visual Basic]
Public Class RatingEventArgs
Inherits EventArgs
[C#]
public class RatingEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

RatingEventArgs Members | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventArgs Members

RatingEventArgs Members

RatingEventArgs overview

Public Instance Constructors

RatingEventArgs Constructor Initializes a new instance of the RatingEventArgs class.

Public Instance Fields

ComponentID | Gets the Rating ID when the event is raised.
RatingSegment | Gets the referenced segment in the Rating control when the event is raised.
SegmentID | Gets the ID of the selected segment in the Rating control when the event is raised.
SegmentValue | Gets the value of the selected segment in the Rating control when the event is raised.

Public Instance Properties

Parameter Gets or sets a value of parameter when the event is raised.

See Also

RatingEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventArgs Constructor

RatingEventArgs Constructor

Initializes a new instance of the RatingEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public RatingEventArgs();

See Also

RatingEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventArgs Fields

RatingEventArgs Fields

The fields of the RatingEventArgs class are listed below. For a complete list of RatingEventArgs class members, see the RatingEventArgs Members topic.

Public Instance Fields

ComponentID | Gets the Rating ID when the event is raised.
RatingSegment | Gets the referenced segment in the Rating control when the event is raised.
SegmentID | Gets the ID of the selected segment in the Rating control when the event is raised.
SegmentValue | Gets the value of the selected segment in the Rating control when the event is raised.

See Also

RatingEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventArgs.ComponentID Field

RatingEventArgs.ComponentID Field

Gets the Rating ID when the event is raised.

[Visual Basic]
Public ComponentID As String
[C#]
public string ComponentID;

See Also

RatingEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventArgs.RatingSegment Field

RatingEventArgs.RatingSegment Field

Gets the referenced segment in the Rating control when the event is raised.

[Visual Basic]
Public RatingSegment As RatingSegment
[C#]
public RatingSegment RatingSegment;

See Also

RatingEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventArgs.SegmentID Field

RatingEventArgs.SegmentID Field

Gets the ID of the selected segment in the Rating control when the event is raised.

[Visual Basic]
Public SegmentID As String
[C#]
public string SegmentID;

See Also

RatingEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventArgs.SegmentValue Field

RatingEventArgs.SegmentValue Field

Gets the value of the selected segment in the Rating control when the event is raised.

[Visual Basic]
Public SegmentValue As Integer
[C#]
public int SegmentValue;

See Also

RatingEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventArgs Properties

RatingEventArgs Properties

The properties of the RatingEventArgs class are listed below. For a complete list of RatingEventArgs class members, see the RatingEventArgs Members topic.

Public Instance Properties

Parameter Gets or sets a value of parameter when the event is raised.

See Also

RatingEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Parameter Property

RatingEventArgs.Parameter Property

Gets or sets a value of parameter when the event is raised.

[Visual Basic]
Public Property Parameter As String
[C#]
public string Parameter {get; set;}

See Also

RatingEventArgs Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingEventHandler Delegate

RatingEventHandler Delegate

Represents the method that will handle command events of a Rating.

[Visual Basic]
Public Delegate Sub RatingEventHandler( _
ByVal sender As Object, _
ByVal e As RatingEventArgs _
)
[C#]
public delegate void RatingEventHandler(
object sender,
RatingEventArgs e
);

Parameters

sender
The source of the event.
e
A RatingEventArgs than contains the event data.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingSegment Class

RatingSegment Class

Represents the part of a RatingSegmentCollection.

For a list of all members of this type, see RatingSegment Members.

System.Object
APNSoft.WebControls.APNSoftElement
APNSoft.WebControls.RatingSegment

[Visual Basic]
Public Class RatingSegment
Inherits APNSoftElement
[C#]
public class RatingSegment : APNSoftElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

RatingSegment Members | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingSegment Members

RatingSegment Members

RatingSegment overview

Public Instance Properties

AutoPostBackOnItemClick (inherited from APNSoftElement) | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
ClientSideOnItemClick (inherited from APNSoftElement) | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
HasNext | Gets a value indicating whether this segment has a segment immediately following it.
HasPrevious | Gets a value indicating whether this segment has a segment immediately preceding it.
href (inherited from APNSoftElement) | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon (inherited from APNSoftElement) | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight (inherited from APNSoftElement) | Gets or sets the pixel height of the item's icon.
iconWidth (inherited from APNSoftElement) | Gets or sets the pixel width of the item's icon.
id (inherited from APNSoftElement) | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
image | Gets or sets the name of the picture, used for segment.
imageActive | Gets or sets the name of the picture, used for active (hovered by mouse) segment.
imageDisabled | Gets or sets the name of the picture, used for disabled segment.
imageDisabledActive | Gets or sets the name of the picture, used for segment which is disabled and active.
selected | Gets or sets a value indicating whether the segment is selected. Default value is false.
target (inherited from APNSoftElement) | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
title (inherited from APNSoftElement) | Gets or sets the text (caption) displayed for the item.
Type (inherited from APNSoftElement) | Gets or sets a type of the Element.
value | Gets or sets the value of the segment.

Public Instance Methods

Add | Overloaded. Adds a new segment. New segment is added after the current segment.
MoveBackward (inherited from APNSoftElement) | Moves the element backward by one position in the current element group.
MoveForward (inherited from APNSoftElement) | Moves the element forward by one position in the current element group.
Remove (inherited from APNSoftElement) | Removes specified element from the collection.

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingSegment Properties

RatingSegment Properties

The properties of the RatingSegment class are listed below. For a complete list of RatingSegment class members, see the RatingSegment Members topic.

Public Instance Properties

AutoPostBackOnItemClick (inherited from APNSoftElement) | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
ClientSideOnItemClick (inherited from APNSoftElement) | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
HasNext | Gets a value indicating whether this segment has a segment immediately following it.
HasPrevious | Gets a value indicating whether this segment has a segment immediately preceding it.
href (inherited from APNSoftElement) | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon (inherited from APNSoftElement) | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight (inherited from APNSoftElement) | Gets or sets the pixel height of the item's icon.
iconWidth (inherited from APNSoftElement) | Gets or sets the pixel width of the item's icon.
id (inherited from APNSoftElement) | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
image | Gets or sets the name of the picture, used for segment.
imageActive | Gets or sets the name of the picture, used for active (hovered by mouse) segment.
imageDisabled | Gets or sets the name of the picture, used for disabled segment.
imageDisabledActive | Gets or sets the name of the picture, used for segment which is disabled and active.
selected | Gets or sets a value indicating whether the segment is selected. Default value is false.
target (inherited from APNSoftElement) | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
title (inherited from APNSoftElement) | Gets or sets the text (caption) displayed for the item.
Type (inherited from APNSoftElement) | Gets or sets a type of the Element.
value | Gets or sets the value of the segment.

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - HasNext Property

RatingSegment.HasNext Property

Gets a value indicating whether this segment has a segment immediately following it.

[Visual Basic]
Public ReadOnly Property HasNext As Boolean
[C#]
public bool HasNext {get;}

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - HasPrevious Property

RatingSegment.HasPrevious Property

Gets a value indicating whether this segment has a segment immediately preceding it.

[Visual Basic]
Public ReadOnly Property HasPrevious As Boolean
[C#]
public bool HasPrevious {get;}

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - image Property

RatingSegment.image Property

Gets or sets the name of the picture, used for segment.

[Visual Basic]
Public Property image As String
[C#]
public string image {get; set;}

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - imageActive Property

RatingSegment.imageActive Property

Gets or sets the name of the picture, used for active (hovered by mouse) segment.

[Visual Basic]
Public Property imageActive As String
[C#]
public string imageActive {get; set;}

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - imageDisabled Property

RatingSegment.imageDisabled Property

Gets or sets the name of the picture, used for disabled segment.

[Visual Basic]
Public Property imageDisabled As String
[C#]
public string imageDisabled {get; set;}

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - imageDisabledActive Property

RatingSegment.imageDisabledActive Property

Gets or sets the name of the picture, used for segment which is disabled and active.

[Visual Basic]
Public Property imageDisabledActive As String
[C#]
public string imageDisabledActive {get; set;}

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - selected Property

RatingSegment.selected Property

Gets or sets a value indicating whether the segment is selected. Default value is false.

[Visual Basic]
Public Property selected As Boolean
[C#]
public bool selected {get; set;}

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - value Property

RatingSegment.value Property

Gets or sets the value of the segment.

[Visual Basic]
Public Property value As Integer
[C#]
public int value {get; set;}

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingSegment Methods

RatingSegment Methods

The methods of the RatingSegment class are listed below. For a complete list of RatingSegment class members, see the RatingSegment Members topic.

Public Instance Methods

Add | Overloaded. Adds a new segment. New segment is added after the current segment.
MoveBackward (inherited from APNSoftElement) | Moves the element backward by one position in the current element group.
MoveForward (inherited from APNSoftElement) | Moves the element forward by one position in the current element group.
Remove (inherited from APNSoftElement) | Removes specified element from the collection.

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Add Method

RatingSegment.Add Method

Adds a new segment. New segment is added after the current segment.

Overload List

Adds a new segment. New segment is added after the current segment.

public RatingSegment Add(int);

Adds a new segment. New segment is added after the current segment.

public RatingSegment Add(string,int);

See Also

RatingSegment Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingSegment.Add Method (Int32)

RatingSegment.Add Method (Int32)

Adds a new segment. New segment is added after the current segment.

[Visual Basic]
Overloads Public Function Add( _
ByVal Value As Integer _
) As RatingSegment
[C#]
public RatingSegment Add(
int Value
);

Parameters

Value
Segment value.

Return Value

New segment.

Remarks

Segment ID is generated automatically.

See Also

RatingSegment Class | APNSoft.WebControls Namespace | RatingSegment.Add Overload List


ASP.NET Rating Control - RatingSegment.Add Method (String, Int32)

RatingSegment.Add Method (String, Int32)

Adds a new segment. New segment is added after the current segment.

[Visual Basic]
Overloads Public Function Add( _
ByVal NewID As String, _
ByVal Value As Integer _
) As RatingSegment
[C#]
public RatingSegment Add(
string NewID,
int Value
);

Parameters

NewID
ID of the new segment.
Value
Segment value.

Return Value

New segment.

See Also

RatingSegment Class | APNSoft.WebControls Namespace | RatingSegment.Add Overload List


ASP.NET Rating Control - RatingSegmentCollection Class

RatingSegmentCollection Class

Represents the collection of segments.

For a list of all members of this type, see RatingSegmentCollection Members.

System.Object
APNSoft.WebControls.APNSoftElementCollection
APNSoft.WebControls.RatingSegmentCollection

[Visual Basic]
Public Class RatingSegmentCollection
Inherits APNSoftElementCollection
[C#]
public class RatingSegmentCollection : APNSoftElementCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

RatingSegmentCollection Members | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingSegmentCollection Members

RatingSegmentCollection Members

RatingSegmentCollection overview

Public Instance Properties

Count (inherited from APNSoftElementCollection) | Gets the number of elements in the collection.
Item | Overloaded. Gets the specified RatingSegment from the collection.

Public Instance Methods

Add | Overloaded. Adds a new segment to the collection.
Clear (inherited from APNSoftElementCollection) | Removes all elements from the collection.
Contains (inherited from APNSoftElementCollection) | Determines whether an element is in the collection.
Init (inherited from APNSoftElementCollection) | Initializes the collection.
Remove (inherited from APNSoftElementCollection) | Removes a specific element from the collection.

See Also

RatingSegmentCollection Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingSegmentCollection Properties

RatingSegmentCollection Properties

The properties of the RatingSegmentCollection class are listed below. For a complete list of RatingSegmentCollection class members, see the RatingSegmentCollection Members topic.

Public Instance Properties

Count (inherited from APNSoftElementCollection) | Gets the number of elements in the collection.
Item | Overloaded. Gets the specified RatingSegment from the collection.

See Also

RatingSegmentCollection Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Item Property

RatingSegmentCollection.Item Property

Gets the specified RatingSegment from the collection.

Overload List

Gets the specified RatingSegment from the collection.

public virtual RatingSegment this[int] {get;}

Gets the specified RatingSegment from the collection.

public virtual RatingSegment this[string] {get;}

See Also

RatingSegmentCollection Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Item Property (Int32)

RatingSegmentCollection.Item Property (Int32)

Gets the specified RatingSegment from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As RatingSegment
[C#]
public virtual RatingSegment this[
int index
] {get;}

Parameters

index
Segment index.

See Also

RatingSegmentCollection Class | APNSoft.WebControls Namespace | RatingSegmentCollection.Item Overload List


ASP.NET Rating Control - Item Property (String)

RatingSegmentCollection.Item Property (String)

Gets the specified RatingSegment from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal id As String _
) As RatingSegment
[C#]
public virtual RatingSegment this[
string id
] {get;}

Parameters

id
The string identifying the Segment.

See Also

RatingSegmentCollection Class | APNSoft.WebControls Namespace | RatingSegmentCollection.Item Overload List


ASP.NET Rating Control - RatingSegmentCollection Methods

RatingSegmentCollection Methods

The methods of the RatingSegmentCollection class are listed below. For a complete list of RatingSegmentCollection class members, see the RatingSegmentCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a new segment to the collection.
Clear (inherited from APNSoftElementCollection) | Removes all elements from the collection.
Contains (inherited from APNSoftElementCollection) | Determines whether an element is in the collection.
Init (inherited from APNSoftElementCollection) | Initializes the collection.
Remove (inherited from APNSoftElementCollection) | Removes a specific element from the collection.

See Also

RatingSegmentCollection Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - Add Method

RatingSegmentCollection.Add Method

Adds a new segment to the collection.

Overload List

Adds a new segment to the collection.

public RatingSegment Add(int);

Adds a new segment to the collection.

public RatingSegment Add(string,int);

See Also

RatingSegmentCollection Class | APNSoft.WebControls Namespace


ASP.NET Rating Control - RatingSegmentCollection.Add Method (Int32)

RatingSegmentCollection.Add Method (Int32)

Adds a new segment to the collection.

[Visual Basic]
Overloads Public Function Add( _
ByVal Value As Integer _
) As RatingSegment
[C#]
public RatingSegment Add(
int Value
);

Parameters

Value
Segment value.

Return Value

New segment.

Remarks

Segment ID is generated automatically.

See Also

RatingSegmentCollection Class | APNSoft.WebControls Namespace | RatingSegmentCollection.Add Overload List


ASP.NET Rating Control - RatingSegmentCollection.Add Method (String, Int32)

RatingSegmentCollection.Add Method (String, Int32)

Adds a new segment to the collection.

[Visual Basic]
Overloads Public Function Add( _
ByVal NewID As String, _
ByVal Value As Integer _
) As RatingSegment
[C#]
public RatingSegment Add(
string NewID,
int Value
);

Parameters

NewID
ID of the new segment.
Value
Segment value.

Return Value

New segment.

See Also

RatingSegmentCollection Class | APNSoft.WebControls Namespace | RatingSegmentCollection.Add Overload List


ASP.NET TreeView Control - TreeViewElement Class

TreeViewElement Class

Represents the part of a TreeViewElementCollection.

For a list of all members of this type, see TreeViewElement Members.

System.Object
APNSoft.WebControls.APNSoftElement
APNSoft.WebControls.TreeViewElement

[Visual Basic]
Public Class TreeViewElement
Inherits APNSoftElement
[C#]
public class TreeViewElement : APNSoftElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

TreeViewElement Members | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement Members

TreeViewElement Members

TreeViewElement overview

Public Instance Properties

AutoPostBackOnItemClick (inherited from APNSoftElement) | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
Checked | Gets or sets a value indicating whether the item is checked. Default value is false.
ChildElements | Gets all the child elements of the element.
ClientSideOnItemClick (inherited from APNSoftElement) | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
HasChildElements | Gets a value indicating whether this element has any child elements.
HasNextSibling | Gets a value indicating whether this element has a sibling element immediately following it.
HasParentElement | Gets a value indicating whether this element has parent element.
HasPreviousSibling | Gets a value indicating whether this element has a sibling element immediately preceding it.
href (inherited from APNSoftElement) | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon (inherited from APNSoftElement) | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight (inherited from APNSoftElement) | Gets or sets the pixel height of the item's icon.
iconOpen | Gets or sets the name of the icon for expanded item.
iconWidth (inherited from APNSoftElement) | Gets or sets the pixel width of the item's icon.
id (inherited from APNSoftElement) | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
NextSibling | Gets the element immediately following this element.
opened | Gets or sets a value indicating whether the item is opened (expanded). Default value is false.
ParentElement | Gets the parent of this element (for elements that can have parents).
PreviousSibling | Gets the element immediately preceding this element.
selected | Gets or sets a value indicating whether the item is selected. Default value is false.
target (inherited from APNSoftElement) | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
Template | Gets or sets the path to the template file for the Element. The property value can be an absolute or relative URI.
title (inherited from APNSoftElement) | Gets or sets the text (caption) displayed for the item.
Type (inherited from APNSoftElement) | Gets or sets a type of the Element.

Public Instance Methods

AddChild | Overloaded. Adds a new element to the end of the list of child elements.
AddChildItem | Overloaded. Adds a new item to the end of the list of child elements.
AddChildSeparator | Overloaded. Adds a new separator to the end of the list of child elements.
AddSibling | Overloaded. Adds a new element as a sibling to the current element. New element is added after the current element.
AddSiblingItem | Overloaded. Adds a new item as a sibling to the current element. New item is added after the current element.
AddSiblingSeparator | Overloaded. Adds a new separator as a sibling to the current element. New separator is added after the current element.
Clone | Overloaded. Creates a duplicate of this element. Child elements are not duplicated.
CloneToParent | Overloaded. Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.
CloneToRoot | Overloaded. Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.
MoveBackward (inherited from APNSoftElement) | Moves the element backward by one position in the current element group.
MoveForward (inherited from APNSoftElement) | Moves the element forward by one position in the current element group.
MoveToParent | Moves the element to specified parent element.
MoveToRoot | Moves the element to the root.
Remove (inherited from APNSoftElement) | Removes specified element from the collection.
RemoveChilds | Removes child elements.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement Properties

TreeViewElement Properties

The properties of the TreeViewElement class are listed below. For a complete list of TreeViewElement class members, see the TreeViewElement Members topic.

Public Instance Properties

AutoPostBackOnItemClick (inherited from APNSoftElement) | Gets or sets a value indicating whether the control causes a postback to the server when the item is clicked.
Checked | Gets or sets a value indicating whether the item is checked. Default value is false.
ChildElements | Gets all the child elements of the element.
ClientSideOnItemClick (inherited from APNSoftElement) | Gets or sets the name of the client-side function to be called when an item is clicked. Can include variables $ComponentID$, $ItemID$ and $Title$. Each variable is replaced to the corresponding value.
HasChildElements | Gets a value indicating whether this element has any child elements.
HasNextSibling | Gets a value indicating whether this element has a sibling element immediately following it.
HasParentElement | Gets a value indicating whether this element has parent element.
HasPreviousSibling | Gets a value indicating whether this element has a sibling element immediately preceding it.
href (inherited from APNSoftElement) | Gets or sets URL the browser is directed to when a user clicks the item. Property value can include variables $ComponentID$, $ItemID$ and $Rnd$. Each variable is replaced to the corresponding value. The $Rnd$ displays a random number. It can be used as an additional parameter to avoid page caching in browser.
icon (inherited from APNSoftElement) | Gets or sets the name of the one item's icon image. The icon displayed at the left side of the item.
iconHeight (inherited from APNSoftElement) | Gets or sets the pixel height of the item's icon.
iconOpen | Gets or sets the name of the icon for expanded item.
iconWidth (inherited from APNSoftElement) | Gets or sets the pixel width of the item's icon.
id (inherited from APNSoftElement) | Gets or sets a value that identifies the Element. If the id attribute is not specified, the component will automatically set it for each Element.
NextSibling | Gets the element immediately following this element.
opened | Gets or sets a value indicating whether the item is opened (expanded). Default value is false.
ParentElement | Gets the parent of this element (for elements that can have parents).
PreviousSibling | Gets the element immediately preceding this element.
selected | Gets or sets a value indicating whether the item is selected. Default value is false.
target (inherited from APNSoftElement) | Gets or sets the target window or frame to load Web page content into when a user clicks the item.
Template | Gets or sets the path to the template file for the Element. The property value can be an absolute or relative URI.
title (inherited from APNSoftElement) | Gets or sets the text (caption) displayed for the item.
Type (inherited from APNSoftElement) | Gets or sets a type of the Element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - Checked Property

TreeViewElement.Checked Property

Gets or sets a value indicating whether the item is checked. Default value is false.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ChildElements Property

TreeViewElement.ChildElements Property

Gets all the child elements of the element.

[Visual Basic]
Public ReadOnly Property ChildElements As ArrayList
[C#]
public System.Collections.ArrayList ChildElements {get;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - HasChildElements Property

TreeViewElement.HasChildElements Property

Gets a value indicating whether this element has any child elements.

[Visual Basic]
Public ReadOnly Property HasChildElements As Boolean
[C#]
public bool HasChildElements {get;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - HasNextSibling Property

TreeViewElement.HasNextSibling Property

Gets a value indicating whether this element has a sibling element immediately following it.

[Visual Basic]
Public ReadOnly Property HasNextSibling As Boolean
[C#]
public bool HasNextSibling {get;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - HasParentElement Property

TreeViewElement.HasParentElement Property

Gets a value indicating whether this element has parent element.

[Visual Basic]
Public ReadOnly Property HasParentElement As Boolean
[C#]
public bool HasParentElement {get;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - HasPreviousSibling Property

TreeViewElement.HasPreviousSibling Property

Gets a value indicating whether this element has a sibling element immediately preceding it.

[Visual Basic]
Public ReadOnly Property HasPreviousSibling As Boolean
[C#]
public bool HasPreviousSibling {get;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - iconOpen Property

TreeViewElement.iconOpen Property

Gets or sets the name of the icon for expanded item.

[Visual Basic]
Public Property iconOpen As String
[C#]
public string iconOpen {get; set;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - NextSibling Property

TreeViewElement.NextSibling Property

Gets the element immediately following this element.

[Visual Basic]
Public ReadOnly Property NextSibling As TreeViewElement
[C#]
public TreeViewElement NextSibling {get;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - opened Property

TreeViewElement.opened Property

Gets or sets a value indicating whether the item is opened (expanded). Default value is false.

[Visual Basic]
Public Property opened As Boolean
[C#]
public bool opened {get; set;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - ParentElement Property

TreeViewElement.ParentElement Property

Gets the parent of this element (for elements that can have parents).

[Visual Basic]
Public ReadOnly Property ParentElement As TreeViewElement
[C#]
public TreeViewElement ParentElement {get;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - PreviousSibling Property

TreeViewElement.PreviousSibling Property

Gets the element immediately preceding this element.

[Visual Basic]
Public ReadOnly Property PreviousSibling As TreeViewElement
[C#]
public TreeViewElement PreviousSibling {get;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - selected Property

TreeViewElement.selected Property

Gets or sets a value indicating whether the item is selected. Default value is false.

[Visual Basic]
Public Property selected As Boolean
[C#]
public bool selected {get; set;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - Template Property

TreeViewElement.Template Property

Gets or sets the path to the template file for the Element. The property value can be an absolute or relative URI.

[Visual Basic]
Public Property Template As String
[C#]
public string Template {get; set;}

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement Methods

TreeViewElement Methods

The methods of the TreeViewElement class are listed below. For a complete list of TreeViewElement class members, see the TreeViewElement Members topic.

Public Instance Methods

AddChild | Overloaded. Adds a new element to the end of the list of child elements.
AddChildItem | Overloaded. Adds a new item to the end of the list of child elements.
AddChildSeparator | Overloaded. Adds a new separator to the end of the list of child elements.
AddSibling | Overloaded. Adds a new element as a sibling to the current element. New element is added after the current element.
AddSiblingItem | Overloaded. Adds a new item as a sibling to the current element. New item is added after the current element.
AddSiblingSeparator | Overloaded. Adds a new separator as a sibling to the current element. New separator is added after the current element.
Clone | Overloaded. Creates a duplicate of this element. Child elements are not duplicated.
CloneToParent | Overloaded. Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.
CloneToRoot | Overloaded. Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.
MoveBackward (inherited from APNSoftElement) | Moves the element backward by one position in the current element group.
MoveForward (inherited from APNSoftElement) | Moves the element forward by one position in the current element group.
MoveToParent | Moves the element to specified parent element.
MoveToRoot | Moves the element to the root.
Remove (inherited from APNSoftElement) | Removes specified element from the collection.
RemoveChilds | Removes child elements.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - AddChild Method

TreeViewElement.AddChild Method

Adds a new element to the end of the list of child elements.

Overload List

Adds a new element to the end of the list of child elements.

public TreeViewElement AddChild(Types);

Adds a new element to the end of the list of child elements.

public TreeViewElement AddChild(string,Types);

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.AddChild Method (Types)

TreeViewElement.AddChild Method (Types)

Adds a new element to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChild( _
ByVal Type As Types _
) As TreeViewElement
[C#]
public TreeViewElement AddChild(
Types Type
);

Parameters

Type
Type of the new element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddChild Overload List


ASP.NET TreeView Control - TreeViewElement.AddChild Method (String, Types)

TreeViewElement.AddChild Method (String, Types)

Adds a new element to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChild( _
ByVal NewID As String, _
ByVal Type As Types _
) As TreeViewElement
[C#]
public TreeViewElement AddChild(
string NewID,
Types Type
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.

Return Value

New element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddChild Overload List


ASP.NET TreeView Control - AddChildItem Method

TreeViewElement.AddChildItem Method

Adds a new item to the end of the list of child elements.

Overload List

Adds a new item to the end of the list of child elements.

public TreeViewElement AddChildItem(string);

Adds a new item to the end of the list of child elements.

public TreeViewElement AddChildItem(string,string);

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.AddChildItem Method (String)

TreeViewElement.AddChildItem Method (String)

Adds a new item to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChildItem( _
ByVal Title As String _
) As TreeViewElement
[C#]
public TreeViewElement AddChildItem(
string Title
);

Parameters

Title
The text (caption) displayed for the item.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddChildItem Overload List


ASP.NET TreeView Control - TreeViewElement.AddChildItem Method (String, String)

TreeViewElement.AddChildItem Method (String, String)

Adds a new item to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChildItem( _
ByVal NewID As String, _
ByVal Title As String _
) As TreeViewElement
[C#]
public TreeViewElement AddChildItem(
string NewID,
string Title
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.

Return Value

New item element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddChildItem Overload List


ASP.NET TreeView Control - AddChildSeparator Method

TreeViewElement.AddChildSeparator Method

Adds a new separator to the end of the list of child elements.

Overload List

Adds a new separator to the end of the list of child elements.

public TreeViewElement AddChildSeparator();

Adds a new separator to the end of the list of child elements.

public TreeViewElement AddChildSeparator(string);

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.AddChildSeparator Method ()

TreeViewElement.AddChildSeparator Method ()

Adds a new separator to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChildSeparator() As TreeViewElement
[C#]
public TreeViewElement AddChildSeparator();

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddChildSeparator Overload List


ASP.NET TreeView Control - TreeViewElement.AddChildSeparator Method (String)

TreeViewElement.AddChildSeparator Method (String)

Adds a new separator to the end of the list of child elements.

[Visual Basic]
Overloads Public Function AddChildSeparator( _
ByVal NewID As String _
) As TreeViewElement
[C#]
public TreeViewElement AddChildSeparator(
string NewID
);

Parameters

NewID
ID of the new separator.

Return Value

New separator element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddChildSeparator Overload List


ASP.NET TreeView Control - AddSibling Method

TreeViewElement.AddSibling Method

Adds a new element as a sibling to the current element. New element is added after the current element.

Overload List

Adds a new element as a sibling to the current element. New element is added after the current element.

public TreeViewElement AddSibling(Types);

Adds a new element as a sibling to the current element. New element is added after the current element.

public TreeViewElement AddSibling(string,Types);

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.AddSibling Method (Types)

TreeViewElement.AddSibling Method (Types)

Adds a new element as a sibling to the current element. New element is added after the current element.

[Visual Basic]
Overloads Public Function AddSibling( _
ByVal Type As Types _
) As TreeViewElement
[C#]
public TreeViewElement AddSibling(
Types Type
);

Parameters

Type
Type of the new element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddSibling Overload List


ASP.NET TreeView Control - TreeViewElement.AddSibling Method (String, Types)

TreeViewElement.AddSibling Method (String, Types)

Adds a new element as a sibling to the current element. New element is added after the current element.

[Visual Basic]
Overloads Public Function AddSibling( _
ByVal NewID As String, _
ByVal Type As Types _
) As TreeViewElement
[C#]
public TreeViewElement AddSibling(
string NewID,
Types Type
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.

Return Value

New element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddSibling Overload List


ASP.NET TreeView Control - AddSiblingItem Method

TreeViewElement.AddSiblingItem Method

Adds a new item as a sibling to the current element. New item is added after the current element.

Overload List

Adds a new item as a sibling to the current element. New item is added after the current element.

public TreeViewElement AddSiblingItem(string);

Adds a new item as a sibling to the current element. New item is added after the current element.

public TreeViewElement AddSiblingItem(string,string);

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.AddSiblingItem Method (String)

TreeViewElement.AddSiblingItem Method (String)

Adds a new item as a sibling to the current element. New item is added after the current element.

[Visual Basic]
Overloads Public Function AddSiblingItem( _
ByVal Title As String _
) As TreeViewElement
[C#]
public TreeViewElement AddSiblingItem(
string Title
);

Parameters

Title
The text (caption) displayed for the item.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddSiblingItem Overload List


ASP.NET TreeView Control - TreeViewElement.AddSiblingItem Method (String, String)

TreeViewElement.AddSiblingItem Method (String, String)

Adds a new item as a sibling to the current element. New item is added after the current element.

[Visual Basic]
Overloads Public Function AddSiblingItem( _
ByVal NewID As String, _
ByVal Title As String _
) As TreeViewElement
[C#]
public TreeViewElement AddSiblingItem(
string NewID,
string Title
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.

Return Value

New item element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddSiblingItem Overload List


ASP.NET TreeView Control - AddSiblingSeparator Method

TreeViewElement.AddSiblingSeparator Method

Adds a new separator as a sibling to the current element. New separator is added after the current element.

Overload List

Adds a new separator as a sibling to the current element. New separator is added after the current element.

public TreeViewElement AddSiblingSeparator();

Adds a new separator as a sibling to the current element. New separator is added after the current element.

public TreeViewElement AddSiblingSeparator(string);

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.AddSiblingSeparator Method ()

TreeViewElement.AddSiblingSeparator Method ()

Adds a new separator as a sibling to the current element. New separator is added after the current element.

[Visual Basic]
Overloads Public Function AddSiblingSeparator() As TreeViewElement
[C#]
public TreeViewElement AddSiblingSeparator();

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddSiblingSeparator Overload List


ASP.NET TreeView Control - TreeViewElement.AddSiblingSeparator Method (String)

TreeViewElement.AddSiblingSeparator Method (String)

Adds a new separator as a sibling to the current element. New separator is added after the current element.

[Visual Basic]
Overloads Public Function AddSiblingSeparator( _
ByVal NewID As String _
) As TreeViewElement
[C#]
public TreeViewElement AddSiblingSeparator(
string NewID
);

Parameters

NewID
ID of the new separator.

Return Value

New separator element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.AddSiblingSeparator Overload List


ASP.NET TreeView Control - Clone Method

TreeViewElement.Clone Method

Creates a duplicate of this element. Child elements are not duplicated.

Overload List

Creates a duplicate of this element. Child elements are not duplicated.

public TreeViewElement Clone();

Creates a duplicate of this element. Child elements are not duplicated.

public TreeViewElement Clone(string);

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.Clone Method ()

TreeViewElement.Clone Method ()

Creates a duplicate of this element. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function Clone() As TreeViewElement
[C#]
public TreeViewElement Clone();

Return Value

The cloned element.

Remarks

Element ID is generated automatically.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.Clone Overload List


ASP.NET TreeView Control - TreeViewElement.Clone Method (String)

TreeViewElement.Clone Method (String)

Creates a duplicate of this element. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function Clone( _
ByVal NewID As String _
) As TreeViewElement
[C#]
public TreeViewElement Clone(
string NewID
);

Parameters

NewID
ID of the cloned element.

Return Value

The cloned element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.Clone Overload List


ASP.NET TreeView Control - CloneToParent Method

TreeViewElement.CloneToParent Method

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

Overload List

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

public TreeViewElement CloneToParent(string);

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

public TreeViewElement CloneToParent(string,string);

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.CloneToParent Method (String)

TreeViewElement.CloneToParent Method (String)

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function CloneToParent( _
ByVal ParentID As String _
) As TreeViewElement
[C#]
public TreeViewElement CloneToParent(
string ParentID
);

Parameters

ParentID
ID of the element that will be parent for cloned element.

Return Value

The cloned element.

Remarks

Element ID is generated automatically.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.CloneToParent Overload List


ASP.NET TreeView Control - TreeViewElement.CloneToParent Method (String, String)

TreeViewElement.CloneToParent Method (String, String)

Creates a duplicate of this element. Inserts the duplicated element to specified parent element. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function CloneToParent( _
ByVal NewID As String, _
ByVal ParentID As String _
) As TreeViewElement
[C#]
public TreeViewElement CloneToParent(
string NewID,
string ParentID
);

Parameters

NewID
ID of the cloned element.
ParentID
ID of the element that will be parent for cloned element.

Return Value

The cloned element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.CloneToParent Overload List


ASP.NET TreeView Control - CloneToRoot Method

TreeViewElement.CloneToRoot Method

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

Overload List

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

public TreeViewElement CloneToRoot();

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

public TreeViewElement CloneToRoot(string);

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.CloneToRoot Method ()

TreeViewElement.CloneToRoot Method ()

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function CloneToRoot() As TreeViewElement
[C#]
public TreeViewElement CloneToRoot();

Return Value

The cloned element.

Remarks

Element ID is generated automatically.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.CloneToRoot Overload List


ASP.NET TreeView Control - TreeViewElement.CloneToRoot Method (String)

TreeViewElement.CloneToRoot Method (String)

Creates a duplicate of this element. Inserts the duplicated element to the root of collection. Child elements are not duplicated.

[Visual Basic]
Overloads Public Function CloneToRoot( _
ByVal NewID As String _
) As TreeViewElement
[C#]
public TreeViewElement CloneToRoot(
string NewID
);

Parameters

NewID
ID of the cloned element.

Return Value

The cloned element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace | TreeViewElement.CloneToRoot Overload List


ASP.NET TreeView Control - TreeViewElement.MoveToParent Method

TreeViewElement.MoveToParent Method

Moves the element to specified parent element.

[Visual Basic]
Public Sub MoveToParent( _
ByVal ParentID As String _
)
[C#]
new public void MoveToParent(
string ParentID
);

Parameters

ParentID
ID of the parent element.

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.MoveToRoot Method

TreeViewElement.MoveToRoot Method

Moves the element to the root.

[Visual Basic]
Public Sub MoveToRoot()
[C#]
new public void MoveToRoot();

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElement.RemoveChilds Method

TreeViewElement.RemoveChilds Method

Removes child elements.

[Visual Basic]
Public Sub RemoveChilds()
[C#]
new public void RemoveChilds();

See Also

TreeViewElement Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElementCollection Class

TreeViewElementCollection Class

Represents the collection of elements.

For a list of all members of this type, see TreeViewElementCollection Members.

System.Object
APNSoft.WebControls.APNSoftElementCollection
APNSoft.WebControls.TreeViewElementCollection

[Visual Basic]
Public Class TreeViewElementCollection
Inherits APNSoftElementCollection
[C#]
public class TreeViewElementCollection : APNSoftElementCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

TreeViewElementCollection Members | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElementCollection Members

TreeViewElementCollection Members

TreeViewElementCollection overview

Public Instance Properties

Count (inherited from APNSoftElementCollection) | Gets the number of elements in the collection.
Item | Overloaded. Gets the specified TreeViewElement from the collection.

Public Instance Methods

AddChild | Overloaded. Adds a new child element to specified parent element.
AddChildItem | Overloaded. Adds a new child item to specified parent element.
AddChildSeparator | Overloaded. Adds a new child separator to specified parent element.
AddRootItem | Overloaded. Adds a new item to the root of collection.
AddRootSeparator | Overloaded. Adds a new separator to the root of collection.
AddToRoot | Overloaded. Adds a new element to the root of collection.
Clear (inherited from APNSoftElementCollection) | Removes all elements from the collection.
Contains (inherited from APNSoftElementCollection) | Determines whether an element is in the collection.
Init (inherited from APNSoftElementCollection) | Initializes the collection.
Remove (inherited from APNSoftElementCollection) | Removes a specific element from the collection.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElementCollection Properties

TreeViewElementCollection Properties

The properties of the TreeViewElementCollection class are listed below. For a complete list of TreeViewElementCollection class members, see the TreeViewElementCollection Members topic.

Public Instance Properties

Count (inherited from APNSoftElementCollection) | Gets the number of elements in the collection.
Item | Overloaded. Gets the specified TreeViewElement from the collection.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - Item Property

TreeViewElementCollection.Item Property

Gets the specified TreeViewElement from the collection.

Overload List

Gets the specified TreeViewElement from the collection.

public virtual TreeViewElement this[int] {get;}

Gets the specified TreeViewElement from the collection.

public virtual TreeViewElement this[string] {get;}

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - Item Property (Int32)

TreeViewElementCollection.Item Property (Int32)

Gets the specified TreeViewElement from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As TreeViewElement
[C#]
public virtual TreeViewElement this[
int index
] {get;}

Parameters

index
Element index.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.Item Overload List


ASP.NET TreeView Control - Item Property (String)

TreeViewElementCollection.Item Property (String)

Gets the specified TreeViewElement from the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal id As String _
) As TreeViewElement
[C#]
public virtual TreeViewElement this[
string id
] {get;}

Parameters

id
The string identifying the Element.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.Item Overload List


ASP.NET TreeView Control - TreeViewElementCollection Methods

TreeViewElementCollection Methods

The methods of the TreeViewElementCollection class are listed below. For a complete list of TreeViewElementCollection class members, see the TreeViewElementCollection Members topic.

Public Instance Methods

AddChild | Overloaded. Adds a new child element to specified parent element.
AddChildItem | Overloaded. Adds a new child item to specified parent element.
AddChildSeparator | Overloaded. Adds a new child separator to specified parent element.
AddRootItem | Overloaded. Adds a new item to the root of collection.
AddRootSeparator | Overloaded. Adds a new separator to the root of collection.
AddToRoot | Overloaded. Adds a new element to the root of collection.
Clear (inherited from APNSoftElementCollection) | Removes all elements from the collection.
Contains (inherited from APNSoftElementCollection) | Determines whether an element is in the collection.
Init (inherited from APNSoftElementCollection) | Initializes the collection.
Remove (inherited from APNSoftElementCollection) | Removes a specific element from the collection.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - AddChild Method

TreeViewElementCollection.AddChild Method

Adds a new child element to specified parent element.

Overload List

Adds a new child element to specified parent element.

public TreeViewElement AddChild(Types,string);

Adds a new child element to specified parent element.

public TreeViewElement AddChild(string,Types,string);

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElementCollection.AddChild Method (Types, String)

TreeViewElementCollection.AddChild Method (Types, String)

Adds a new child element to specified parent element.

[Visual Basic]
Overloads Public Function AddChild( _
ByVal Type As Types, _
ByVal ParentID As String _
) As TreeViewElement
[C#]
public TreeViewElement AddChild(
Types Type,
string ParentID
);

Parameters

Type
Type of the new element.
ParentID
ID of the parent element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddChild Overload List


ASP.NET TreeView Control - TreeViewElementCollection.AddChild Method (String, Types, String)

TreeViewElementCollection.AddChild Method (String, Types, String)

Adds a new child element to specified parent element.

[Visual Basic]
Overloads Public Function AddChild( _
ByVal NewID As String, _
ByVal Type As Types, _
ByVal ParentID As String _
) As TreeViewElement
[C#]
public TreeViewElement AddChild(
string NewID,
Types Type,
string ParentID
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.
ParentID
ID of the parent element.

Return Value

New element.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddChild Overload List


ASP.NET TreeView Control - AddChildItem Method

TreeViewElementCollection.AddChildItem Method

Adds a new child item to specified parent element.

Overload List

Adds a new child item to specified parent element.

public TreeViewElement AddChildItem(string,string);

Adds a new child item to specified parent element.

public TreeViewElement AddChildItem(string,string,string);

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElementCollection.AddChildItem Method (String, String)

TreeViewElementCollection.AddChildItem Method (String, String)

Adds a new child item to specified parent element.

[Visual Basic]
Overloads Public Function AddChildItem( _
ByVal Title As String, _
ByVal ParentID As String _
) As TreeViewElement
[C#]
public TreeViewElement AddChildItem(
string Title,
string ParentID
);

Parameters

Title
The text (caption) displayed for the item.
ParentID
ID of the parent element.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddChildItem Overload List


ASP.NET TreeView Control - TreeViewElementCollection.AddChildItem Method (String, String, String)

TreeViewElementCollection.AddChildItem Method (String, String, String)

Adds a new child item to specified parent element.

[Visual Basic]
Overloads Public Function AddChildItem( _
ByVal NewID As String, _
ByVal Title As String, _
ByVal ParentID As String _
) As TreeViewElement
[C#]
public TreeViewElement AddChildItem(
string NewID,
string Title,
string ParentID
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.
ParentID
ID of the parent element.

Return Value

New item element.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddChildItem Overload List


ASP.NET TreeView Control - AddChildSeparator Method

TreeViewElementCollection.AddChildSeparator Method

Adds a new child separator to specified parent element.

Overload List

Adds a new child separator to specified parent element.

public TreeViewElement AddChildSeparator(string);

Adds a new child separator to specified parent element.

public TreeViewElement AddChildSeparator(string,string);

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElementCollection.AddChildSeparator Method (String)

TreeViewElementCollection.AddChildSeparator Method (String)

Adds a new child separator to specified parent element.

[Visual Basic]
Overloads Public Function AddChildSeparator( _
ByVal ParentID As String _
) As TreeViewElement
[C#]
public TreeViewElement AddChildSeparator(
string ParentID
);

Parameters

ParentID
ID of the parent element.

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddChildSeparator Overload List


ASP.NET TreeView Control - TreeViewElementCollection.AddChildSeparator Method (String, String)

TreeViewElementCollection.AddChildSeparator Method (String, String)

Adds a new child separator to specified parent element.

[Visual Basic]
Overloads Public Function AddChildSeparator( _
ByVal NewID As String, _
ByVal ParentID As String _
) As TreeViewElement
[C#]
public TreeViewElement AddChildSeparator(
string NewID,
string ParentID
);

Parameters

NewID
ID of the new separator.
ParentID
ID of the parent element.

Return Value

New separator element.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddChildSeparator Overload List


ASP.NET TreeView Control - AddRootItem Method

TreeViewElementCollection.AddRootItem Method

Adds a new item to the root of collection.

Overload List

Adds a new item to the root of collection.

public TreeViewElement AddRootItem(string);

Adds a new item to the root of collection.

public TreeViewElement AddRootItem(string,string);

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElementCollection.AddRootItem Method (String)

TreeViewElementCollection.AddRootItem Method (String)

Adds a new item to the root of collection.

[Visual Basic]
Overloads Public Function AddRootItem( _
ByVal Title As String _
) As TreeViewElement
[C#]
public TreeViewElement AddRootItem(
string Title
);

Parameters

Title
The text (caption) displayed for the item.

Return Value

New item element.

Remarks

Item ID is generated automatically.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddRootItem Overload List


ASP.NET TreeView Control - TreeViewElementCollection.AddRootItem Method (String, String)

TreeViewElementCollection.AddRootItem Method (String, String)

Adds a new item to the root of collection.

[Visual Basic]
Overloads Public Function AddRootItem( _
ByVal NewID As String, _
ByVal Title As String _
) As TreeViewElement
[C#]
public TreeViewElement AddRootItem(
string NewID,
string Title
);

Parameters

NewID
ID of the new item.
Title
The text (caption) displayed for the item.

Return Value

New item element.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddRootItem Overload List


ASP.NET TreeView Control - AddRootSeparator Method

TreeViewElementCollection.AddRootSeparator Method

Adds a new separator to the root of collection.

Overload List

Adds a new separator to the root of collection.

public TreeViewElement AddRootSeparator();

Adds a new separator to the root of collection.

public TreeViewElement AddRootSeparator(string);

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElementCollection.AddRootSeparator Method ()

TreeViewElementCollection.AddRootSeparator Method ()

Adds a new separator to the root of collection.

[Visual Basic]
Overloads Public Function AddRootSeparator() As TreeViewElement
[C#]
public TreeViewElement AddRootSeparator();

Return Value

New separator element.

Remarks

Separator ID is generated automatically.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddRootSeparator Overload List


ASP.NET TreeView Control - TreeViewElementCollection.AddRootSeparator Method (String)

TreeViewElementCollection.AddRootSeparator Method (String)

Adds a new separator to the root of collection.

[Visual Basic]
Overloads Public Function AddRootSeparator( _
ByVal NewID As String _
) As TreeViewElement
[C#]
public TreeViewElement AddRootSeparator(
string NewID
);

Parameters

NewID
ID of the new separator.

Return Value

New separator element.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddRootSeparator Overload List


ASP.NET TreeView Control - AddToRoot Method

TreeViewElementCollection.AddToRoot Method

Adds a new element to the root of collection.

Overload List

Adds a new element to the root of collection.

public TreeViewElement AddToRoot(Types);

Adds a new element to the root of collection.

public TreeViewElement AddToRoot(string,Types);

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewElementCollection.AddToRoot Method (Types)

TreeViewElementCollection.AddToRoot Method (Types)

Adds a new element to the root of collection.

[Visual Basic]
Overloads Public Function AddToRoot( _
ByVal Type As Types _
) As TreeViewElement
[C#]
public TreeViewElement AddToRoot(
Types Type
);

Parameters

Type
Type of the new element.

Return Value

New element.

Remarks

Element ID is generated automatically.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddToRoot Overload List


ASP.NET TreeView Control - TreeViewElementCollection.AddToRoot Method (String, Types)

TreeViewElementCollection.AddToRoot Method (String, Types)

Adds a new element to the root of collection.

[Visual Basic]
Overloads Public Function AddToRoot( _
ByVal NewID As String, _
ByVal Type As Types _
) As TreeViewElement
[C#]
public TreeViewElement AddToRoot(
string NewID,
Types Type
);

Parameters

NewID
ID of the new element.
Type
Type of the new element.

Return Value

New element.

See Also

TreeViewElementCollection Class | APNSoft.WebControls Namespace | TreeViewElementCollection.AddToRoot Overload List


ASP.NET TreeView Control - TreeViewEventArgs Class

TreeViewEventArgs Class

TreeView object arguments that received after post back.

For a list of all members of this type, see TreeViewEventArgs Members.

System.Object
System.EventArgs
APNSoft.WebControls.TreeViewEventArgs

[Visual Basic]
Public Class TreeViewEventArgs
Inherits EventArgs
[C#]
public class TreeViewEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

TreeViewEventArgs Members | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewEventArgs Members

TreeViewEventArgs Members

TreeViewEventArgs overview

Public Instance Constructors

TreeViewEventArgs Constructor Initializes a new instance of the TreeViewEventArgs class.

Public Instance Fields

ComponentID | Gets the TreeView ID when the event is raised.
ItemID | Gets the ID of the referenced item in the TreeView control when the event is raised.
TreeViewElement | Gets the referenced element in the TreeView control when the event is raised.

See Also

TreeViewEventArgs Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewEventArgs Constructor

TreeViewEventArgs Constructor

Initializes a new instance of the TreeViewEventArgs class.

[Visual Basic]
Public Sub New()
[C#]
public TreeViewEventArgs();

See Also

TreeViewEventArgs Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewEventArgs Fields

TreeViewEventArgs Fields

The fields of the TreeViewEventArgs class are listed below. For a complete list of TreeViewEventArgs class members, see the TreeViewEventArgs Members topic.

Public Instance Fields

ComponentID | Gets the TreeView ID when the event is raised.
ItemID | Gets the ID of the referenced item in the TreeView control when the event is raised.
TreeViewElement | Gets the referenced element in the TreeView control when the event is raised.

See Also

TreeViewEventArgs Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewEventArgs.ComponentID Field

TreeViewEventArgs.ComponentID Field

Gets the TreeView ID when the event is raised.

[Visual Basic]
Public ComponentID As String
[C#]
public string ComponentID;

See Also

TreeViewEventArgs Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewEventArgs.ItemID Field

TreeViewEventArgs.ItemID Field

Gets the ID of the referenced item in the TreeView control when the event is raised.

[Visual Basic]
Public ItemID As String
[C#]
public string ItemID;

See Also

TreeViewEventArgs Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewEventArgs.TreeViewElement Field

TreeViewEventArgs.TreeViewElement Field

Gets the referenced element in the TreeView control when the event is raised.

[Visual Basic]
Public TreeViewElement As TreeViewElement
[C#]
public TreeViewElement TreeViewElement;

See Also

TreeViewEventArgs Class | APNSoft.WebControls Namespace


ASP.NET TreeView Control - TreeViewEventHandler Delegate

TreeViewEventHandler Delegate

Represents the method that will handle command events of a TreeView.

[Visual Basic]
Public Delegate Sub TreeViewEventHandler( _
ByVal sender As Object, _
ByVal e As TreeViewEventArgs _
)
[C#]
public delegate void TreeViewEventHandler(
object sender,
TreeViewEventArgs e
);

Parameters

sender
TreeView object that is considered as initiator of the event.
e
Event arguments of the TreeViewEventArgs type.

Requirements

Namespace: APNSoft.WebControls

Assembly: APNSoftControls (in APNSoftControls.dll)

See Also

APNSoft.WebControls Namespace


ASP.NET Controls - License Agreement

APNSoft Controls [4.5.2.20]
License Agreement

This End-User License Agreement ("EULA") is a legal agreement between you, either a single end-user or a single entity, and APNSoft. By installing APNSoft Controls Suite and accompanying user documentation (the "SOFTWARE PRODUCT"), you are indicating your acceptance of all the terms and conditions of this EULA. If you do not agree to any of the terms or conditions of this EULA, do not install or use the SOFTWARE PRODUCT.

The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties.

  1. GRANT OF LICENSE

    This is a license agreement, and NOT an agreement for sale. APNSoft retains ownership of the copy of the SOFTWARE PRODUCT in your possession, and all copies you may be licensed to make. APNSoft retains all rights not expressly granted to you in this EULA. APNSoft hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE PRODUCT only as authorized below.

    • Free Trial License

      The License Key is NOT required. SOFTWARE PRODUCT automatically includes a Free Trial License. The Free Trial License does not expire; you may use SOFTWARE PRODUCT for free on an unlimited number of web sites. In this case, SOFTWARE PRODUCT renders a demo warning at random intervals.

    • Time-Limited License

      The License Key is required. You may use SOFTWARE PRODUCT for free on an unlimited number of web sites. No demo warning at random intervals. This type of license allows the immediate use of the product for 30 days. To obtain a Time-Limited License Key, contact support.

    • One Site License

      The License Key is required. Provides a license for use of SOFTWARE PRODUCT with a single web site or application. Only one copy of the main assembly is allowed in one Bin directory of a web application. SOFTWARE PRODUCT cannot be registered in the Global Assembly Cache.

    • Developer License

      The License Key is required. You are granted a license as a single developer (individual) to distribute the SOFTWARE PRODUCT royalty-free with an unlimited number of ASP.NET applications to an unlimited number of web servers, provided they are developed solely by you. At no time may the SOFTWARE PRODUCT be used by more than one individual at the same time for development purposes -- nor may the SOFTWARE PRODUCT be distributed for use with applications other than those developed by you.

      You are required to ensure that the SOFTWARE PRODUCT is not distributed in any form that allows it to be reused by any application other than that with which you distribute it. For example, if you install the SOFTWARE PRODUCT along with a packaged application on a customer's server, that customer is not permitted to use the SOFTWARE PRODUCT independent of your application.

    • Team License

      The License Key is required. The Team License provides the same unlimited, royalty-free development and distribution terms as the Developer License, but allows use by 5 developers in a single corporation or organization.

    • Source Code License

      The License Key is required. The Source Code License provides the same unlimited, royalty-free development and distribution terms as the Developer License, but allows use by 5 developers in a single corporation or organization. Developers are further licensed to view the Source Code of the SOFTWARE PRODUCT and modify it.

      For applications distributed outside of the licensed organization, you are required to ensure that the SOFTWARE PRODUCT is not distributed in any form that allows it to be reused by any application other than that with which you distribute it. For example, if you install the SOFTWARE PRODUCT along with a packaged application on a customer's server, that customer is not permitted to use the SOFTWARE PRODUCT independent of your application.

      Developers may only re-distribute the source code as part of a compiled solution that adds significant functionality to the SOFTWARE PRODUCT, and may not redistribute it in non-compiled form. Under no circumstances may the source code be used as the basis for creating a product that contains the same, or substantially the same, functionality as any APNSoft product.

    • Enterprise License

      The License Key is required. The Enterprise License provides the same terms as the Source Code License, but allows use by an unlimited number of developers in a single corporation or organization. Developers are further licensed to view the Source Code of the SOFTWARE PRODUCT and modify it.

    For All Licenses: In no case shall you rent, lease, lend, redistribute nor re-license the SOFTWARE PRODUCT or source code to a 3rd party individual or entity, except as outlined above. In no case shall you grant further redistribution rights for the SOFTWARE PRODUCT to the end-users of your solution.

  2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS

    Termination. Without prejudice to any other rights, APNSoft may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the SOFTWARE PRODUCT and all of its component parts, source code, associated documentation, and related materials.

  3. COPYRIGHT

    All title and copyrights in and to the SOFTWARE PRODUCT (including but not limited to any images, photographs, animations, video, audio, music, text, and "applets" incorporated into the SOFTWARE PRODUCT), the accompanying printed materials, and any copies of the SOFTWARE PRODUCT are owned by APNSoft. The SOFTWARE PRODUCT is protected by Lithuanian and U.S. copyright laws and international treaty provisions. Therefore, you must treat the SOFTWARE PRODUCT like any other copyrighted material.

  4. LIMITED WARRANTY

    No warranties. APNSoft expressly disclaims any warranty for the SOFTWARE PRODUCT. The SOFTWARE PRODUCT and any related documentation is provided "as is" without warranty of any kind, either express or implied, including, without limitation, the implied warranties of merchantability, fitness for a particular purpose, or non-infringement. The entire risk arising out of use or performance of the SOFTWARE PRODUCT remains with you.

  5. LIMITATION OF LIABILITY

    No liability for consequential damages. In no event shall APNSoft or its distributors be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use the SOFTWARE PRODUCT and related materials, even if APNSoft has been advised of the possibility of such damages. Because some states do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.


ASP.NET Controls - License Types

APNSoft Controls [4.5.2.20]
License Types

APNSoft offers the following license types:
  • Free Trial License

    The License Key is NOT required. APNSoft Controls Suite (the "SOFTWARE PRODUCT") automatically includes a Free Trial License. The Free Trial License does not expire; you may use SOFTWARE PRODUCT for free on an unlimited number of web sites. In this case, SOFTWARE PRODUCT renders a demo warning at random intervals.

  • Time-Limited License

    The License Key is required. You may use SOFTWARE PRODUCT for free on an unlimited number of web sites. No demo warning at random intervals. This type of license allows the immediate use of the product for 30 days. To obtain a Time-Limited License Key, contact support.

  • One Site License

    The License Key is required. Provides a license for use of SOFTWARE PRODUCT with a single web site or application. Only one copy of the main assembly is allowed in one Bin directory of a web application. SOFTWARE PRODUCT cannot be registered in the Global Assembly Cache.

  • Developer License

    The License Key is required. Provides a license for use of the SOFTWARE PRODUCT by a single user in the development of an unlimited number of applications, as well as unlimited, royalty-free distribution of the SOFTWARE PRODUCT with solutions built by that developer. Full featured product.

  • Team License

    The License Key is required. The Team License provides the same unlimited, royalty-free development and distribution terms as the Developer License, but allows use by 5 developers in a single corporation or organization. Full featured product.

  • Source Code License

    The License Key is required. The Source Code License provides the same unlimited, royalty-free development and distribution terms as the Developer License, but allows use by 5 developers in a single corporation or organization. Developers are further licensed to view the Source Code of the SOFTWARE PRODUCT and modify it. Full featured product.

  • Enterprise License

    The License Key is required. The Enterprise License provides the same terms as the Source Code License, but allows use by an unlimited number of developers in a single corporation or organization. Developers are further licensed to view the Source Code of the SOFTWARE PRODUCT and modify it. Full featured product.


ASP.NET Controls - License Key

APNSoft Controls [4.5.2.20]
License Key

If you use the Free Trial License, you are not required to obtain a License Key. In this case, the APNSoft Controls Suite renders a demo warning at random intervals.

To enable full functionality and register your copy of APNSoft Controls Suite you have to purchase a non-free license and set a License Key. After purchasing, you will receive the file named APNSoft_License.xml with your License Key and instructions how to set it up.

Setting License Key

The APNSoft_License.xml itself is an .xml file that contains the following:

<!--
License Key for APNSoft product(s).

Registered to: Registration Name, Company

Product(s):
DataGrid (Time-Limited License, expires on: December 31, 2011)
Menu (Developer License, subscription expires on: December 06, 2012)
TreeView (Developer License, subscription expires on: December 06, 2012)
...

Copyright (C) APNSoft. All rights reserved. Unauthorized copying prohibited!
http://www.apnsoft.com
-->

<license>
    <![CDATA[...]]>
</license>

To set the License Key, you must place the APNSoft_License.xml into the Bin directory of your web application. The main assembly file APNSoftControls.dll is also located in the Bin folder. That is all.


ASP.NET Controls - Subscription

APNSoft Controls [4.5.2.20]
Subscription

APNSoft Controls Suite is provided on a subscription basis. A subscription is a more flexible way to buy APNSoft products. You purchase products with your subscription and become eligible to use updates as long as your subscription remains active.

An APNSoft subscription comes with "perpetual" use rights-the ability to continue using the full-featured product after the subscription has expired. An expired subscriber can only use product that was available during the subscription term; all products released after the subscription expiration can be used only as trial software.

To determine the subscription's expiration date, see the content of your License Key. APNSoft notifies customers of updates by e-mail as they become available.


ASP.NET Controls - Time-Limited License

APNSoft Controls [4.5.2.20]
Time-Limited License

The Time-Limited License allows for the immediate use of the product for 30 days without demo warning. When the Time-Limited License expires, you will automatically revert to the Free Trial License.

To obtain a Time-Limited License Key, contact support. To determine the expiration date, see the content of your License Key.


ASP.NET Controls - Source Code

APNSoft Controls [4.5.2.20]
Source Code

The Source Code package includes complete Visual Studio 2005+ solutions (C#, XML, XSL, JS, image files, etc.) for APNSoft Controls Suite in one archive (ZIP format). Each solution is ready to be compiled into the main assembly APNSoftControls.dll, which can be used in your applications.

If you want to use the Source Code, you should purchase the Source Code License or Enterprise License. The Source Code is available only for full Suite (not for individual products - Menu, DataGrid, TreeView, etc.).


APNSoft - Support

APNSoft Controls [4.5.2.20]
Support

We offer free technical support to our customers and those interested in evaluating our products.

  1. Help Center

    Our Help Center is intended to provide an easy and quick way for users to find answers to most frequently asked questions (FAQs), or to give instructions concerning how to use the APNSoft products. Browse our easy-to-navigate knowledge base and find answers using the search option.

  2. Direct E-mail

    Our expert support staff is able to resolve most issues within a few hours, and we respond to all messages within two business days.

    General information: info@apnsoft.com
    Technical Support: support@apnsoft.com
    Sales questions: sales@apnsoft.com

(!) Your information will be kept strictly confidential. APNSoft will not share your information with any third party vendors or companies.


ASP.NET Control - APNSoftControl Hierarchy

APNSoftControl Hierarchy

System.Object
Control
WebControl
APNSoftControl
APNSoftComboBox
APNSoftDataGrid
APNSoftInclude
APNSoftMenu
APNSoftRating
APNSoftTreeView

See Also

APNSoftControl Class | APNSoftControl Members | APNSoft.WebControls Namespace


ASP.NET Control - APNSoft.WebControlsHierarchy

APNSoft.WebControls Hierarchy
System.Object
APNSoft.WebControls.APNSoftElement
APNSoft.WebControls.ComboBoxElement
APNSoft.WebControls.MenuElement
APNSoft.WebControls.RatingSegment
APNSoft.WebControls.TreeViewElement
APNSoft.WebControls.APNSoftElementCollection
APNSoft.WebControls.ComboBoxElementCollection
APNSoft.WebControls.MenuElementCollection
APNSoft.WebControls.RatingSegmentCollection
APNSoft.WebControls.TreeViewElementCollection
APNSoft.WebControls.GridBottomBar
APNSoft.WebControls.GridCell
APNSoft.WebControls.GridCellCollection
APNSoft.WebControls.GridColumn
APNSoft.WebControls.GridColumnCollection
APNSoft.WebControls.GridContextMenuHeader
APNSoft.WebControls.GridContextMenuRow
APNSoft.WebControls.GridEditForm
APNSoft.WebControls.GridRow
APNSoft.WebControls.GridRowCollection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
APNSoft.WebControls.ComboBoxEventHandler
APNSoft.WebControls.DataGridEventHandler
APNSoft.WebControls.IncludeEventHandler
APNSoft.WebControls.MenuEventHandler
APNSoft.WebControls.RatingEventHandler
APNSoft.WebControls.TreeViewEventHandler
System.EventArgs
APNSoft.WebControls.ComboBoxEventArgs
APNSoft.WebControls.DataGridEventArgs
APNSoft.WebControls.IncludeEventArgs
APNSoft.WebControls.MenuEventArgs
APNSoft.WebControls.RatingEventArgs
APNSoft.WebControls.TreeViewEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
APNSoft.WebControls.APNSoftComboBox.ListCloseValues
APNSoft.WebControls.APNSoftComboBox.ListOpenValues
APNSoft.WebControls.APNSoftControl.CSSSourceValues
APNSoft.WebControls.APNSoftControl.PositionValues
APNSoft.WebControls.APNSoftDataGrid.AutoResizeValues
APNSoft.WebControls.APNSoftDataGrid.EditFormMethodValues
APNSoft.WebControls.APNSoftDataGrid.ModeValues
APNSoft.WebControls.APNSoftElement.Types
APNSoft.WebControls.APNSoftMenu.ExpandDirectionHorizontalValues
APNSoft.WebControls.APNSoftMenu.ExpandDirectionVerticalValues
APNSoft.WebControls.APNSoftMenu.OrientationValues
APNSoft.WebControls.APNSoftMenu.SubMenusCloseValues
APNSoft.WebControls.APNSoftMenu.SubMenusOpenValues
APNSoft.WebControls.APNSoftRating.DirectionValues
APNSoft.WebControls.APNSoftRating.OrientationValues
APNSoft.WebControls.GridColumn.FormatOrderValues
APNSoft.WebControls.GridColumn.SortedValues
APNSoft.WebControls.GridEditForm.PositionValues
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IControlBuilderAccessor, System.Web.UI.IControlDesignerAccessor, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IExpressionsAccessor, System.Web.UI.IParserAccessor, System.Web.UI.IUrlResolutionService
System.Web.UI.WebControls.WebControl ---- System.Web.UI.IAttributeAccessor
APNSoft.WebControls.APNSoftControl
APNSoft.WebControls.APNSoftComboBox ---- System.Web.UI.IPostBackEventHandler
APNSoft.WebControls.APNSoftDataGrid ---- System.Web.UI.ICallbackEventHandler, System.Web.UI.IPostBackEventHandler
APNSoft.WebControls.APNSoftInclude
APNSoft.WebControls.APNSoftMenu ---- System.Web.UI.ICallbackEventHandler, System.Web.UI.IPostBackEventHandler
APNSoft.WebControls.APNSoftRating ---- System.Web.UI.ICallbackEventHandler, System.Web.UI.IPostBackEventHandler
APNSoft.WebControls.APNSoftTreeView ---- System.Web.UI.ICallbackEventHandler, System.Web.UI.IPostBackEventHandler

See Also

APNSoft.WebControls Namespace